Poor video quality (also screen sharing) after updating

Hi, jitsi community!

I have deployed a jitsi meet on my local server and it can work normally. And the video quality is ok (keep HD status), but I recently updated it from github, and now I find that the video quality (including screen sharing) is very poor (maybe only 320*180).

I also find that if my client (browser) and server are located in the same local area network (LAN), the video quality is the same as before. When the client is not in the same LAN, the video quality between participants will become very poor. But the video quality of jitsi official site is ok.

After testing different versions, I found that the version before August ( ab1c016

Compare) is ok.

I also noticed that there were several discussions about poor video quality, but I did not figure out how to use the results of these discussions. These solutions seem to be related to the configuration of something about websocket or p2p ? I found such error in my browser console:

Is this related to the problem?

p.s. My deployment is installed jisti-meet through running apt on ubuntu20.04, and then change the nginx 's config file to the path of code git clone from github repo. (Follow [How to] How to build Jitsi Meet from source: A developer’s guide - Developers - Jitsi Community Forum - developers & users)

So… How I can improve the video quality as before, what config need to be updated? Thanks a lot!

I am having the exact some issue. Also using Ubuntu. I have tried many different configuration settings to get everything to work as expected. By disabling simulcast (disableSimulcast: true) and disabling unified on Chrome (enableUnifiedOnChrome: false) I have managed to fix screen sharing quality issues, but now a new issue where participants are getting kicked out when sharing their screen has come up. I adjusted the preferred screen resolutions using the constraints config setting:

constraints: {
        video: {
            height: {
                ideal: 1080,
                max: 1080,
                min: 480
            width: {
                ideal: 1920,
                max: 1920,
                min: 848

But this is still not a perfect solution, as it only seems to help some of the time (other times the video is still blurry).

At this point, I am planning to revert back to an older release in order to avoid these issues for now (from my testing, 2.0.5963 would work best). But I would also love to know why this is happening and whether it will be fixed in a future release (and why I am also not getting these issues on the main Jitsi site; I have tried matching their exact config settings, and I am still having the same issues).

Any advice for how to get around these issues without reverting the code to a previous release would be appreciated as well.

Seems like bridge websocket is not properly configured in your deployment. Is your JVB hosted on the same server with Jitsi Meet? Do you have multiple JVBs?

Are you also seeing websocket errors in your js console? Give more details about how you installed Jitsi and what version you are currently running.

Are you also seeing websocket errors in your js console? Give more details about how you installed Jitsi and what version you are currently running.
Yes. I am seeing the same errors in the console log:
[modules/RTC/BridgeChannel.js] <WebSocket.e.onclose>: Channel closed: 1006

I installed Jitsi using the exact steps in the self-hosting guide:

I am currently running Jitsi 2.0.6433-1 on a Debian 10 (buster) server. (I also have a test server that is running into the same issues which is running on Ubuntu 20.04.3 LTS). My prosody, turnserver, web, and web-config projects are all on version 1.0.5415-1 and my videobridge-2 is on version 2.1-570-gb802be83-1).

Please let me know if there is any other useful information I can provide regarding this.

To be sure, you don’t have an additional JVB server, right?

To be sure, you don’t have an additional JVB server, right?

From the other posts I’ve read I assume JVB stands for jitsi-videobridge2 (sorry if it doesn’t, I’m new here). No, we do not. We run JVB on the same server and we only have the single server (we are not running multiple JVB servers).

Maybe the old configs cause the issue. You may try purging all related packages and reinstall them.

I did not change the JVB configuration, and I just executed the commands given in the website Self-Hosting Guide - Debian/Ubuntu server · Jitsi Meet Handbook in the shell.
The above is the content of jitsi-meet in my /usr/share/ directory, I didn’s change them…

Yeah. I just install it using sudo apt install jitsi-meet, and change the nginx config to the code from github repo. I did not change the installation directory… And this is my only server.

The installation script configures nginx as part of the process, you don’t need to do it yourself, if everything’s on the same server. Sounds like you might have some misconfiguration in your nginx. If you don’t mind uninstalling and reinstalling, that would be my suggestion at this point, just to make sure you have a completely clean installation.

Ok, I’m going to try to reinstall it.

@emrah the uninstall and reinstall appears to have worked! All of the console log errors are now gone. I will run some tests to see if the video streams are the high quality they were before the recent updates. Thank you for your helpful suggestion! I’m hoping this was the final fix I needed!

@qw_gao please be advised, I ran into one issue when uninstalling and reinstalling the Jitsi packages: nginx was not working properly. You can check the status after you uninstall and reinstall using:
sudo service nginx status
Also it was clearly broken because, as soon as I tried to connect two people to a meeting, both participants immediately disconnected). Throughout the weekend I was trying to figure out how to fix this, trying many steps and then undoing each of those steps, as most did not work. I eventually found an article within the Jitsi forums which recommended moving the 60-jitsi-meet.conf file from /etc/nginx/modules-enabled/ to /etc/nginx/modules-available. As soon as I did this and stopped/started (restart wasn’t working because it was inactive) nginx, everything started working as expected. You can do both of these things using the console lines below:
sudo mv /etc/nginx/modules-enabled/60-jitsi-meet.conf /etc/nginx/modules-available
sudo service nginx stop
sudo service nginx start

Also, if you have any questions about the process I went through uninstall and reinstall everything please let me know. I am happy to help in any way that I can.

This issue is now better, but is still not consistently good. Essentially, in some meetings (but not all) our video streams are extremely low quality. I have run speed tests and tried switching to meet.jit.si to confirm that the connection speeds are not the problem. I am glad that I uninstalled and reinstalled all of the Jitsi software, as it appears to have gotten rid of the errors I was receiving before, but there video quality is still an issue and appears to be more common in p2p meetings than in group settings.

I am open to suggestions. I saw a new stable release came out on Monday, so my first plan is to upgrade my test server to that and see if that helps the video quality. If it does not, my next step is to try adjusting the configuration settings (I adjusted them a bit before this post and was able to improve the likelihood of a good stream, but was not able to do this consistently; I wonder if the settings I changed are now having a negative impact on the video streams now that the errors have been resolved).

After these two steps, my next plan was to roll back to the June release (2.0.5963). However, I see that breakout rooms was just added to Jitsi Meet. This is a feature we have been waiting on and are excited to include in our solution, so it is much preferred to move forward and be able to include that than to step back and try a previous build.

I am saying all of this here for anyone else who is running into this issue, as well as requesting feedback from others for other suggestions on things to look at and try as I am troubleshooting this.

I will try to keep this updated as I continue to try and find a solution to this problem.

Thanks for your focus.
Now I have updated jitsi meet to the latest version (Dec,2021). While when I used it for the first time, I found that the second participant could not join a conference. This may related to this discussion: Room crashes when anyone trys to join.
Then I followed the solution in above discussion, and it works normally (video quality is excellent!). I think my trouble is about jvb config and prosody.

So I list my operating steps (just this comment):

  1. open /etc/jitsi/videobridge/config and find the JVB_SECRET, if not exist, you can set it by yourself (maybe). And add config: JVB_OPTS="--apis=xmpp,rest",JVB_HOST=your.jitsimeet.com (the same as my jvb_hostname);

  2. edit /etc/prosody/conf.d/your.site.cfg.lua, add a component:

    Component “jitsi-videobridge.your.jitsimeet.com”
           component_secret = "JVB_SECRET"  #(a string get from step 1)
  3. restart the jitsi-videobridge and prosody.

Hope the above can help you more!