Please, update the documentation or am I missing something?

Hello, can we have an updated documentation ?

I’m trying to follow the scalable setup, I have installed my Jitsi Meet instance without videobridge but on some part the documentation talk about configuration file path that is not present.

You will need to adapt the following files (see the files in example-config-files/scalable)

  • /etc/jitsi/jicofo/config (hostname, jicofo_secret, jicofo_password)
  • /etc/jitsi/jicofo/sip-communicator.properties (hostname)

There is no /etc/jitsi/jicofo/sip-communicator.properties file on the Jitsi Meet host.

It is present on /etc/jitsi/videobridge/sip-communicator.properties on the videobridge host.

You will need to adapt the following files (see the files in example-config-files/scalable)

Where is the example ? How can I link my video bridge with the jitsi meet ?
The link returns me a 404 error page.

It seem hard to fine good explanation on how to set up the Scalable setup.

I’m looking to deploy in private LAN environment:

  • HA setup of Jitsi Meet
  • Scalable and Loadbalanced setup of Jitsi Video Bridge
  • Loadbalance the conference on all Jitsi Video Bridge (with OCTO I presume)

Thank you !

1 Like

Create a simple deployment installing jitsi-meet, make sure it works and use those configurations.

When you say use those configurations, what are you referring ? Everything is already in the configuration files or I just need to copy configuration on a new nodeand it will link the JVB ?

I already have a single node installed with the quick install. But it seems there is no clear documentation on how to setup Multi node Jitsi Meet / Multi node VideoBridge.

I have for now:

1 Jitsi Meet node ready (without JVB)
1 Jitsi Video Bridge ready

But what configuration files I need to change to link the JVB to Jitsi Meet ?

Is it those file I need to change ?

on Jitsi Meet: /etc/jitsi/jicofo/config
on Jitsi Video Bridge: /etc/jitsi/videobridge/sip-communicator.properties

I need to update nickname and password accordingly ?

I followed this tutorial, but I still can’t use the external JVB. I added those line below on the sip-communicator.properties because i’m in a private LAN:

org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=10.5.5.6
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=10.5.5.6
org.jitsi.jicofo.auth.URL=XMPP:lbmeet.company.lan
org.jitsi.videobridge.DISABLE_TCP_HARVESTER=true
org.jitsi.videobridge.xmpp.user.shard.DISABLE_CERTIFICATE_VERIFICATION=true

I can’t create meetings with 2+ people, it kick me out, so the JVB is not used.

In the tutorial, it says that the server-id must be int the websocets block on all JVB but not the main JVB located on the JMS.

I thought in a scalable setup, we do not need to have JVB on the JMS ? The official documentation tells me to do this setup and the community tells me the other way.

How the JMS can redirect conference traffic on my external JVB ?
I do not have any configuration that tell JMS there is an external JVB here.

Why did you add these lines?

It doesn’t tell to install a JVB on JMS. It only tells you don’t need to set a server-id for the local JVB if there is one.

Don’t worry about that. If the additional JVBs can connect to the XMPP server through TCP/5222, the magic will happen.

I use these lines because we have VLANs and when people from different network want to join a meeting, it does not work. It is not behind NAT but in private LAN

It doesn’t tell to install a JVB on JMS . It only tells you don’t need to set a server-id for the local JVB if there is one.

Yes sorry I was wrong, thank you for the clarification.

Ok I will look further.

Thanks !

Hello @emrah

After one week of trying to debug my problem, I’m still stuck but I think the websocket work.

I paste all my setup on this Github page

When I tcpdump from the JMS, I can see JVB sending XMPP packets, and when I stop the jitsi-videobridge service, tcpdump does not capture anymore.

But I can’t find what’s the issue here … if you have bit of a time to lookup my configuration files, it would be helpful.

Thank you !

TCP/5222 should be open on JMS, not JVB…

For now; the firewall is disabled on JMS and JVB. For testing purpose.

On JVB

tcpdump host 10.100.120.122 (ip of JMS)

15:55:56.682395 IP lbmeet.company.lan.xmpp-client > lbmeet-jvb-1.51930: Flags [.], ack 1649, win 501, options [nop,nop,TS val 3268330435 ecr 561601237], length 0
15:55:56.682601 IP lbmeet.company.lan.xmpp-client > lbmeet-jvb-1.51930: Flags [P.], seq 3175:3364, ack 1649, win 501, options [nop,nop,TS val 3268330436 ecr 561601237], length 189
15:55:56.682610 IP lbmeet-jvb-1.51930 > lbmeet.company.lan.xmpp-client: Flags [.], ack 3364, win 251, options [nop,nop,TS val 561601238 ecr 3268330436], length 0
15:55:56.682924 IP lbmeet-jvb-1.51930 > lbmeet.company.lan.xmpp-client: Flags [P.], seq 1649:1703, ack 3364, win 251, options [nop,nop,TS val 561601238 ecr 3268330436], length 5415:55:56.683017 IP lbmeet.company.lan.xmpp-client > lbmeet-jvb-1.51930: Flags [.], ack 1703, win 501, options [nop,nop,TS val 3268330436 ecr 561601238], length 0
15:55:56.683056 IP lbmeet.company.lan.xmpp-client > lbmeet-jvb-1.51930: Flags [P.], seq 3364:3402, ack 1703, win 501, options [nop,nop,TS val 3268330436 ecr 561601238], length 3815:55:56.683072 IP lbmeet.company.lan.xmpp-client > lbmeet-jvb-1.51930: Flags [FP.], seq 3402:3426, ack 1703, win 501, options [nop,nop,TS val 3268330436 ecr 561601238], length 24

On JMS:

tcpdump host 10.100.120.123(ip of JVB)

15:58:52.781274 IP lbmeet.company.lan.xmpp-client > 10.100.120.123.52096: Flags [.], ack 1649, win 501, options [nop,nop,TS val 3268746534 ecr 562017336], length 0
15:58:52.781552 IP lbmeet.company.lan.xmpp-client > 10.100.120.123.52096: Flags [P.], seq 3175:3364, ack 1649, win 501, options [nop,nop,TS val 3268746534 ecr 562017336], length 189
15:58:52.781663 IP 10.100.120.123.52096 > lbmeet.company.lan.xmpp-client: Flags [.], ack 3364, win 251, options [nop,nop,TS val 562017336 ecr 3268746534], length 0
15:58:52.781921 IP 10.100.120.123.52096 > lbmeet.company.lan.xmpp-client: Flags [P.], seq 1649:1703, ack 3364, win 251, options [nop,nop,TS val 562017337 ecr 3268746534], length 54
15:58:52.781972 IP lbmeet.company.lan.xmpp-client > 10.100.120.123.52096: Flags [.], ack 1703, win 501, options [nop,nop,TS val 3268746535 ecr 562017337], length 0
15:58:52.782103 IP lbmeet.company.lan.xmpp-client > 10.100.120.123.52096: Flags [P.], seq 3364:3402, ack 1703, win 501, options [nop,nop,TS val 3268746535 ecr 562017337], length 38

On jvb.log, I have an warning message:

JVB 2022-02-04 16:10:36.675 AVERTISSEMENT: [28] [hostname=lbmeet.company.lan id=shard] MucClient.setPresenceExtensions#445: Cannot set presence extension: not connected.
JVB 2022-02-04 16:10:39.072 INFOS: [22] [hostname=lbmeet.company.lan id=shard] MucClient$2.connected#301: Connected.
JVB 2022-02-04 16:10:39.072 INFOS: [22] [hostname=lbmeet.company.lan id=shard] MucClient.lambda$getConnectAndLoginCallable$7#624: Logging in.
JVB 2022-02-04 16:10:39.073 AVERTISSEMENT: [22] [hostname=lbmeet.company.lan id=shard] MucClient.lambda$getConnectAndLoginCallable$7#638: Failed to login. Disconnecting to trigger a re-connect.

It tried to connect to the host but did not succeed.

IMO start with a single server which contains all components (jicofo, jvb, prosody etc). When it works properly, install the additional JVB, check its config according to the main JVB (which is hosted on JMS) and then disable the main JVB.

I have same error about MucClient

JVB 2022-02-04 16:53:16.431 INFOS: [22] [hostname=meet.company.lan id=shard] MucClient$2.connectionClosed#313: Closed.
JVB 2022-02-04 16:53:20.982 AVERTISSEMENT: [28] [hostname=meet.company.lan id=shard] MucClient.setPresenceExtensions#445: Cannot set presence extension: not connected.
JVB 2022-02-04 16:53:21.448 INFOS: [22] [hostname=meet.company.lan id=shard] MucClient$2.connected#301: Connected.
JVB 2022-02-04 16:53:21.449 INFOS: [22] [hostname=meet.company.lan id=shard] MucClient.lambda$getConnectAndLoginCallable$7#624: Logging in.
JVB 2022-02-04 16:53:21.451 AVERTISSEMENT: [22] [hostname=meet.company.lan id=shard] MucClient.lambda$getConnectAndLoginCallable$7#638: Failed to login. Disconnecting to trigger a re-connect.
JVB 2022-02-04 16:53:21.453 INFOS: [22] [hostname=meet.company.lan id=shard] MucClient$2.connectionClosed#313: Closed.

I found out also someone had the same issue and he fixed it by changing the password in /var/lib/prosody/ but I do no have any file with bridge password in this repo.

https://community.jitsi.org/t/videobridge-pool-not-connecting/92263/4

Well, i’m a bit ashamed.

It was a mistake of mine, in the /etc/jitsi/videobridge/sip-communicator.properties, I changed the shard username without realizing that it was not the MUC username !

org.jitsi.videobridge.xmpp.user.shard.USERNAME=jvb1

I changed it to jvb as default.

I search everywhere for a simple issue that I created alone without paying really attention to the documentation.

Sorry for the waste of time.