Please help, install jibri always failed

Hi all,
Please help, i’m trying installing jibri for recording my jitsi server (in separate machine) more than 10 times always failed. :frowning

i try using debian 10 ( failed ) , using ubuntu 16.04 failed too…
since this morning i twiced try installing jibri failed too…
the last i try to install using ubuntu 16.04 , the result is :

root@jibri:~# systemctl restart jibri
root@jibri:~# systemctl status jibri
● jibri.service - Jibri Process
Loaded: loaded (/etc/systemd/system/jibri.service; disabled; vendor preset: enabled)
Active: failed (Result: start-limit-hit) since Jum 2020-07-24 19:50:33 WIB; 870ms ago
Process: 2289 ExecStop=/opt/jitsi/jibri/graceful_shutdown.sh (code=exited, status=7)
Process: 2272 ExecStart=/opt/jitsi/jibri/launch.sh (code=exited, status=143)
Main PID: 2272 (code=exited, status=143)

Jul 24 19:50:33 jibri graceful_shutdown.sh[2289]: Dload Upload Total Spent Left Speed
Jul 24 19:50:33 jibri graceful_shutdown.sh[2289]: [149B blob data]
Jul 24 19:50:33 jibri systemd[1]: jibri.service: Control process exited, code=exited status=7
Jul 24 19:50:33 jibri systemd[1]: jibri.service: Main process exited, code=exited, status=143/n/a
Jul 24 19:50:33 jibri systemd[1]: Stopped Jibri Process.
Jul 24 19:50:33 jibri systemd[1]: jibri.service: Unit entered failed state.
Jul 24 19:50:33 jibri systemd[1]: jibri.service: Failed with result ‘exit-code’.
Jul 24 19:50:33 jibri systemd[1]: jibri.service: Start request repeated too quickly.
Jul 24 19:50:33 jibri systemd[1]: Failed to start Jibri Process.
Jul 24 19:50:33 jibri systemd[1]: jibri.service: Failed with result ‘start-limit-hit’.
root@jibri:~#

i’ve try with this link of tutorial :frowning:

  1. https://github.com/jitsi/jibri
  2. How-to to setup integrated Jitsi and Jibri for dummies, my comprehensive tutorial for the beginner
  3. https://nerdonthestreet.com/wiki?find=Set+Up+Jibri+for+Jitsi+Recording%3Aslash%3AStreaming
  4. https://raj-yadav-jibri-setup.blogspot.com/

all failed … please help.

Thank you

Regards,

Hi! Have you tried to install Jibri in Ubuntu 18.04? I have no problems with Jibri running in this distro. Maybe it works for you too. There’s a very good tutorial to follow in this link.

Could you try the followings?

systemctl  stop jibri-xorg.service
sleep 5
systemctl start jibri.service
systemctl status jibri.service

hi emrah,

i’ve tried ur suggestion but no luck, :frowning:

root@jibri:~# systemctl stop jibri-xorg.service
root@jibri:~# sleep 5
root@jibri:~# systemctl start jibri.service
root@jibri:~# systemctl status jibri.service
● jibri.service - Jibri Process
Loaded: loaded (/etc/systemd/system/jibri.service; disabled; vendor preset: e
Active: failed (Result: start-limit-hit) since Sab 2020-07-25 16:46:54 WIB; 4
Process: 32133 ExecStop=/opt/jitsi/jibri/graceful_shutdown.sh (code=exited, st
Process: 32116 ExecStart=/opt/jitsi/jibri/launch.sh (code=exited, status=143)
Main PID: 32116 (code=exited, status=143)

Jul 25 16:46:54 jibri graceful_shutdown.sh[32133]:
Jul 25 16:46:54 jibri graceful_shutdown.sh[32133]: [149B blob data]
Jul 25 16:46:54 jibri systemd[1]: jibri.service: Control process exited, code=ex
Jul 25 16:46:54 jibri systemd[1]: jibri.service: Main process exited, code=exite
Jul 25 16:46:54 jibri systemd[1]: Stopped Jibri Process.
Jul 25 16:46:54 jibri systemd[1]: jibri.service: Unit entered failed state.
Jul 25 16:46:54 jibri systemd[1]: jibri.service: Failed with result ‘exit-code’.
Jul 25 16:46:54 jibri systemd[1]: jibri.service: Start request repeated too quic
Jul 25 16:46:54 jibri systemd[1]: Failed to start Jibri Process.
Jul 25 16:46:54 jibri systemd[1]: jibri.service: Failed with result 'start-limit
lines 1-17/17 (END)…skipping…
● jibri.service - Jibri Process
Loaded: loaded (/etc/systemd/system/jibri.service; disabled; vendor preset: enabled)
Active: failed (Result: start-limit-hit) since Sab 2020-07-25 16:46:54 WIB; 4s ago
Process: 32133 ExecStop=/opt/jitsi/jibri/graceful_shutdown.sh (code=exited, status=7)
Process: 32116 ExecStart=/opt/jitsi/jibri/launch.sh (code=exited, status=143)
Main PID: 32116 (code=exited, status=143)

Jul 25 16:46:54 jibri graceful_shutdown.sh[32133]: Dload Upload Total Spent Left Speed
Jul 25 16:46:54 jibri graceful_shutdown.sh[32133]: [149B blob data]
Jul 25 16:46:54 jibri systemd[1]: jibri.service: Control process exited, code=exited status=7
Jul 25 16:46:54 jibri systemd[1]: jibri.service: Main process exited, code=exited, status=143/n/a
Jul 25 16:46:54 jibri systemd[1]: Stopped Jibri Process.
Jul 25 16:46:54 jibri systemd[1]: jibri.service: Unit entered failed state.
Jul 25 16:46:54 jibri systemd[1]: jibri.service: Failed with result ‘exit-code’.
Jul 25 16:46:54 jibri systemd[1]: jibri.service: Start request repeated too quickly.
Jul 25 16:46:54 jibri systemd[1]: Failed to start Jibri Process.
Jul 25 16:46:54 jibri systemd[1]: jibri.service: Failed with result ‘start-limit-hit’.

It said that there is a very short time between stop and start action.

The information you have posted didn’t show the real error @InGenetic. The Jibri log file is the best place to look for error information. Could you try this one?

grep -i "error\|warning\|severe" /var/log/jitsi/jibri/log.0.txt

@danhcs

here the log

2020-07-26 11:00:35.134 INFO: [1] org.jitsi.jibri.Main.main() Jibri run with args [–config, /etc/jitsi/jibri/config.json]
2020-07-26 11:00:35.138 INFO: [1] org.jitsi.jibri.Main.main() Using config file /etc/jitsi/jibri/config.json
2020-07-26 11:00:35.139 INFO: [1] org.jitsi.jibri.Main.main() Using port 3333 for internal HTTP API
2020-07-26 11:00:35.139 INFO: [1] org.jitsi.jibri.Main.main() Using port 2222 for the HTTP API
~
~

please advice.

Thanks & regards,

the requirement for install jibri on ubuntu 16.04 did has to using linux kernel version 4.4 ?
or it can be installed in linux kernel 4.15 ?

please advice.

Regards,

Hi @InGenetic,
Please try these steps for change the linux kernel,
apt-get update
apt-get install linux-image-amd64
vim /etc/default/grub after that chage the default GRUB
GRUB_DEFAULT='1>2'
update-grub && reboot

hi, i check the kernel like below

root@jibri:~# dpkg --list ‘linux-image-*’
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
++±==============-============-============-=================================
ii linux-image-4. 4.15.0-112.1 amd64 Signed kernel image generic
ii linux-image-4. 4.15.0-45.48 amd64 Signed kernel image generic
ii linux-image-4. 4.4.0-186.21 amd64 Signed kernel image generic
ii linux-image-ex 4.4.0.186.19 amd64 Transitional package.
ii linux-image-ge 4.4.0.186.19 amd64 Generic Linux kernel image
ii linux-image-ge 4.15.0.112.1 amd64 Generic Linux kernel image
un linux-image-un (no description available)
un linux-image-un (no description available)
un linux-image-un (no description available)

root@jibri:~# nano /etc/default/grub

If you change this file, run ‘update-grub’ afterwards to update

/boot/grub/grub.cfg.

For full documentation of the options in this file, see:

info -f grub -n ‘Simple configuration’

GRUB_DEFAULT=“gnulinux-advanced-4a67ec61-9cd5-4a26-b00f-9391a34c8a29>gnulinux-4.4.0-186-generic-advanced-30d53252-d286-4bad-8f4e-658f591f5a54”
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=lsb_release -i -s 2> /dev/null || echo Debian
GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash”
GRUB_CMDLINE_LINUX=""

Uncomment to enable BadRAM filtering, modify to suit your needs

This works with Linux (no patch required) and with any kernel that obtains

the memory map information from GRUB (GNU Mach, kernel of FreeBSD …)

#GRUB_BADRAM=“0x01234567,0xfefefefe,0x89abcdef,0xefefefef”

Uncomment to disable graphical terminal (grub-pc only)

#GRUB_TERMINAL=console

The resolution used on graphical terminal

note that you can use only modes which your graphic card supports via VBE

you can see them in real GRUB with the command `vbeinfo’

#GRUB_GFXMODE=640x480

Uncomment if you don’t want GRUB to pass “root=UUID=xxx” parameter to Linux

#GRUB_DISABLE_LINUX_UUID=true

Uncomment to disable generation of recovery mode menu entries

#GRUB_DISABLE_RECOVERY=“true”

Uncomment to get a beep at grub start

#GRUB_INIT_TUNE=“480 440 1”

sudo update-grub
reboot,
root@jibri:~# uname -r
4.15.0-112-generic
root@jibri:~#

the kernel still 4.15 .

i tried as @akalana suggestion

vim /etc/default/grub after that chage the default GRUB
GRUB_DEFAULT='1>2'
update-grub && reboot

my ubuntu stuck at boot at recovery menu (filesystem state : read-only).

please advice

hi all,
is there any requirement for setup jibri server separated from jitsi server ?
for example :

  1. jibri must using ubuntu 16.04 with kernel 4.4 ?
  2. jibri server have to use ip public ( not lan ip / or lan ip behind router )

i’ve tried so many times , always failed. the latest failed today is

root@jibri:~# service jibri status
● jibri.service - Jibri Process
Loaded: loaded (/etc/systemd/system/jibri.service; disabled; vendor preset: enabled)
Active: failed (Result: start-limit-hit) since Sen 2020-07-27 13:17:52 WIB; 3s ago
Process: 4033 ExecStop=/opt/jitsi/jibri/graceful_shutdown.sh (code=exited, status=7)
Process: 4014 ExecStart=/opt/jitsi/jibri/launch.sh (code=exited, status=143)
Main PID: 4014 (code=exited, status=143)

Jul 27 13:17:52 jibri graceful_shutdown.sh[4033]: Dload Upload Total Spent Left Speed
Jul 27 13:17:52 jibri graceful_shutdown.sh[4033]: [149B blob data]
Jul 27 13:17:52 jibri systemd[1]: jibri.service: Control process exited, code=exited status=7
Jul 27 13:17:52 jibri systemd[1]: jibri.service: Main process exited, code=exited, status=143/n/a
Jul 27 13:17:52 jibri systemd[1]: Stopped Jibri Process.
Jul 27 13:17:52 jibri systemd[1]: jibri.service: Unit entered failed state.
Jul 27 13:17:52 jibri systemd[1]: jibri.service: Failed with result ‘exit-code’.
Jul 27 13:17:52 jibri systemd[1]: jibri.service: Start request repeated too quickly.
Jul 27 13:17:52 jibri systemd[1]: Failed to start Jibri Process.
Jul 27 13:17:52 jibri systemd[1]: jibri.service: Failed with result ‘start-limit-hit’.

please advice,

Regards,
please advice,

@InGenetic
Switch as root. After that try it.

hi @danhcs

here’s the status of my jibri server after reinstalled ubuntu 16.04

root@jibri:~# systemctl status jibri
● jibri.service - Jibri Process
Loaded: loaded (/etc/systemd/system/jibri.service; disabled; vendor preset: enabled)
Active: active (running) since Sen 2020-07-27 16:23:14 WIB; 3min 4s ago
Process: 1901 ExecStop=/opt/jitsi/jibri/graceful_shutdown.sh (code=exited, status=7)
Main PID: 1908 (java)
CGroup: /system.slice/jibri.service
├─1908 java -Djava.util.logging.config.file=/etc/jitsi/jibri/logging.properties -jar /opt/jitsi/jibri/jibri.jar --config /etc/jitsi/jibri/config.json
└─1953 /usr/local/bin/chromedriver --port=5927 --log-path=/tmp/chromedriver.log

Jul 27 16:23:14 jibri systemd[1]: Started Jibri Process.
Jul 27 16:23:14 jibri launch.sh[1908]: SLF4J: Failed to load class “org.slf4j.impl.StaticLoggerBinder”.
Jul 27 16:23:14 jibri launch.sh[1908]: SLF4J: Defaulting to no-operation (NOP) logger implementation
Jul 27 16:23:14 jibri launch.sh[1908]: SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.
Jul 27 16:23:22 jibri launch.sh[1908]: Starting ChromeDriver 84.0.4147.30 (48b3e868b4cc0aa7e8149519690b6f6949e110a8-refs/branch-heads/4147@{#310}) on port 5927
Jul 27 16:23:22 jibri launch.sh[1908]: Only local connections are allowed.
Jul 27 16:23:22 jibri launch.sh[1908]: Please see https://chromedriver.chromium.org/security-considerations for suggestions on keeping ChromeDriver safe.
Jul 27 16:23:22 jibri launch.sh[1908]: ChromeDriver was started successfully.

then when i try to start recording, recording is failed , and here the log
root@jibri:~# grep -i “error|warning|severe” /var/log/jitsi/jibri/log.0.txt
2020-07-27 16:23:15.267 WARNING: [1] org.glassfish.jersey.internal.inject.Providers.checkProviderRuntime() A provider org.jitsi.jibri.api.http.internal.InternalHttpApi registered in SERVER runtime does not implement any provider interfaces applicable in the SERVER runtime. Due to constraint configuration problems the provider org.jitsi.jibri.api.http.internal.InternalHttpApi will be ignored.
2020-07-27 16:23:15.511 WARNING: [20] org.jitsi.xmpp.mucclient.MucClient.log() Disabling certificate verification!
2020-07-27 16:23:15.561 WARNING: [1] org.glassfish.jersey.internal.inject.Providers.checkProviderRuntime() A provider org.jitsi.jibri.api.http.HttpApi registered in SERVER runtime does not implement any provider interfaces applicable in the SERVER runtime. Due to constraint configuration problems the provider org.jitsi.jibri.api.http.HttpApi will be ignored.
2020-07-27 16:23:23.382 SEVERE: [35] org.jitsi.jibri.api.xmpp.XmppApi.handleStartJibriIq() Error starting Jibri service : org.openqa.selenium.WebDriverException: unknown error: Chrome failed to start: exited abnormally.
(unknown error: DevToolsActivePort file doesn’t exist)
(Driver info: chromedriver=84.0.4147.30 (48b3e868b4cc0aa7e8149519690b6f6949e110a8-refs/branch-heads/4147@{#310}),platform=Linux 4.4.0-186-generic x86_64) (WARNING: The server did not provide any stacktrace information)
org.openqa.selenium.remote.ErrorHandler.createThrowable(ErrorHandler.java:214)
org.openqa.selenium.remote.ErrorHandler.throwIfResponseFailed(ErrorHandler.java:166)
root@jibri:~#

please advice

I don’t think so. Jibri needs a kernel with ALSA and a loopback device. This can be installed on Ubuntu 16.04 using package name linux-image-extra-virtual. You can check if it’s installed by running:

lsmod | grep snd_aloop

I think the most important requirement for Jibri is the java 8 version. This can be installed on Ubuntu 16.04 using package name openjdk-8-jre. The default-jre package name may give you the wrong version. You can check the java version running this command:

java -version

My Jibri works great with the Openjdk 1.8.0_252.

And make sure the jibri user is in the groups: adm, audio, video and plugdev. You can check this by running this command:

groups jibri

It must return at least the groups above.

@danhcs
group jibri is ok,

now my jibri status is running , here status :

root@jibri:~# service jibri status
● jibri.service - Jibri Process
Loaded: loaded (/etc/systemd/system/jibri.service; disabled; vendor preset: e
Active: active (running) since Rab 2020-07-29 19:58:32 WIB; 10s ago
Process: 1544 ExecStop=/opt/jitsi/jibri/graceful_shutdown.sh (code=exited, sta
Main PID: 1549 (java)
CGroup: /system.slice/jibri.service
└─1549 java -Djava.util.logging.config.file=/etc/jitsi/jibri/logging.

Jul 29 19:58:32 jibri systemd[1]: Started Jibri Process.
Jul 29 19:58:33 jibri launch.sh[1549]: SLF4J: Failed to load class "org.slf4j.im
Jul 29 19:58:33 jibri launch.sh[1549]: SLF4J: Defaulting to no-operation (NOP) l
Jul 29 19:58:33 jibri launch.sh[1549]: SLF4J: See http://www.slf4j.org/codes.htm

But, recording failed , and here’s the log :
root@jibri:~# grep -i “error|warning|severe” /var/log/jitsi/jibri/log.0.txt
2020-07-29 19:58:34.329 WARNING: [1] org.glassfish.jersey.internal.inject.Provid ers.checkProviderRuntime() A provider org.jitsi.jibri.api.http.internal.Internal HttpApi registered in SERVER runtime does not implement any provider interfaces applicable in the SERVER runtime. Due to constraint configuration problems the p rovider org.jitsi.jibri.api.http.internal.InternalHttpApi will be ignored.
2020-07-29 19:58:34.715 WARNING: [20] org.jitsi.xmpp.mucclient.MucClient.log() D isabling certificate verification!
2020-07-29 19:58:34.762 WARNING: [1] org.glassfish.jersey.internal.inject.Provid ers.checkProviderRuntime() A provider org.jitsi.jibri.api.http.HttpApi registere d in SERVER runtime does not implement any provider interfaces applicable in the SERVER runtime. Due to constraint configuration problems the provider org.jitsi .jibri.api.http.HttpApi will be ignored.
2020-07-29 19:59:21.891 SEVERE: [35] org.jitsi.jibri.api.xmpp.XmppApi.handleStar tJibriIq() Error starting Jibri service : org.openqa.selenium.WebDriverException : unknown error: Chrome failed to start: exited abnormally.
(unknown error: DevToolsActivePort file doesn’t exist)
(Driver info: chromedriver=84.0.4147.30 (48b3e868b4cc0aa7e8149519690b6f6949e11 0a8-refs/branch-heads/4147@{#310}),platform=Linux 4.15.0-45-generic x86_64) (WAR NING: The server did not provide any stacktrace information)
org.openqa.selenium.remote.ErrorHandler.createThrowable(ErrorHandler.java:214)
org.openqa.selenium.remote.ErrorHandler.throwIfResponseFailed(ErrorHandler.java: 166)

, for your information , my jibri setup is :

  1. using public ip , 1 subnet with jitsi server
  2. using server hardware not VM
  3. os ubuntu linux 16.04

by the way, i try to setup jibri on vm in digitalocean like below:

root@jibri:~# hostnamectl
root@jibri:~# hostnamectl
Static hostname: jibri
Icon name: computer-vm
Chassis: vm
Machine ID: a53c192edea54735b597c12a7d0d2d05
Boot ID: 0b2d97483183466b96860e505b6eeb05
Virtualization: kvm
Operating System: Ubuntu 16.04.6 LTS
Kernel: Linux 4.4.0-186-generic
Architecture: x86-64
it’s running normal… and my jitsi server can recording and streaming to youtube.

but, the condition, i have to use real server hardware on my place

and i setup my jibri server hardware exactly the same with the vm in digital ocean, the different things are :

  1. vm and not vm ( real server hardware)
  2. kernel version of ubuntu , in vm : Linux 4.4.0-186-generic , in real server : Linux 4.15.0-45-generic

but my jibri in real server hardware failed to recording with the log as above

please advice …

The log file reports that there’s a problem starting Google Chrome. It won’t start properly if there’s no access to display :0. Did you already have a working display there? It seems that is the same problem described in this post.

Could you try running those commands:

systemctl status jibri-xorg
ps ax | grep -i xorg

And make sure you aren’t running a Xorg Server or Display Manager there before the jibri-xorg service starts. It uses only the DISPLAY :0. If it’s not available, the Jibri will eventually fail to start.

hi @danhcs,
here the log when jibri not starting

root@jibri:~# systemctl status jibri-xorg
● jibri-xorg.service - Jibri Xorg Process
Loaded: loaded (/etc/systemd/system/jibri-xorg.service; disabled; vendor prese
Active: failed (Result: start-limit-hit) since Jum 2020-07-31 13:01:58 WIB; 1h
Process: 2140 ExecStart=/usr/bin/Xorg -nocursor -noreset +extension RANDR +exte
Main PID: 2140 (code=exited, status=1/FAILURE)

Jul 31 13:01:58 jibri systemd[1]: jibri-xorg.service: Unit entered failed state.
Jul 31 13:01:58 jibri systemd[1]: jibri-xorg.service: Failed with result 'exit-co
Jul 31 13:01:58 jibri systemd[1]: jibri-xorg.service: Service hold-off time over,
Jul 31 13:01:58 jibri systemd[1]: Stopped Jibri Xorg Process.
Jul 31 13:01:58 jibri systemd[1]: jibri-xorg.service: Start request repeated too
Jul 31 13:01:58 jibri systemd[1]: Failed to start Jibri Xorg Process.
Jul 31 13:01:58 jibri systemd[1]: jibri-xorg.service: Unit entered failed state.
Jul 31 13:01:58 jibri systemd[1]: jibri-xorg.service: Failed with result 'start-l
lines 1-14/14 (END)

root@jibri:~# systemctl status jibri-xorg
● jibri-xorg.service - Jibri Xorg Process
Loaded: loaded (/etc/systemd/system/jibri-xorg.service; disabled; vendor prese
Active: failed (Result: start-limit-hit) since Jum 2020-07-31 13:01:58 WIB; 1h
Process: 2140 ExecStart=/usr/bin/Xorg -nocursor -noreset +extension RANDR +exte
Main PID: 2140 (code=exited, status=1/FAILURE)

Jul 31 13:01:58 jibri systemd[1]: jibri-xorg.service: Unit entered failed state.
Jul 31 13:01:58 jibri systemd[1]: jibri-xorg.service: Failed with result 'exit-co
Jul 31 13:01:58 jibri systemd[1]: jibri-xorg.service: Service hold-off time over,
Jul 31 13:01:58 jibri systemd[1]: Stopped Jibri Xorg Process.
Jul 31 13:01:58 jibri systemd[1]: jibri-xorg.service: Start request repeated too
Jul 31 13:01:58 jibri systemd[1]: Failed to start Jibri Xorg Process.
Jul 31 13:01:58 jibri systemd[1]: jibri-xorg.service: Unit entered failed state.
Jul 31 13:01:58 jibri systemd[1]: jibri-xorg.service: Failed with result 'start-l
root@jibri:~# ps ax | grep -i xorg
877 tty7 Ssl+ 0:01 /usr/lib/xorg/Xorg -core :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
3090 pts/8 S+ 0:00 grep --color=auto -i xorg

ok , now when i start jibri :
jibri won’t running active :
root@jibri:~# sleep 5
root@jibri:~# systemctl restart jibri
root@jibri:~# service jibri status
● jibri.service - Jibri Process
Loaded: loaded (/etc/systemd/system/jibri.service; disabled; vendor preset: enabled)
Active: failed (Result: start-limit-hit) since Jum 2020-07-31 14:45:26 WIB; 2s ago
Process: 3777 ExecStop=/opt/jitsi/jibri/graceful_shutdown.sh (code=exited, status=7)
Process: 3760 ExecStart=/opt/jitsi/jibri/launch.sh (code=exited, status=143)
Main PID: 3760 (code=exited, status=143)

Jul 31 14:45:26 jibri graceful_shutdown.sh[3777]: Dload Upload Total Spent Left Speed
Jul 31 14:45:26 jibri graceful_shutdown.sh[3777]: [149B blob data]
Jul 31 14:45:26 jibri systemd[1]: jibri.service: Control process exited, code=exited status=7
Jul 31 14:45:26 jibri systemd[1]: jibri.service: Main process exited, code=exited, status=143/n/a
Jul 31 14:45:26 jibri systemd[1]: Stopped Jibri Process.
Jul 31 14:45:26 jibri systemd[1]: jibri.service: Unit entered failed state.
Jul 31 14:45:26 jibri systemd[1]: jibri.service: Failed with result ‘exit-code’.
Jul 31 14:45:26 jibri systemd[1]: jibri.service: Start request repeated too quickly.
Jul 31 14:45:26 jibri systemd[1]: Failed to start Jibri Process.
Jul 31 14:45:26 jibri systemd[1]: jibri.service: Failed with result ‘start-limit-hit’.
root@jibri:~#

after wait for about 2-3 minutes then i try to start jibri again :

root@jibri:~# service jibri status
● jibri.service - Jibri Process
Loaded: loaded (/etc/systemd/system/jibri.service; disabled; vendor preset: enabled)
Active: active (running) since Jum 2020-07-31 14:50:03 WIB; 2s ago
Process: 4622 ExecStop=/opt/jitsi/jibri/graceful_shutdown.sh (code=exited, status=7)
Main PID: 4689 (java)
CGroup: /system.slice/jibri.service
└─4689 java -Djava.util.logging.config.file=/etc/jitsi/jibri/logging.properties -jar /opt/jitsi/jibri/jibri.jar --config /etc/jitsi/jibri/config.json

Jul 31 14:50:03 jibri systemd[1]: Started Jibri Process.
Jul 31 14:50:04 jibri launch.sh[4689]: SLF4J: Failed to load class “org.slf4j.impl.StaticLoggerBinder”.
Jul 31 14:50:04 jibri launch.sh[4689]: SLF4J: Defaulting to no-operation (NOP) logger implementation
Jul 31 14:50:04 jibri launch.sh[4689]: SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.
root@jibri:~#

they running , but jitsi failed to recording
failed to start.PNG

here log for xorg :
root@jibri:~# systemctl status jibri-xorg
● jibri-xorg.service - Jibri Xorg Process
Loaded: loaded (/etc/systemd/system/jibri-xorg.service; disabled; vendor preset: enabled)
Active: failed (Result: start-limit-hit) since Jum 2020-07-31 14:52:34 WIB; 6s ago
Process: 4872 ExecStart=/usr/bin/Xorg -nocursor -noreset +extension RANDR +extension RENDER -logfile /var/log/jitsi/jibri/xorg.log -config /etc/jitsi/jibri/xorg-vide
Main PID: 4872 (code=exited, status=1/FAILURE)

Jul 31 14:52:34 jibri systemd[1]: jibri-xorg.service: Unit entered failed state.
Jul 31 14:52:34 jibri systemd[1]: jibri-xorg.service: Failed with result ‘exit-code’.
Jul 31 14:52:34 jibri systemd[1]: jibri-xorg.service: Service hold-off time over, scheduling restart.
Jul 31 14:52:34 jibri systemd[1]: Stopped Jibri Xorg Process.
Jul 31 14:52:34 jibri systemd[1]: jibri-xorg.service: Start request repeated too quickly.
Jul 31 14:52:34 jibri systemd[1]: Failed to start Jibri Xorg Process.
Jul 31 14:52:34 jibri systemd[1]: jibri-xorg.service: Unit entered failed state.
Jul 31 14:52:34 jibri systemd[1]: jibri-xorg.service: Failed with result ‘start-limit-hit’.
lines 1-14/14 (END)

and here tail -f /var/log/jitsi/jibri/log.0.txt

root@jibri:~# tail -f /var/log/jitsi/jibri/log.0.txt
JibriConfig(recordingDirectory=/srv/recordings, singleUseMode=false, enabledStatsD=true, finalizeRecordingScriptPath=/path/to/finalize_recording.sh, xmppEnvironments=[XmppEnvironmentConfig(name=prod environment, xmppServerHosts=[artius.fajarbenua.co.id], xmppDomain=artius.fajarbenua.co.id, controlLogin=XmppCredentials(domain=auth.artius.fajarbenua.co.id, username=jibri, password=Nicholas88), controlMuc=XmppMuc(domain=internal.auth.artius.fajarbenua.co.id, roomName=JibriBrewery, nickname=jibri-nickname), sipControlMuc=null, callLogin=XmppCredentials(domain=recorder.artius.fajarbenua.co.id, username=recorder, password=Nicholas88), stripFromRoomDomain=conference., usageTimeoutMins=0, trustAllXmppCerts=true)])
2020-07-31 14:52:35.587 WARNING: [1] org.glassfish.jersey.internal.inject.Providers.checkProviderRuntime() A provider org.jitsi.jibri.api.http.internal.InternalHttpApi registered in SERVER runtime does not implement any provider interfaces applicable in the SERVER runtime. Due to constraint configuration problems the provider org.jitsi.jibri.api.http.internal.InternalHttpApi will be ignored.
2020-07-31 14:52:35.790 INFO: [1] org.jitsi.jibri.api.xmpp.XmppApi.updatePresence() Jibri reports its status is now JibriStatus(busyStatus=IDLE, health=OverallHealth(healthStatus=HEALTHY, details={})), publishing presence to connections
2020-07-31 14:52:35.797 INFO: [1] org.jitsi.jibri.api.xmpp.XmppApi.start() Connecting to xmpp environment on artius.fajarbenua.co.id with config XmppEnvironmentConfig(name=prod environment, xmppServerHosts=[artius.fajarbenua.co.id], xmppDomain=artius.fajarbenua.co.id, controlLogin=XmppCredentials(domain=auth.artius.fajarbenua.co.id, username=jibri, password=password), controlMuc=XmppMuc(domain=internal.auth.artius.fajarbenua.co.id, roomName=JibriBrewery, nickname=jibri-nickname), sipControlMuc=null, callLogin=XmppCredentials(domain=recorder.artius.fajarbenua.co.id, username=recorder, password=password), stripFromRoomDomain=conference., usageTimeoutMins=0, trustAllXmppCerts=true)
2020-07-31 14:52:35.798 INFO: [1] org.jitsi.jibri.api.xmpp.XmppApi.start() The trustAllXmppCerts config is enabled for this domain, all XMPP server provided certificates will be accepted
2020-07-31 14:52:35.818 WARNING: [20] org.jitsi.xmpp.mucclient.MucClient.log() Disabling certificate verification!
2020-07-31 14:52:35.855 WARNING: [1] org.glassfish.jersey.internal.inject.Providers.checkProviderRuntime() A provider org.jitsi.jibri.api.http.HttpApi registered in SERVER runtime does not implement any provider interfaces applicable in the SERVER runtime. Due to constraint configuration problems the provider org.jitsi.jibri.api.http.HttpApi will be ignored.
2020-07-31 14:52:36.068 INFO: [20] org.jitsi.xmpp.mucclient.MucClient.log() Connected.
2020-07-31 14:52:36.068 INFO: [20] org.jitsi.xmpp.mucclient.MucClient.log() Logging in.
2020-07-31 14:52:36.170 INFO: [20] org.jitsi.xmpp.mucclient.MucClient.log() Joined MUC: jibribrewery@internal.auth.artius.fajarbenua.co.id

and below when i hit start recording :

2020-07-31 14:56:25.264 INFO: [42] org.jitsi.jibri.api.xmpp.XmppApi.handleJibriIq () Received JibriIq from environment [MucClie nt id=artius.fajarbenua.co.id hostname=artius.fajarbenua.co.id]
2020-07-31 14:56:25.265 INFO: [42] org.jitsi.jibri.api.xmpp.XmppApi.handleStartJi briIq() Received start request, starting service
2020-07-31 14:56:25.299 INFO: [42] org.jitsi.jibri.api.xmpp.XmppApi.handleStartSe rvice() Parsed call url info: CallUrlInfo(baseUrl=https://artius.fajarbenua.co.id , callName=medico, urlParams=)
2020-07-31 14:56:25.300 INFO: [42] org.jitsi.jibri.JibriManager.startFileRecordin g() Starting a file recording with params: FileRecordingRequestParams(callParams= CallParams(callUrlInfo=CallUrlInfo(baseUrl=https://artius.fajarbenua.co.id, callN ame=medico, urlParams=)), sessionId=ttwjhyguqwbnuofv, callLoginParams=XmppCrede ntials(domain=recorder.artius.fajarbenua.co.id, username=recorder, password=Nicho las88)) finalize script path: /path/to/finalize_recording.sh and recordings direc tory: /srv/recordings
2020-07-31 14:56:25.801 SEVERE: [42] org.jitsi.jibri.api.xmpp.XmppApi.handleStart JibriIq() Error starting Jibri service : org.openqa.selenium.WebDriverException: unknown error: Chrome failed to start: exited abnormally.

  • (unknown error: DevToolsActivePort file doesn’t exist)*
  • (The process started from chrome location /usr/bin/google-chrome is no longer r unning, so ChromeDriver is assuming that Chrome has crashed.)*
  • (Driver info: chromedriver=84.0.4147.30 (48b3e868b4cc0aa7e8149519690b6f6949e110 a8-refs/branch-heads/4147@{#310}),platform=Linux 4.15.0-112-generic x86_64) (WARN ING: The server did not provide any stacktrace information)*
    Command duration or timeout: 229 milliseconds
    Build info: version: ‘unknown’, revision: ‘unknown’, time: ‘unknown’
    System info: host: ‘jibri’, ip: ‘127.0.1.1’, os.name: ‘Linux’, os.arch: ‘amd64’, os.version: ‘4.15.0-112-generic’, java.version: ‘1.8.0_265’
    Driver info: driver.version: ChromeDriver with stack:
    sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorIm pl.java:62)
    sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAc cessorImpl.java:45)
    java.lang.reflect.Constructor.newInstance(Constructor.java:423)
    org.openqa.selenium.remote.ErrorHandler.createThrowable(ErrorHandler.java:214)
    org.openqa.selenium.remote.ErrorHandler.throwIfResponseFailed(ErrorHandler.java:1 66)
    org.openqa.selenium.remote.JsonWireProtocolResponse.lambda$new$0(JsonWireProtocol Response.java:53)
    org.openqa.selenium.remote.JsonWireProtocolResponse.lambda$getResponseFunction$2( JsonWireProtocolResponse.java:91)
    org.openqa.selenium.remote.ProtocolHandshake.lambda$createSession$0(ProtocolHands hake.java:123)
    java.util.stream.ReferencePipeline$3$1.accept(ReferencePipeline.java:193)
    java.util.Spliterators$ArraySpliterator.tryAdvance(Spliterators.java:958)
    java.util.stream.ReferencePipeline.forEachWithCancel(ReferencePipeline.java:126)
    java.util.stream.AbstractPipeline.copyIntoWithCancel(AbstractPipeline.java:499)
    java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:486)
    java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:472)
    java.util.stream.FindOps$FindOp.evaluateSequential(FindOps.java:152)
    java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234)
    java.util.stream.ReferencePipeline.findFirst(ReferencePipeline.java:531)
    org.openqa.selenium.remote.ProtocolHandshake.createSession(ProtocolHandshake.java :126)
    org.openqa.selenium.remote.ProtocolHandshake.createSession(ProtocolHandshake.java :73)
    org.openqa.selenium.remote.HttpCommandExecutor.execute(HttpCommandExecutor.java:1 36)
    org.openqa.selenium.remote.service.DriverCommandExecutor.execute(DriverCommandExe cutor.java:83)
    org.openqa.selenium.remote.RemoteWebDriver.execute(RemoteWebDriver.java:543)
    org.openqa.selenium.remote.RemoteWebDriver.startSession(RemoteWebDriver.java:207)
    org.openqa.selenium.remote.RemoteWebDriver.(RemoteWebDriver.java:130)
    org.openqa.selenium.chrome.ChromeDriver.(ChromeDriver.java:181)
    org.openqa.selenium.chrome.ChromeDriver.(ChromeDriver.java:168)
    org.jitsi.jibri.selenium.JibriSelenium.(JibriSelenium.kt:159)
    org.jitsi.jibri.selenium.JibriSelenium.(JibriSelenium.kt:117)
    org.jitsi.jibri.service.impl.FileRecordingJibriService.(FileRecordingJibriS ervice.kt:107)
    org.jitsi.jibri.JibriManager.startFileRecording(JibriManager.kt:134)
    org.jitsi.jibri.api.xmpp.XmppApi.handleStartService(XmppApi.kt:287)
    org.jitsi.jibri.api.xmpp.XmppApi.handleStartJibriIq(XmppApi.kt:188)
    org.jitsi.jibri.api.xmpp.XmppApi.handleJibriIq(XmppApi.kt:161)
    org.jitsi.jibri.api.xmpp.XmppApi.handleIq(XmppApi.kt:146)
    org.jitsi.xmpp.mucclient.MucClient.handleIq(MucClient.java:547)
    org.jitsi.xmpp.mucclient.MucClient.access$500(MucClient.java:50)
    org.jitsi.xmpp.mucclient.MucClient$2.handleIQRequest(MucClient.java:511)
    org.jivesoftware.smack.AbstractXMPPConnection$4.run(AbstractXMPPConnection.java:1 188)
    java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
    java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
    java.lang.Thread.run(Thread.java:748)

please advice.

Thanks n regards,

Do you have an already installed desktop environment? If yes, reinstall Ubuntu without a desktop environment.

Yes u’re right 100% emrah, i’ m using desktop edition is that the problem?

Jibri uses its own desktop environment (xorg, icewm etc). If there is an already one, it can’t start some services.