PiPViewCoordinator is not a member type of JitsiMeet and many more in fresh build

I am not sure if this belongs here or in the Installation category. If I am in the wrong place please let me know and I will re-post in the correct place.
I have been trying to get an extremely simple sample setup with JitsiMeet on iOS and having an absolute nightmare. No matter what I do it will not build. I originally thought the problem was ‘Failed to load module JitsiMeet’ but that is the resulting issue I believe is caused by 11 other issues.
First the setup…

  • Create a new project in xcode

  • Set Enable Bitcode to No for project

  • Enable Always Embed Swift Standard Libraries for project

  • Build it, just to be sure it builds.

  • Close xcode, open terminal, cd to project directory and run ‘pod init’
    open podfile and edit to read…

    platform :ios, '12.0'
    
    target 'JitsiMeetTest' do
    
      use_frameworks!
    
      pod 'JitsiMeetSDK'
    
      post_install do |installer|
    
        installer.pods_project.targets.each do |target|
    
          target.build_configurations.each do |config|
    
            config.build_settings['ENABLE_BITCODE'] = 'NO'
    
          end
    
        end
    
      end
    
    end
    
  • Save podfile, go back to terminal and run ‘pod install’

  • After pod install finishes open up the new xcworkspace file in xcode

  • Build the app.
    At that point 11 errors occur, all swift compiler errors, things like…

‘PiPViewCoordinator’ is not a member type of ‘JitsiMeet’

‘AnimationCompletion’ is not a member type of ‘JitsiMeet’

‘JMCallKitListener’ is not a member type of ‘JitsiMeet’

And more, all from the same file ‘x86_64-applie-ios-simulator.swiftinterface’
It won’t build, and I can’t figure out why. I have tried removing the ‘use_frameworks!’ from the podfile. I have tried in xcode 10 and xcode 11, neither works. I don’t know what to do, all I have done is literally installed JitsiMeetSDK with cocoapods and the app will no longer build. Any help would be greatly appreciated. Thank you.

I had the same issue today when I upgraded to Xcode 12, the issue is that the latest release is compiled with Swift 5.2.x I guess and Xcode 12 need binary with built with Swift 5.3. I have compiled it with Swift 5.3 using Xcode 12 and its working for me, you can also try my fork if it works for you. I will be using my own build until Jitis releases a latest framework compiled with latest Xcode. You can find my fork here.

That solution worked, though mine was because I was on xcode 11 and couldn’t update to xcode 11.4/11.5 due to my mac osx only being 10.14 and not 10.15.6. So I compiled the source with my xcode 11 and it finally worked.

Hi Pratik948, i am getting the same error after upgrading to xcode 12 can you help me with how to use this fork over email? my email id is rizulsharma16@gmail.com.

Thanks
Rizul

@Rizul_Sharma for using custom fork on CocoaPods you can simply define the link of your repo
pod ‘JitsiMeetSDK’, :git=> ‘https://github.com/Pratik948/jitsi-meet-ios-sdk-releases.git

Also there is no need for my fork to be used as Jitsi has released a new version of its framework built with Xcode 12 you can find that here.

To use latest version you can just specify it in your pod
pod ‘JitsiMeetSDK’, ‘~> 2.10.2’

Thank you so much, @Pratik948 for the information.

I think you need to do pod update from the command line after that? But thanks for this info.

@ile Yes you’re right but I just mentioned that if we need a specific version or above we can set version given in my previous comment and the mentioned version was of latest version of Jitsi SDK

Hi @Pratik948, I am here again facing the same issue somehow my working code stopped working when I logged back in!! I have updated the pod to the latest version and I am still facing the same issue.
I am getting this error.
‘PiPViewCoordinator’ is not a member type of ‘JitsiMeet’
and 18 more of the same sort can you please help?

Hi @Rizul_Sharma I am also facing the same issue. Have you found any solutions?

Yes, just run podupdate command and see if that helps.

I tried pod update. still same issue.

Below is my Xcode and swift version.

Xcode 12.3
Build version 12C33
Apple Swift version 5.3.2 (swiftlang-1200.0.45 clang-1200.0.32.28)
Target: arm64-apple-darwin20.1.0

Can you see this error, let me know if you can help @Rizul_Sharma . I am getting this error plus and 10+ similar errors.

   23:41: error: 'PiPViewCoordinator' is not a member type of 'JitsiMeet'
    public static func == (a: JitsiMeet.PiPViewCoordinator.Position, b: JitsiMeet.PiPViewCoordinator.Position) -> Swift.Bool
                              ~~~~~~~~~ ^
JitsiMeet.JitsiMeet:1:12: note: 'JitsiMeet' declared here
open class JitsiMeet : NSObject {

It might be that you are using an older version of JitsiMeet. When I updated my Xcode to 12.3 I ran into that problem as well, all of a sudden, it just wouldn’t compile and I was getting the PiPViewCoordinator and others error. The problem was the version of JitsiMeetSDK in my podfile.
Try updating your version in there. Mine is now set to 2.11 and it works fine. Here’s my podfile for reference.

platform :ios, '11.0'

target 'Finity Care Meet' do
  pod 'JitsiMeetSDK', '~> 2.11'

  post_install do |installer|
    installer.pods_project.targets.each do |target|
      target.build_configurations.each do |config|
        config.build_settings['ENABLE_BITCODE'] = 'NO'
      end
    end
  end
end

After you update the podfile you should probably either run podupdate or podinstall to update the version of JitsiMeetSDK.