Performance optimization / Jitsi with separate videobridges, rather poor quality

can you try disable p2p mode so that all communication uses the bridge?
p2p: {
enabled: false,

here’s the log files.
Sorry…wasn’t able to upload it in any other way…


i suppose you would like to read the logfiles before i edit p2p to false?

I looked at the jicofo log WARNUNG’s and odd information.

  1. Not merging A/V streams from A to B
    Jicofo 2020-04-15 09:59:40.625 INFORMATION: [48] org.jitsi.jicofo.LipSyncHack.log() Not merging A/V streams from to
    Jicofo 2020-04-15 09:59:40.625 INFORMATION: [48] org.jitsi.jicofo.LipSyncHack.log() Not merging A/V streams from to

  2. it looks that all three videobridges uses the same login i think this is an error *

  3. missing pub-sub configuration, i think this is a requirement when using external videobridges *
    Jicofo 2020-04-15 09:48:50.448 WARNUNG: [30] org.jitsi.jicofo.bridge.BridgeSelector.log() No pub-sub node mapped for

I do not know if 0. is an issue.

I base my two remarks 1. and 2. on how to setup more than one videobridge and configure pubsub using this video tutorial:

I think muc is now replacing pubsub (when using jvb2), and we consider it correct to use the same login for all videobridges.

Are we wrong?


Good morning,

no ideas anymore?
We’re still suffering from really odd performance issues we can’t explain.
More examples:

  • yesterday at 10 pm out of 2 external partners only one came into the chat. Thousands of restarts, different device … everything tried. Nothing.
  • yesterday at 8 pm 1:1 session
    The latency was around one second, video and sound quality were good.
    However, the sound changed after a short time, my counterpart suddenly heard me distorted, although my line was good, the mic definitely ok.
    In direct comparison with Skype this problem did not exist.
    Back in jitsi the same problem after a short time!

P2P is disabled at the moment
disableAudioLevels set to true

i am getting desperate here…

Are your VM’s setup to make use of hardware encryption?

Also try using 480 resolution.

Above two changes together with enough CPU (10 cores) and enough memory helped us a lot. We were suddenly able to do conferences with 20 people. Had similar problems like you before. We’re running on unstable branch.

1 Like

Hi PeterS,
sound great, will try asap and let you know

still trying to understand the AES-NI bit, but regarding the video resolution:

// Video
// Sets the preferred resolution (height) for local video. Defaults to 720.
resolution: 48ß,

anything else i would need to adjust for that?

That’s the only change you need to do for the resolution.

If your VM’s are not set to use this hardware encryption then this will hopefully really help.
See also comment from emcho here [jitsi-users] Jitsi Videobridge performance and comment from mueller-physics about performance tweaks here Server requirements for 20 users with video

Ok, i think i managed to set AES in my VM.
Using Proxmox i needed to change CPU to Westmere and enable AES:

So now the VM shows:

grep -o aes /proc/cpuinfo

cpuid | grep -i aes | sort | uniq
AES instruction = true
VAES instructions = false

lscpu | grep '^CPU(s):'
CPU(s): 8
grep -o aes /proc/cpuinfo | wc -l

Would this be sufficient, or do you see any more i need to do for AES-NI?

1 Like

Did you try running the VM’s with this setting? Looks like this is enough.

i set AES for all VMs now, and the outout on the VMs is what i posted. So presumably AES is enabled for them.
Will now test Jitsi performance again.

Ok, can’t really say anything about the performance yet, will have to wait for a few people testing it.
But in any case, the changes didn’t have a negative effect, jitsi still works.
However one of our users had difficulties again entering the room with the (Android) mobile app.
He had to relogin, before we could see him.
Before he seemed to be in the room, but only saw himself, while the other two (already talking with each other) haven’t noticed him at all.

really strange. I don’t think we had this behavior before with JVB1.


Just installed a “Big Blue Button” VM on the very same server.
How come, that with BBB we have incredible performance using HD video and audio.
This seems completely weird to me.

Don’t get me wrong, we still want to go with jitsi, but we wanted to understand if we probably have issues with the hardware.

I don’t want to believe, that a software i have installed in 20 minutes, on an EOL ubuntu 16.04 (which is the reccomended system for BBB) reaches a better performance than a 3 node jitsi setup, we have been working on for about 6 weeks.

Any hints or help is highly appreciated!


1 Like

hey sascha,

that’s funny i had similar problems you currently have with jitsi with bbb and so i’m testing jitsi now.

when you say good quality etc. how many concurrent users with cameras and audio are we talking about?

Hi mm_bln,

i tried bbb with 3 concurent users and it worked very very well, right out of the box, without any optimization or further configuration.
3 users only working with good performance might sound completely obvious, but as i said, we’re having troubles with jitsi even with that at the moment.

Again, i really believe think jitsi is the better system and we may have some configuration error somewhere.
That’s why i still hope some of the jitsi experts here can find that error in the config files i have posted.


hey sascha,

thanks for the answer.

at the very beginning of your thread you wrote that you were quite satisfied with the jvb1 version.
may i ask you with how many participants you had the system running.
furthermore there seem to be some people here in the forum who have enormous problems after the upgrade from jvb1 to jvb2.

i personally have already thought about testing the jvb1 but after a test run on friday with
about 20 people which turned out quite negative i made some changes to the currently installed
system jvb2 and now i want to wait for further tests on monday.

thx matthias

We had an estimate of 40-50 concurrent users on jvb1, but suffered from poor audio/video quality also.
Unfortunately our hope on bettering the situation by using jvb2 has not fulfilled until today.
We read about SFU and VP9, but to be frank, we don’t understand too much of that discussions…
If this is something we should try out, let us know…and most importantly…please give us instructions…:slight_smile:
thanks a lot

just to give a short feedback.

last night i had to completely rebuild the server after a failed update of the jitsi packages and several failed attempts to get it running again.
this time i decided to use ubuntu 18.04 instead of debian 10. i read somewhere here in the forum in a post from dec. 2019 that jitsi needs java 8 in ubuntu the quick-install of jitsi installs the appropriate openjdk-8-jdk directly.

today’s tests with up to 15 participants were quite good in contrast to friday.
only two participants had serious problems, but i attribute this to their pcs. the server is running relatively quietly and the network throughput is still up.

so if you are still looking for a solution to your problem i would suggest to try and test the install ones again on a single machine using ubuntu 18.04 and jitsi’s quick install.