People in rooms can not see each other

Hello,

this is my 2nd attempt to get a local jitsi installation up and running.

Background information

I want to run a jitsi meet setup on my own server, so that people can connect with their browsers.
But I am missing an overview,

  • what components are running and what are they good for?
  • why would I use nginx, apache2 or none of both?
  • What ports need to be available
  • What are the requirements for fqdns and valid certificates

I have the feeling that problems might arise from each of those points if there is a misunderstanding.
I did not find an up-to-date components schematics and not a list of all ports.
I found a lot of information and hints, but not in one place. It would be great, if someone could point me there!

What have I done

I installed jitsi meet on a fresh Ubuntu 18.04 behind a firewall.
Finally I natted the following ports:

  • TCP/80

  • TCP/443

  • TCP/4443

  • TCP/5222

  • TCP/5269

  • TCP/5280

  • TCP/10000

  • UDP/10000-20000

Honestly I was not aware before, that so many ports would be needed. For what? XMPP… probably. Aha, the chat is transferred via xmpp? I was not aware of this (see my above questions in regards to the components schema)

Are these enough open ports? Or too much?

Then I installed jitsi this way (without any webserver installed before!) on Ubuntu 18.04LTS:

wget -qO - https://download.jitsi.org/jitsi-key.gpg.key | sudo apt-key add -
sh -c "echo 'deb https://download.jitsi.org stable/' > /etc/apt/sources.list.d/jitsi-stable.list"
apt-get -y update
apt-get -y install jitsi-meet

Then I thought, everything would be fine. But I was wrong!

Problems I am experiencing

When I connect to the webpage with my browser, it takes a loooooong time, till the browser connects.

Here is my waterfall:

The browser console produces errors like “modules/UI/videolayout/SmallVideo.js” in “Logger.js:154”
Unable to init acator - no id.

The browsers eat up all the CPU.

In some browsers like chrome or brave I can not see myself, although the video is allowed.
In Firefox and the Android smartphone App, the video works fine.

But when two machines connect to one room, the two participants can not see each other. They are even not notfifed - there is no indication - that there is a 2nd participant present.

The chat between two participants in the same room also does not work - as mentioned, no indication of a 2nd person.

How to debug

What would be the best way to debug this?
It is a bit difficult to get my head around this, since I am again missing the above mentioned component schema.

Thanks a lot for any pointers!
I am happy to provide any additional information!

On what machine is the deployment running, is there enough RAM for it (8GB). Have you checked jicofo logs?

Thanks a lot for your response.
I forgot this question. It is a KVM machine, which currently does not have 8GB or RAM. I will increase it
Are there any direct hardware requirements, so that it has problems running in a virtual machine?

I will check the log.

It’s not running on a VM that’s a problem it’s the fact that some of the components (jicofo and JVB) can be RAM hungry.

Thanks @saghul, @damencho

I updated the machine to 12GB and 4 cores. Indeed the website loads really quick now.
I checked the logfile /var/log/jitsi/jicofo.log.

Mär 15, 2020 1:46:36 PM org.jitsi.utils.logging.LoggerImpl log
WARNUNG: Skipped empty cmd line argument: domain=
Mär 15, 2020 1:46:36 PM org.jitsi.utils.logging.LoggerImpl log
WARNUNG: Skipped empty cmd line argument: port=
Mär 15, 2020 1:46:36 PM org.jitsi.utils.logging.LoggerImpl log
WARNUNG: Skipped empty cmd line argument: secret=
Mär 15, 2020 1:46:36 PM org.jitsi.utils.logging.LoggerImpl log
WARNUNG: Skipped empty cmd line argument: user_name=
Mär 15, 2020 1:46:36 PM org.jitsi.utils.logging.LoggerImpl log
WARNUNG: Skipped empty cmd line argument: user_domain=
Mär 15, 2020 1:46:36 PM org.jitsi.utils.logging.LoggerImpl log
WARNUNG: Skipped empty cmd line argument: user_password=
Exception in thread "main" org.jitsi.cmd.ParseException: Some of required arguments were not specified: [secret]
        at org.jitsi.cmd.CmdLine.parse(CmdLine.java:130)
        at org.jitsi.jicofo.Main.main(Main.java:118)

Hm, I was not told, I have to configure something else. But what?
The config file
/etc/jitsi/jicofo/config looks like this:

# Jitsi Conference Focus settings
# sets the host name of the XMPP server
JICOFO_HOST=localhost

# sets the XMPP domain (default: none)
JICOFO_HOSTNAME=meet.mydomain.it

# sets the secret used to authenticate as an XMPP component
JICOFO_SECRET=mysecret

# sets the port to use for the XMPP component connection
JICOFO_PORT=5347

# sets the XMPP domain name to use for XMPP user logins
JICOFO_AUTH_DOMAIN=auth.meet.mydomain.it

# sets the username to use for XMPP user logins
JICOFO_AUTH_USER=focus

# sets the password to use for XMPP user logins
JICOFO_AUTH_PASSWORD=myothersecret

# extra options to pass to the jicofo daemon
JICOFO_OPTS=""

# adds java system props that are passed to jicofo (default are for home and logging config file)
JAVA_SYS_PROPS="-Dnet.java.sip.communicator.SC_HOME_DIR_LOCATION=/etc/jitsi -Dnet.java.sip.communicator.SC_HOME_DIR_NAME=jicofo -Dnet.java.sip.communicator.SC_LOG_DIR_LOCATION=/var/log/jitsi -Djava.util.logging.config.file=/etc/jitsi/jicofo/logging.properties"

What am I missing?

Wait a second. THis is an old error message. With current connections, the log file does not contain anything.

Users still can not see each other in one room.

A new test with several machines was now successful.
Not quite sure what it was. But thanks a lot for all the help.