Patching Prosody. Does prosody version 0.11.5 really requires prosody-trunk version 747?

I am using Ubuntu 18.04 on hosted machine at Digital Ocean. All ports are opened.
I see that in the documentation here it is said that you need to install prosody-trunk version 747 in order to get the jitsi-meet-token to work.
But when i install the patch on version Prosody 0.11.5 its gives the following error:
prosody-trunk conflicts with prosody
I tried all version of prosody-trunks all gives the same error. Just fyi here is the error output.
root@meet:~# dpkg -i prosody-trunk_1nightly1315-1~bionic_amd64.deb
dpkg: regarding prosody-trunk_1nightly1315-1~bionic_amd64.deb containing prosody-trunk:
prosody-trunk conflicts with prosody
prosody (version 0.11.5-1~bionic6) is present and installed.
prosody provides prosody and is present and installed.

dpkg: error processing archive prosody-trunk_1nightly1315-1~bionic_amd64.deb (--install):
conflicting packages - not installing prosody-trunk
Errors were encountered while processing:
prosody-trunk_1nightly1315-1~bionic_amd64.deb

Here is the list of Prosody version details.

root@meet:~# prosodyctl about
Prosody 0.11.5

Prosody directories
Data directory:     /var/lib/prosody
Config directory:   /etc/prosody
Source directory:   /usr/lib/prosody
Plugin directories:
  /usr/share/jitsi-meet/prosody-plugins/
  /usr/lib/prosody/modules/ 

#Lua environment
Lua version: Lua 5.2

Lua module search paths:
/usr/lib/prosody/?.lua
/usr/local/share/lua/5.2/?.lua
/usr/local/share/lua/5.2/?/init.lua
/usr/local/lib/lua/5.2/?.lua
/usr/local/lib/lua/5.2/?/init.lua
/usr/share/lua/5.2/?.lua
/usr/share/lua/5.2/?/init.lua
/root/.luarocks/share/lua/5.2/?.lua
/root/.luarocks/share/lua/5.2/?/init.lua

Lua C module search paths:
/usr/lib/prosody/?.so
/usr/local/lib/lua/5.2/?.so
/usr/lib/x86_64-linux-gnu/lua/5.2/?.so
/usr/lib/lua/5.2/?.so
/usr/local/lib/lua/5.2/loadall.so
/root/.luarocks/lib/lua/5.2/?.so

LuaRocks: Installed (2.4.2)

#Network

Backend: select

#Lua module versions
lfs: LuaFileSystem 1.6.3
lxp: LuaExpat 1.3.0
socket: LuaSocket 3.0-rc1
ssl: 0.6
`
My question is do we really need to follow the patch section on Prosody version 0.11.5.