Participants or sesions how Load Balancing between VideoBridges

How can I distribute the number of participants on a system with 1master server 5 videobridge server? Or where can they be adjusted? Does not evenly distribute. Takes all participants to the same videobridge server. When I turn off all videobridge servers and turn on any of them, it picks up all sesions at the open videobridge server. it even transfers ongoing conference participants, but normally it does not distribute them between servers, it transfers all participants or sesions to whichever one it finds.
How can I fix this issue.
Thanks

By default one meeting goes to the same bridge. If you want to distribute one meeting between few bridges you need to enable octo https://github.com/jitsi/jitsi-videobridge/blob/master/doc/octo.md

Thank you damencho,
In this post as I understand it, we may use videobridge according to participants geographic places via setting up Octo. But All participants from same region in my case.
4 core and 24 Gb Ram machine, behind 400mb metro internet connection, but more than 13-15 people system is not working properly, so i need to distrubute them other videobridges but how?

    org.jitsi.videobridge.REGION=region1 # the region that the jitsi-videobridge instance is in
    ```

Octo is the way to distribute one meeting across several bridges in one region. This is how meet.jit.si is currently running.

Dear Damian,
All participant are communicating with each other without any problem.
When I stopped jitsi-videobridge2 services on main jitsi server, conferance is still continues on other additional JitsiVideoBridge2 or JitsiVideoBridge3 Servers but nobody can’t see anyone without himself on the own screen. Only can see own video camera.
When I start videobridge2 service on the main jitsi server and stop videobridge2 services on the additional jitsivideobridge server, everything is back to normal.

By the way I saw that; we working behind NAT. Internal devices or connected via SSL-VPN no problem. when someone connected to conferance from external, have this problem.
I added second videobridge server log file.

What is the problem? Thank you.jvb.log (53.9 KB)

Make sure port forwarding works for the rest of the bridges and they advertise correct public addresses

There is an public ip routing for the main jitsimeetserver but not for the other two videobridge servers. Is an public ip address required in these two servers?

Yep, or you can use same address but different port and you need port forwarding for those and the bridge announce correct public address so clients can reach it on the custom single port.

I installed JVB servers accordance of this manual https://github.com/jitsi/jitsi-meet/wiki/jitsi-meet-load-balancing-installation-Ubuntu-18.04-with-MUC-and-JID
my installation steps are in full compliance with this document.
Where should the public or private ip address be entered? I can’t see any field on this doc.
Thank you.

Checkout the advanced section of the quick install guide.

Thank you @damencho
Let me summarize briefly what I did and explain the new problem;
I installed Jitsi Meet Server on 8 core CPU 16 Gb Ram VM ubuntu, using “Jitsi Meet quick install” methot as this link: https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md
The Server behind NAT and port forwarding is ok. And I added following extra line on the /etc/jitsi/videobridge/sip-communicator.properties
org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=<Local.IP.Address>
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=<Public.IP.Address>

I Used my wildcard cert.
Inter_plain authentication is ok.

After 15 participants connect to meeting video conferencing began to shake … like freezing, video not appearing, sound interruptions etc… in some people… after that,

  • Set default video resolution to 480
  • disabled the blue “i am talking dots”
  • disabled the blurry video background

after that I check System working fine but eventually poor productivity for 40-50 participants

So I installed jitsi meet load balancing on new 2 pieces Ubuntu 18.04 with MUC and JID methot as this link : https://github.com/jitsi/jitsi-meet/wiki/jitsi-meet-load-balancing-installation-Ubuntu-18.04-with-MUC-and-JID

After that I setup Octo (cascaded bridges) using “SplitBridgeSelectionStrategy” as this link : https://github.com/jitsi/jitsi-videobridge/blob/master/doc/octo.md

When 4 people attend the meeting, OCTO distributes them to each server. I can see them by using “tcpdump -i any src port 10000” on every server . OCTO Works.

Now; I’m facing a problem;

Only people on the same server can hear and see each other. If a participant in the same conference with others, but on JVB2 or JVB3, the audio and video do not go to others.

Do you have firewall between bridges ?

No, all servers are running on same vlan and network only different physical machine. All are behind one firewall.

Not sure what can be wrong maybe @bbaldinoand @Boris_Grozev can have better ideas.

Hello,
I have the same exact problem with Octo. Only people on the same server can hear and see each other. and I see no traffic between the JVBs on port 4096. (I am using the latest sable version btw).

when I start a JVB I see this line in jicofo.log :

Jicofo 2020-05-05 19:15:56.572 INFO: [94] org.jitsi.jicofo.xmpp.BaseBrewery.processInstanceStatusChanged().330 Added brewery instance: jvbbrewery@internal.auth.mydomain.fr/v-webconf-jvb-inter-pre-02
Jicofo 2020-05-05 19:15:56.573 WARNING: [94] org.jitsi.jicofo.bridge.BridgeSelector.log() No pub-sub node mapped for jvbbrewery@internal.auth.mydomain.fr/v-webconf-jvb-inter-pre-02
Jicofo 2020-05-05 19:15:56.575 INFO: [94] org.jitsi.jicofo.bridge.BridgeSelector.log() Added new videobridge: Bridge[jid=jvbbrewery@internal.auth.mydomain.fr/v-webconf-jvb-inter-pre-02, relayId=null, region=null, stress=0.00]
Jicofo 2020-05-05 19:15:56.577 INFO: [52] org.jitsi.jicofo.bridge.JvbDoctor.log() Scheduled health-check task for: jvbbrewery@internal.auth.mydomain.fr/v-webconf-jvb-inter-pre-02

is it normal to get relayId=null, region=null in jicofo log ?

PS : all my JVBs belong to the same vlan

Hello,
Is there anyone who can help me with this?
The same problem persists.


@damencho @Boris_Grozev

Hello, if I have 2 videobridges in one region, (in my case it is in kubernetes cluster), should I have different BIND_PORT? For example on jvb1 4096 and on jvb2 4097?