Participants can't see or hear each other

I had a working instance of jitsi set up on my home server. I tested it out with a three-way meeting between my phone (jitsi app - no wifi so it went out over the cell network), my workstation and another person not on my home network. That went fine apart from feedback between my workstation and my phone when I didn’t have the phone’s mic muted.

All I’ve done to the server is some updates (Debian/Buster - stable) over the last couple of weeks but now I can’t even get the phone to work properly. Worse, a scheduled family get together flopped when all we could do was use the chat function. No one could see or hear anyone else. We just could see our own screens and the initials of the other participants.

I tried retesting it with my phone + workstation and I get exactly the same problem. I can connect to the meeting but can’t see my other device’s video feed nor hear its audio.

The other people used a variety of iPhone, Android, Mac, Windows and Linux systems so this is probably not an issue with their devices. I’ve checked the router port forwarding settings and they haven’t changed. I’ve rebooted the server but that didn’t help.

As a newbie to running a jitsi server, I don’t really know how to fix this. The suggestions I’ve seen for similar problems don’t seem to be related as they were client-side. Any ideas?

  • What are the forwarded ports?

  • Could you paste /etc/jitsi/videobridge/sip-communicator.properties

I’m forwarding 9, 22, 80, 443, 5349 & 10000 - the latter being UPD only

#cat /etc/jitsi/videobridge/sip-communicator.properties
org.ice4j.ice.harvest.DISABLE_AWS_HARVESTER=true
org.ice4j.ice.harvest.STUN_MAPPING_HARVESTER_ADDRESSES=meet-jit-si-turnrelay.jitsi.net:443
org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=muc
org.jitsi.videobridge.xmpp.user.shard.HOSTNAME=localhost
org.jitsi.videobridge.xmpp.user.shard.DOMAIN=auth.meet..
org.jitsi.videobridge.xmpp.user.shard.USERNAME=jvb
org.jitsi.videobridge.xmpp.user.shard.PASSWORD=
org.jitsi.videobridge.xmpp.user.shard.MUC_JIDS=JvbBrewery@internal.auth.meet..
org.jitsi.videobridge.xmpp.user.shard.MUC_NICKNAME=

Looking at the above, I have no idea who jvb / JvbBrewery is. I’m guessing it’s some random jitsi thing.

I’m wondering if some service didn’t restart after I rebooted my server (I’m pretty sure I did that at least once between the initial working jitsi and its current partially-operating state. Is there a list of required services somewhere?

  • prosody
  • jicofo
  • jitsi-videobridge2
  • nginx
  • coturn (optional)

Thanks. Using ps aux | grep on the server, I get

  • prosody is running
  • a lot of output for jicofo indicating that it is a java process (starts with java -Xmx3072m -XX:+He…) (completely fills the terminal window - more than a page of text in the line)
  • jitsi-videobridge2 isn’t running but jitsi-videobridge is running, again as a java process (starts with java -Xmx3072m -XX:+Us…) (4 lines of text)
  • I’m using apache2 and it is running - as expected since the meet site seems to be there.
  • coturn isn’t running

So things seem to look OK from that perspective.

I just remembered that I also installed nextcloud after I got jitsi working initially. I haven’t done anything with it other than create two user accounts. Would nextcloud interfere with jitsi?

Weird. I did an apt reinstall jitsi-meet on my server and it’s back working again. I rebooted the server and it is still working. Tried logging into the nextcloud server and it seems OK too.