Participant has stopped the camera

Hi,

i installed the cool jitsi-meet and managed to start on my own debian server with apache and self installed let’s encrypt certificate. I did not follow the installation description from github because I alreday had certbot on my server.

jitsi-meet seems to start correctly, but if another participant enter my “room” we are not able to see and hear each other. The left window is black and two signes indicate “Participant is muted” and “Participant has stopped the camera”.

In the javascript log I only see this error message:

VM138 lib-jitsi-meet.min.js:6 2020-03-22T11:32:56.025Z [JitsiConference.js] <e.sendMessage>: Failed to send a ping request or response.

Any suggestions what went wrong?

Thanks
Markus

Follow the advanced section in https://jitsi.org/qi.

Thank you for your reply, but I am not behind a NAT. My site is available from public.

For some reason jicofo is not connected and cannot send invites to client. Check jicofo logs. How did you install? Os version? Steps you followed?

The jicofo.log:

Jicofo 2020-03-22 22:41:11.146 SEVERE: [113] org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.doConnect().309 Failed to connect/login: javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
org.jivesoftware.smack.SmackException: javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

I installed via the debian package manager:

  1. Setup virtual host in apache
  2. apt install jitsi-meet
  3. Generate SSL cert with certbot

Did you install/uninstall at some point?

Try sudo update-ca-certificates -f

Yes!
I first tried the docker container, but this didn’t work. After that I installed via Debian Package manager and had a lot of problems because docker snippets didn’t went away with uninstall…

Now it works! Huge thanks!

Regarding your note, I have reinstalled everything. I think the problem was my own “let’s encrypt” certificate and the choice “I will use my own certificate” during the installation process…

I have the same problem, though I didn’t try using docker (I initially used the machine’s hostname instead of the FQDN).
Everything on my server seems to work except audio/video visibility. Updating certificates cannot have been the solution. Could you please elaborate on what were your last steps that made it work? Cheers.

In my case I first installed a “let’s encrypt” certificate and after that jitsi. I thought I will choose “I will use my own certificate” during the installation process. But this resulted in wrong entries in the virtual host configuration. So jitsy coudn’t find his designated files.
So better purge everything and install from the beginning.