P2P Settings

Dear All

My users connect to the meeting from different networks across the globe. Sometimes their network speed isnt that good.
90% of the time its 1 to 1 meeting, So i enabled p2p in config.js file.
My users are saying they see 'User is having network connection issues" most of the time.
But the users are also saying their network bandwidth is good.

What do you think is the issue?

Should i disable p2p in config.js for ? will that improve?

Generally enabling P2P is a good thing, that’s why it’s enabled by default. Enabliong it, however, doesn’t guarantee it will work. You can check by hovering on the “GSM bars” indicator and clicking “Show More” if the remote endpoint doesn’t have “p2p” at the end, you are still using the server.

You could enable TURN to make sure p2p always succeeds: https://github.com/jitsi/jitsi-meet/blob/master/doc/turn.md

Thanks Saghul

Sometimes the Network signal for the user shows low and lost. I have also noticed this when the screen sharing is enabled.

I already have my p2p.useStunTurn: true

If the P2p is enabled and p2p.useStunTurn: true and if the User connection is low , will it switch to using JVB?

Another Question:
What happens if my p2p is not enabled ? Will it use JVB always? Is that good if i am going to have 1000 (1:1) concurrent meetings

If it shows there is packet-loss, there is not much you can do, the network is bad, and things will go bad.

As I’ve said earlier, that’s not enough. You may need to deploy a TURN server.

If P2P is noe enabled or not in use, the JVB will be used always. Generally it’s better to get P2P working to avoid the extra processing.

I setup turn server and enabled p2p like below

{
useStunTurn: true,
p2p: {
enabled: true,
useStunTurn: true,
stunServers: [
{ urls: ‘stun:stun.mydomain.com:443’ },
{ urls: ‘stun:stun1.l.google.com:19302’ },
{ urls: ‘stun:stun2.l.google.com:19302’ }
],

    preferH264: false

},

}
and also add turn credentials to the prosody

but traffic is not going on my turn server it always going through jvb.