Override Jitsi ToolBar Buttons Config

The newer stable release uses toolbar buttons from config.js file instead of interface_config. Does that mean we can override what button we would like to have and what not from the url directly?

Something like:
#config.toolbarButtons=[‘microphone’,‘camera’,‘chat’,‘desktop’,‘hangup’,‘mute-everyone’,‘shortcuts’]

Overriding toolbar buttons is still done through interface config, which has always worked through url too.

Example: https://meet.jit.si/WetMeatsReviseAllegedly#interfaceConfig.TOOLBAR_BUTTONS=[“microphone”,“camera”,“desktop”,“participants-pane”,“hangup”]

1 Like

Interesting. I probably missed it previously. So then, do you know if it works similarly for urls using jwt.

Example:
meet.jit.si/WetMeatsReviseAllegedly#interfaceConfig.TOOLBAR_BUTTONS=[“microphone”,“camera”,“desktop”,“participants-pane”,“hangup”]?jwt=xxxxxx

This is how it should be?

The Query string (?x=1) should come before the #:

https://meet.domain.com/MyMeeting?jwt=...& somethingElse=... #config.option=something &config.somethingElse=1

Also this post may help, if you haven’t seen it:

2 Likes

Interface config is now deprecated, but if you have setting that will be with priority, but you can drop it and just use the config.js

1 Like

But overriding toolbar buttons through url doesn’t work with config.js yet right? At least I can’t make it work.

Should work, do you have toolbar settings in interface config?

I’m trying this on meet.jit.si. I don’t know the configuration there.

on meet.jit.si you can check from the browser by looking the HTML source of the page, it uses config.js and it should work maybe a problem with the syntax

Oh yeah it definitely works with config override as well. No idea why it didn’t work for me before.