Other users cannot join my server

Hi

I have installed jitsi-meet on RPi running ubuntu 20.04.

The installation went fine and I can connect to my server through my dns. When I send invites to others they cannot join the conference. I am only using it for one-to-one video calls.

I have tried web browsers and android app and neither can access the server.

I purged my server when this happened first and followed a complete install but the same issue has occured. I have opened ports 80, 443, 10000 on my router but this have not helped.

I am not sure if it is a certificate issue but I my /etc/nginx/sites-availabel/DOMAIN.conf file appears to be fine also.

Any ideas what could be wrong?

Thanks

If you’ve also opened those ports on your firewall and are still having problems, check out the Advanced Configuration section of the Quick Install Guide.

it’s not clear if:

  • they can’t see the login page with the welcome
  • they can see the welcome but after entering the room name can’t join it

Please be more precise in your problem description.

Thanks for getting back. I have completed full set-up and added the advanced configuration changes to various /etc/… files.

I can open jitsi on my browser and create a room. When I invite others however, they cannot join. The message on the other users browser is:

This site can’t provide a secure connection

ERR_SSL_PROTOCOL_ERROR.

I have completed the letsencrypt.sh procedure and have a file in the proper place. There seems to be a problem with my cert.

Thanks for help.

at this point you can’t even be sure that the computer that your ‘other users’ are connecting to is your Jitsi server. Is there a redirection from your router / FAI box from port 443 to your computer ? If you do a tcpdump on the server when people are trying to connect do you see connections packets (SYN) ? Can you use a test site such as

if your problem is really with the certificate, at the let’sencrypt forum that’s what they will ask for.

I typed in my dns and nothing appears. What am I supposed to get back?

wait that your site appears in ‘current’. Then click on it.

I seem to have received this output in one section

Fatal: Check of /.well-known/acme-challenge/random-filename has a timeout. Creating a Letsencrypt certificate via http-01 challenge can't work. You need a running webserver (http) and an open port 80. If it's a home server + ipv4, perhaps a correct port forwarding port 80 extern ⇒ working port intern is required. Port 80 / http can redirect to another domain port 80 or port 443, but not other ports. If it's a home server, perhaps your ISP blocks port 80. Then you may use the dns-01 challenge. Trouble creating a certificate? Use https://community.letsencrypt.org/ to ask.

well, that’s pretty much self-explanatory. You can’t have a Let-Encrypt certificate managed by your server if Let’sEncrypt server can’t access it on port 80. So create a redirect from your router/box from port 80 to your Jitsi server and check access from Internet to the .well-known/acme-challenge (create a dummy file in it then try to browse to it from the outside of your network)

How do I do this exactly. I have the port open on router so do I have to change some file in the server or something on my dns host?

First I’d test from the outside of the network do

curl http://mydomain.com

and see with tcpdump if there is some packets coming on the port 80 of your server. If not the redirect is not working.

If there are packets, then it’s time to do a directed query.
wget http://mydomain.com/.well-known/acme-challenge/file.txt
after having created a file.txt file in the directory of the server pointed by the URL (normally under /usr/share/jitsi-meet if you did not change the default setup)

I have tried a full re-install. I am now getting a HTTP-01 when I try to run the letsencrypt.sh script.

The curl http://my.domain.com tells me I have a self-signed certificate which is what I have installed with the new instance.

you can use a self-signed certificate if you ask of users that they accept it in the browser but this will not be possible with Android phones.