org.jitsi.impl.neomedia.transform.RetransmissionRequesterImpl.log() format_not_found on H264


#1

Hello. I try to use H264 since I need to support Safari. When I set preferH264: true to the conference options, I have a black screen on a viewer side. The video track.readyState says it is 'live'.

There are a lot of lines in jvb.log:

JVB 2018-08-31 14:14:56.301 WARNING: [1003350] org.jitsi.impl.neomedia.transform.RetransmissionRequesterImpl.log() format_not_found,stream_hash=1046222272

The SDP on the viewing side is:

m=video 9 RTP/SAVPF 107 100 101 96 99 97
c=IN IP4 0.0.0.0
a=rtpmap:107 H264/90000
a=rtpmap:100 VP8/90000
a=rtpmap:101 VP9/90000
a=rtpmap:96 rtx/90000
a=rtpmap:99 rtx/90000
a=rtpmap:97 rtx/90000
a=fmtp:107 level-asymmetry-allowed=1;packetization-mode=1;profile-level-id=42e01f
a=fmtp:96 apt=100
a=fmtp:99 apt=107
a=fmtp:97 apt=101
a=rtcp:9 IN IP4 0.0.0.0
a=rtcp-fb:107 transport-cc
a=rtcp-fb:107 ccm fir
a=rtcp-fb:107 nack
a=rtcp-fb:107 nack pli
a=rtcp-fb:100 transport-cc
a=rtcp-fb:100 ccm fir
a=rtcp-fb:100 nack
a=rtcp-fb:100 nack pli
a=rtcp-fb:101 transport-cc
a=rtcp-fb:101 ccm fir
a=rtcp-fb:101 nack
a=rtcp-fb:101 nack pli
a=extmap:3 http://www.webrtc.org/experiments/rtp-hdrext/abs-send-time
a=extmap:5 http://www.ietf.org/id/draft-holmer-rmcat-transport-wide-cc-extensions-01
a=setup:passive
a=mid:video
a=sendrecv
a=ice-ufrag:Ar70
a=ice-pwd:QQb95sEcv1pTgxXgnO6vcknO
a=fingerprint:sha-256 6E:63:B6:9E:6C:94:B1:54:CF:2A:EC:01:5E:C3:15:92:9F:E6:A8:69:CE:B8:91:53:A6:2B:F0:F6:25:52:49:EF
a=ice-options:trickle
a=rtcp-mux

My jitsi-videobridge is 1077-1, jicofo 1.0-425-1.

Try to stream from both Chrome 68 and Safari, it’s the same.

I saw the issue with H264, and I’m not sure, if https://github.com/jitsi/jitsi-videobridge/commit/be5472c9f16f6a8a9710b38b49ec21094d74344e commit is included in my 1077-1 version, installed via apt-get


#2

Here is my presenter SDPs:

setRemoteDescription: https://pastebin.com/Hc1FAqjG
setLocalDescription: https://pastebin.com/jVzWuyWd

As I understand, Chrome doesn’t accept H264 in the initial SDP from Jitsi.

But, if we look at the statistic, it says the codec is H264: https://pastebin.com/eRcfVsUM

Here is more logs from jvb: https://pastebin.com/Dg3qjaPe

I’m pretty frustrated


#3

No, it is not included in 1077. Update to unstable version where h264 should be working.


#4

You’re right. Installed an unstable version - H264 works like a charm. Thanks