opusMaxAverageBitrate not working anymore in 2.0.5870?

I have performed a fresh install, using latest 2.0.5870. Before this version I was able to set audio quality with opusMaxAverageBitrate, but now audio bitrate doesn’t go over 32kbs in mono, and 64 in stereo, no matter what I type in config. This is a terrible quality for me, because I’m a music/pro audio teacher. Any suggestions?
EDIT:
same thing happens on meet.jit.si, with proper config appended to url

There have been some changes regarding audio sharing and the opusMaxAverageBitrate flag has apparently been moved to an audioQuality object:

Hi plokta, thanks, already tried to move opusMaxAverageBitrate in and out from that new object; got the same behavior, audio fixed at 32 and 64 kbs

We tested it and seems fine. If you open chrome://webrtc-internals before doing the test you can see the result sdp and everything is set as expected:


Both old config and new under audioQuality one should work.

First of all, big thanks for this beautiful project!
I see, but checking “by ear” and looking at stats and graphs, I see that audio bitrate doesn’t change if I change opusMaxAverageBitrate values. For me, it’s fixed at 64 kbit when stereo=true, and 32 if stereo=false. This two screenshots are taken first with opusMaxAverageBitrate=6000, and then with 510000. They do not change.
Also, stereo is not “true stereo”; in fact, signals for left and right paths are identical. The only thing that changes in stereo is bitrate (doubling), but samples are summed to mono. My test is this audio file: the “sender” hears words “left” from left earphone, and “right” from right. “Receivers” hear center sounds, no panning at all, no alternating ears.
Anyway, thank you for your interest!

2021-05-17 (3)
2021-05-17

So if you checked and the sdp was correctly passed to the browser, there is nothing we can do. From there you need to debug the browser part …

Thank you for your time; yes, I’ll do, but for now I can confirm that previous stable release works well (but still no stereo sound)

Is HD Audio intended only when using sharing audio feature, and not while in “normal” talking?

I’m having the same issue. I could only see how to manipulate the maxplaybackrate in Apprtc but switching that value to 8000 from 48000 dropped the bitrate from 64kbps to 24kbps with a noticeable loss in quality. So signaling that parameter appears to work.
here’s the sdp a line from apprtc:
a=fmtp:111 minptime=10;useinbandfec=1;stereo=1;maxplaybackrate=8000

Here’s the a line from the jitsi session setup that doesn’t seem to have any effect:
a=fmtp:111 minptime=10; useinbandfec=1; stereo=1; opusMaxAverageBitrate=510000;

Is it possible that trailing semicolon is violating syntax?