Options on menu

Hi, I’ve installed jitsi-meet Version: 1.0.4314-1 on my debian 9 server.
When I start a conference on https://jitsi.org/ I can see different menu options
For example, I see:
start live stream
mute everyone
On my server they aren’t

Is there a way to make it appear?

Basic:
The mute everyone appear if you install jitsi-meet from unstable.
To install the unstable packages you follow the normal quick install guide:

https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md

but replace stable with unstable when you add the repository
echo 'deb https://download.jitsi.org unstable/' >> /etc/apt/sources.list.d/jitsi-unstable.list

Advanced:
The mute everyone also appear if you compile and install your own jitsi-meet from the lastest git sourcecode:

On my debian server i have done the following:

  1. first checkout the jitsi-meet git sourcecode
    git clone https://github.com/jitsi/jitsi-meet

read the how to build from sourcecode instructions

it will tell you what packages are needed to be installed on debian

>>> https://github.com/jitsi/jitsi-meet/blob/master/doc/development.md

  1. add a deploy-local.sh file inside the jitsi-meet directory that contains commands to copy the built jitsi-meet into /usr/share/jitsi-meet
    my deploy-local.sh script contain:
    #!/bin/bash
    echo “Deploying jitsi-meet!”
    sudo cp interface_config.js /usr/share/jitsi-meet/
    sudo cp libs/* /usr/share/jitsi-meet/libs/
    sudo cp css/* /usr/share/jitsi-meet/css/

  2. run make to build and deploy the latest jitsi-meet web interface!

You can customize the user-interface once you are able to deploy the latest jitsi-meet sourcecode on your server.
First you can enable and disable most toolbar buttons by editing the jitsi-meet/interface_config.js
You also have the possibility to customize the whole interface by editing the files under jitsi-meet/react/

1 Like

Thanks!!
With the “Basic” mode the Mute-everyone option appears, but start live stream option not appear.
Any suggestion?

To make the livestreaming option appear:

First check the file
/usr/share/jitsi-meet/interface_config.js
it contain a block that enable TOOLBAR_BUTTONS and make sure it contain ‘livestreaming’,

/**
 * The name of the toolbar buttons to display in the toolbar. If present,
 * the button will display. Exceptions are "livestreaming" and "recording"
 * which also require being a moderator and some values in config.js to be
 * enabled. Also, the "profile" button will not display for user's with a
 * jwt.
 */
TOOLBAR_BUTTONS: [
    'microphone', 'camera', 'fullscreen',
    'tileview', 'hangup', 'profile', 'chat',
    'recording', 'livestreaming',
    'videoquality', 'settings',
    'shortcuts',
    'help' 
],

Then check the jitsi-meet config.js file that is by default located at
/etc/jitsi/meet/*-config.js
and make sure that this file contain

liveStreamingEnabled: true, // If you want to enable live streaming

Then finally check that you are a moderator in the conference to see the livestreaming button.

Thanks!
I can see the option, but show me an error:
Live Streaming failed to start ( red color )

Is there an other config ?

I think you need to configure “jibri” for streaming (and optionally recording) to work, when you are using your own server.