Only 180p or 320p regardless if i higher Settings

Hi,
in /etc/jitsi/meet/HOSTNAME-config.js i have set:

   maxBitratesVideo: {
       low: 500000,
       standard: 1000000,
       high: 1500000
   },

and

// Sets the preferred resolution (height) for local video. Defaults to 720.
resolution: 720,

constraints: {
     video: {
         aspectRatio: 16 / 9,
         frameRate: {
         max: 25,
         min: 5
         },
         height: {
             ideal: 720,
             max: 1080,
             min: 480,
         }
     }
 },

But it wont take 480 in minimum. Always 180p or 360p. Images looks bad.
What am i missing?

System:

  • 8 Cores or something.
  • Ram enough
  • Bandwidth 1Gbit/s
  • My Test Locations 400mbits/ 40mbits
  • Ubuntu 20.04.2 LTS
1 Like

Do you see any BridgeChannel related errors in the browser console?

Yes, Indeed, what does that mean?

BridgeChannel.js:86 WebSocket connection to 'wss://meet.DOMAIN.COM/colibri-ws/default-id/3b5092162c2770a2/e87f9c83?pwd=2tp1shm5569a6ejnjo5k6ad066' failed: 
_initWebSocket @ BridgeChannel.js:86
Logger.js:154 2021-04-30T10:06:58.005Z [modules/RTC/BridgeChannel.js] <WebSocket.e.onclose>:  Channel closed by server
Logger.js:154 2021-04-30T10:06:58.005Z [modules/RTC/BridgeChannel.js] <WebSocket.e.onclose>:  Channel closed: 1006 
o @ Logger.js:154
BridgeChannel.js:86 WebSocket connection to 'wss://meet.DOMAIN.COM/colibri-ws/default-id/3b5092162c2770a2/e87f9c83?pwd=2tp1shm5569a6ejnjo5k6ad066' failed: 
_initWebSocket @ BridgeChannel.js:86
Logger.js:154 2021-04-30T10:07:01.967Z [modules/RTC/BridgeChannel.js] <WebSocket.e.onclose>:  Channel closed by server
Logger.js:154 2021-04-30T10:07:01.967Z [modules/RTC/BridgeChannel.js] <WebSocket.e.onclose>:  Channel closed: 1006 
o @ Logger.js:154
Logger.js:154 2021-04-30T10:07:04.029Z [modules/RTC/BridgeChannel.js] <l._send>:  Bridge Channel send: no opened channel.
o @ Logger.js:154
Logger.js:154 2021-04-30T10:07:04.029Z [JitsiConference.js] <u.sendMessage>:  Failed to send E2E ping request or response. undefined
o @ Logger.js:154
Logger.js:154 2021-04-30T10:07:06.436Z [features/video-quality] <Object.D.d.register.deepEquals [as listener]>:  Video quality level for thumbnail height: 534, is: 360, override: false, max full res N: 2
Logger.js:154 2021-04-30T10:07:06.437Z [modules/xmpp/JingleSessionPC.js] <w.setReceiverVideoConstraint>:  JingleSessionPC[p2p=false,initiator=false,sid=d0tq8qm2tat88] setReceiverVideoConstraint - max frame height: 360
Logger.js:154 2021-04-30T10:07:06.437Z [features/video-quality] <Sa>:  setReceiverVideoConstraint: 360
BridgeChannel.js:86 WebSocket connection to 'wss://meet.DOMAIN.COM/colibri-ws/default-id/3b5092162c2770a2/e87f9c83?pwd=2tp1shm5569a6ejnjo5k6ad066' failed: 
_initWebSocket @ BridgeChannel.js:86
Logger.js:154 2021-04-30T10:07:09.963Z [modules/RTC/BridgeChannel.js] <WebSocket.e.onclose>:  Channel closed by server
Logger.js:154 2021-04-30T10:07:09.963Z [modules/RTC/BridgeChannel.js] <WebSocket.e.onclose>:  Channel closed: 1006 
o @ Logger.js:154
Logger.js:154 2021-04-30T10:07:14.031Z [modules/RTC/BridgeChannel.js] <l._send>:  Bridge Channel send: no opened channel.
o @ Logger.js:154
Logger.js:154 2021-04-30T10:07:14.031Z [JitsiConference.js] <u.sendMessage>:  Failed to send E2E ping request or response. undefined
o @ Logger.js:154
Logger.js:154 2021-04-30T10:07:14.716Z [modules/RTC/BridgeChannel.js] <l._send>:  Bridge Channel send: no opened channel.
o @ Logger.js:154
Logger.js:154 2021-04-30T10:07:24.029Z [modules/RTC/BridgeChannel.js] <l._send>:  Bridge Channel send: no opened channel.
o @ Logger.js:154
_send @ BridgeChannel.js:383
sendMessage @ BridgeChannel.js:190
sendChannelMessage @ RTC.js:936
ie.sendEndpointMessage @ JitsiConference.js:2519
ie.sendMessage @ JitsiConference.js:2563
(anonymous) @ JitsiConference.js:349
sendRequest @ e2eping.js:93
Logger.js:154 2021-04-30T10:07:24.029Z [JitsiConference.js] <u.sendMessage>:  Failed to send E2E ping request or response. undefined
o @ Logger.js:154
(anonymous) @ JitsiConference.js:352
sendRequest @ e2eping.js:93
Logger.js:154 2021-04-30T10:07:24.714Z [modules/RTC/BridgeChannel.js] <l._send>:  Bridge Channel send: no opened channel.
o @ Logger.js:154
_send @ BridgeChannel.js:383
sendMessage @ BridgeChannel.js:190
sendChannelMessage @ RTC.js:936
ie.sendEndpointMessage @ JitsiConference.js:2519
ie.broadcastEndpointMessage @ JitsiConference.js:2529
_broadcastLocalStats @ ConnectionQuality.js:468
_updateLocalStats @ ConnectionQuality.js:540
a.emit @ events.js:157
m._processAndEmitReport @ RTPStatsCollector.js:868
m.processStatsReport @ RTPStatsCollector.js:726
(anonymous) @ RTPStatsCollector.js:378
BridgeChannel.js:86 WebSocket connection to 'wss://meet.DOMAIN.COM/colibri-ws/default-id/3b5092162c2770a2/e87f9c83?pwd=2tp1shm5569a6ejnjo5k6ad066' failed: 
_initWebSocket @ BridgeChannel.js:86
t @ BridgeChannel.js:105
Logger.js:154 2021-04-30T10:07:25.978Z [modules/RTC/BridgeChannel.js] <WebSocket.e.onclose>:  Channel closed by server
Logger.js:154 2021-04-30T10:07:25.978Z [modules/RTC/BridgeChannel.js] <WebSocket.e.onclose>:  Channel closed: 1006 
o @ Logger.js:154
e.onclose @ BridgeChannel.js:359
Logger.js:154 2021-04-30T10:07:28.022Z [features/video-quality] <Object.D.d.register.deepEquals [as listener]>:  Video quality level for thumbnail height: 347, is: 180, override: false, max full res N: 2
Logger.js:154 2021-04-30T10:07:28.023Z [modules/xmpp/JingleSessionPC.js] <w.setReceiverVideoConstraint>:  JingleSessionPC[p2p=false,initiator=false,sid=d0tq8qm2tat88] setReceiverVideoConstraint - max frame height: 180
Logger.js:154 2021-04-30T10:07:28.024Z [features/video-quality] <Sa>:  setReceiverVideoConstraint: 180
Logger.js:154 2021-04-30T10:07:34.030Z [modules/RTC/BridgeChannel.js] <l._send>:  Bridge Channel send: no opened channel.
o @ Logger.js:154
_send @ BridgeChannel.js:383
sendMessage @ BridgeChannel.js:190
sendChannelMessage @ RTC.js:936
ie.sendEndpointMessage @ JitsiConference.js:2519
ie.sendMessage @ JitsiConference.js:2563
(anonymous) @ JitsiConference.js:349
sendRequest @ e2eping.js:93
Logger.js:154 2021-04-30T10:07:34.031Z [JitsiConference.js] <u.sendMessage>:  Failed to send E2E ping request or response. undefined
o @ Logger.js:154
(anonymous) @ JitsiConference.js:352
sendRequest @ e2eping.js:93
Logger.js:154 2021-04-30T10:07:34.717Z [modules/RTC/BridgeChannel.js] <l._send>:  Bridge Channel send: no opened channel.
o @ Logger.js:154
_send @ BridgeChannel.js:383
sendMessage @ BridgeChannel.js:190
sendChannelMessage @ RTC.js:936
ie.sendEndpointMessage @ JitsiConference.js:2519
ie.broadcastEndpointMessage @ JitsiConference.js:2529
_broadcastLocalStats @ ConnectionQuality.js:468
_updateLocalStats @ ConnectionQuality.js:540
a.emit @ events.js:157
m._processAndEmitReport @ RTPStatsCollector.js:868
m.processStatsReport @ RTPStatsCollector.js:726
(anonymous) @ RTPStatsCollector.js:378


root@meet:~# ufw status
Status: active

To                         Action      From
--                         ------      ----
22                         ALLOW       Anywhere                  
80/tcp                     ALLOW       Anywhere                  
443/tcp                    ALLOW       Anywhere                  
8080/tcp                   ALLOW       Anywhere                  
3478/udp                   ALLOW       Anywhere                  
5349/tcp                   ALLOW       Anywhere                  
10000/udp                  ALLOW       Anywhere

It means you’ll never manage to request the high video layers. You need to fix that WS connection.

How can i do that?

Check your web server configuration. Are you using a reverse proxy? If so you need to add specific proxy-pass options. This applies to Docker but probably helps: Self-Hosting Guide - Docker · Jitsi Meet Handbook

@saghul on the Quick install, does web sockets need to be configured manually, or it takes care of it.

my mostly fails is only websockets with high ports.
it was always problems but suddenly now much errors out of nothing. I installed everything fine in past hm. I never really 100% fully got websockets using low port 443. TURN/STUN… But at least it still worked somehow with high ports.
Many manuals tell different ways or are outdated. the official docs not fully understandable as sometimes it just mentioned something instead of showing commands or something.

I will now install everything new my 4th time since 12 Months. Jitsi not poorly not really easy. I lost also my only two customers :smiley: They went to zoom :smiley: … But not important. I hope someday i will get this running fully.

Also docker installation image ( in the Pasts ) didn’t made a internal turn on port 443 and so on.

wahh!

And i am not linux beginner, i know quite a bit :-/

1 Like

They are configured automatically on the quick install.

Sorry, not sure I understand. WebSockets work on port 443, and that has nothing to do with STUN/TURN.

Lenusch,

I don’t know docker so I used a Virtual Machine.

I followed and found this instructions very useful. Maybe they have some information which will help you, but beyond that I will leave it to Saghul as he is very skilled.

Debian 10, Apache2 web server jitsi-meet installed using;

1 Like

uhm - can i use Jitsi without high ports (forcing TURN/STUN on Port 443) per quick install?
I didn’t saw that.

By default the JVB uses port 10000 UDP for media. Is that a problem for you? We stopped multiplexing STUN/TURN in port 443 in the quick install because they created many issues.

Hm okay, what a pity :blush: .
For us this has created many issues (high Ports) in Company Firewalls and Guest LANs sometimes also private Problems in standard Routers from their ISPs.

It was always like 1-2 from 10 Users could not connect.

That can be changed and you can run it on ports < 1024 no problem.

At any rate, that’s unrelated to the bridge channel problem.

I looked at everything about bridge channel, don’t find Problem.
I reinstalled Server from scratch xD …

Any hint on how to use low ports for that? How can it be changed?

In the jvb.conf file in /etc/jitsi/videobridge locate the udp section inside the ice section inside the top level videobridge section. It should have a port number of 10000. Set a lower value and restart the service.

Thank you for the tip. Never read about jvb.conf. Thats new.
But has following Content:

videobridge {
http-servers {
    public {
        port = 9090
    }
}
websockets {
    enabled = true
    domain = "meet.my345domain.com:443"
    tls = true
}
}

Do you have a sip-communicator.properties file there too?

If not you can add this to your videobridge section:

ice {
    udp {
        port = 1000
    }
}