One way video with jitsi app

I am having problems with the jitsi mobile phone app version 22.5.1. It works OK with meet.jit.si, but with my server it sends video inward but doesn’t receive video. The same problem occurs with both Android and iPhone apps. If a user has set a name, the received video is the users initial and the video icon is set to off even though it is on at the other end.

An earlier version of the app, 20.3.2, works with no problems. I updated the server to the latest release, but that made no difference. A computer with almost any browser works fine.

Operating system is:
Ubuntu
Release 20.04.5 LTS (Focal Fossa) 64-bit
Kernel Linux 5.4.0-126-generic x86_64
MATE 1.24.0

Jitsi set up is:
jitsi-meet 2.0.7830-1
jitsi-meet-turnserver 1.0.6600-1
jitsi-meet-web 1.0.6600-1
jitsi-meet-web-config 1.0.6600-1
jitsi-meet-prosody 1.0.6600-1
jitsi-videobridge 1126-1
jitsi-videobridge2 2.2-43-gce94dbb2-1
jicofo not sure what version

There is a valid certificate from LetsEncrypt.

The server is behind NAT and ports 443 5349 and 10000 are forwarded through the firewall.

Any help with this will be much appreciated.

Don Magee

Can you share your config.js with masked domain and so on, please?

Hi Damien

Thank you for your prompt response. The config.js file is attached.

Don Magee

(Attachment jitsi.zzzzz.com-config.js is missing)

Hi Damien

Thank you for your prompt response. The config.js file is attached.

Don Magee

jitsi.zzzzz.com-config.js.log (36.5 KB)

Just to confirm, opening 3 tabs in the browser works, right?

I have the same error in the app

Had the same problem after update and could resolve it with this new block in config.js:

flags: {
sourceNameSignaling: true,
sendMultipleVideoStreams: true,
receiveMultipleVideoStreams: true,
ssrcRewritingEnabled: false,
},

Yes, no problems with browsers, but the phone problem still there with
2, 3 or 4 users.

Don Magee

@damencho I found this out trying things out blindly with another user. Looks like we have a backwards compat problem with latest stable, I think.

I tried that and it seems to fix it. But I can’t find any documentation about the parameters. Can you explain what the problem is and how the fix works please.

No docs about the flags found, sorry. Just trial and error…

When I had the Problem with the app (only with self hosted Server, but not with jit.si) I simply compared my config.js with https://meet.jit.si/config.js

Those are documented here: jitsi-meet/config.js at 9e11bc302b61e09f0e646f50d00355c7324cfa6f · jitsi/jitsi-meet · GitHub
Enabling multi-stream support in the client.

Thanks guys.