OCTO: Jicofo doesnt get octo=true passed?

Hey Jitsi Community,

maybe anyone got an idea regarding this issue.

To shortly describe the issue:

  • We enabled jwt with jitsi-meet-web-tokens (thats the only difference to other deployments I build & support
  • All is working fine (except for octo)

When a new conference is created, Jicofo logs this line (jwt):

org.jitsi.jicofo.FocusManager.log() Created new focus for fortunateprobabilitiesdictatewhatever@conference.meet.abc.de@auth.meet.abc.de. Conference count 1,options: startVideoMuted=10 disableRtx=false

And also jicofo reports “octo_enabled=false” for the other log lines regarding the conference.

On my other deployments (no jwt), jicofo logs this:

org.jitsi.jicofo.FocusManager.log() Created new focus for fortunateprobabilitiesdictatewhatever@conference.meet.abc.de@auth.meet.abc.de. Conference count 1,options: enableLipSync=false enableTcc=true startVideoMuted=5 enableRemb=true octo=true openSctp=false disableRtx=f
alse

If I understand correctly, the jitsi web client sends the options via xmpp to the jicofo server? The additional options seems to be missing.(octo=true…)

I used the same config.js file on both deployments (just changes to the domains / URLs) and can see this behaviour.

Versions:
jitsi-meet-web: 1.0.4568-1
jicofo: 1.0-670-1

Any ideas how to fix this (if this is the issue? But I only could find this difference in the logs, the jvbs registering correctly with the corresponding region, can reach each other.)

Many thanks,
Th3R3al