Octo_enabled= false

Hello all,

I am trying to configure Octo, initially to load balance between two jvbs, and then to move on to geography based load balancing.

I have configured all components (configs and logs below). My problem is that all clients are being served from the same jvb. In the jicofo logs I can see that octo_enabled= false.

Jicofo 2020-05-07 14:49:51.767 INFO: [27] org.jitsi.jicofo.JitsiMeetConferenceImpl.log()
 Region info, conference=ff2783 octo_enabled= false: [[mytest01    , null, null]]

My configs are as follows:

Server2: where meet, jicofo and jvb1 runs:

videobridge/sip-communicator.properties:

org.ice4j.ice.harvest.DISABLE_AWS_HARVESTER=true
org.ice4j.ice.harvest.STUN_MAPPING_HARVESTER_ADDRESSES=meet-jit-si-turnrelay.jitsi.net:443
org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=muc
org.jitsi.videobridge.xmpp.user.shard.HOSTNAME=localhost
org.jitsi.videobridge.xmpp.user.shard.DOMAIN=auth.mytest02.myservice.com
org.jitsi.videobridge.xmpp.user.shard.USERNAME=jvb
org.jitsi.videobridge.xmpp.user.shard.PASSWORD=HkvPd6Uh
org.jitsi.videobridge.xmpp.user.shard.MUC_JIDS=JvbBrewery@internal.auth.mytest02.myservice.com
org.jitsi.videobridge.xmpp.user.shard.MUC_NICKNAME=mytest02-d847-49e8-aa63

org.jitsi.videobridge.octo.BIND_ADDRESS=yyy.59.62.yyy
org.jitsi.videobridge.octo.BIND_PORT=4096 
org.jitsi.videobridge.REGION=mytest02

jicofo/sip-communicator.properties:

org.jitsi.jicofo.BRIDGE_MUC=JvbBrewery@internal.auth.mytest02.myservice.com
org.jitsi.jicofo.BridgeSelector.BRIDGE_SELECTION_STRATEGY=SplitBridgeSelectionStrategy

meet/mytest02.myservice.com-config.js:

    testing: {
        // Enables experimental simulcast support on Firefox.
        enableFirefoxSimulcast: false,

        // P2P test mode disables automatic switching to P2P when there are 2
        // participants in the conference.
        p2pTestMode: false,
        // Load balancing
        octo: {
                probability: 1
        }

        // Enables the test specific features consumed by jitsi-meet-torture
        // testMode: false

        // Disables the auto-play behavior of *all* newly created video element.
        // This is useful when the client runs on a host with limited resources.
        // noAutoPlayVideo: false
    },

In server1, which is only running jvb and its pointed towards server2

videobridge/sip-communicator.properties:

org.ice4j.ice.harvest.DISABLE_AWS_HARVESTER=true
org.ice4j.ice.harvest.STUN_MAPPING_HARVESTER_ADDRESSES=meet-jit-si-turnrelay.jitsi.net:443
org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=muc
org.jitsi.videobridge.xmpp.user.shard.HOSTNAME=mytest02.myservice.com
org.jitsi.videobridge.xmpp.user.shard.DOMAIN=auth.mytest02.myservice.com
org.jitsi.videobridge.xmpp.user.shard.USERNAME=jvb
org.jitsi.videobridge.xmpp.user.shard.PASSWORD=HkvPd6Uh
org.jitsi.videobridge.xmpp.user.shard.MUC_JIDS=JvbBrewery@internal.auth.mytest02.myservice.com
org.jitsi.videobridge.xmpp.user.shard.MUC_NICKNAME=mytest01-37e3c899-b56a-4237-a50a
org.jitsi.videobridge.xmpp.user.shard.DISABLE_CERTIFICATE_VERIFICATION=true

org.jitsi.videobridge.octo.BIND_ADDRESS=xxx.93.214.xxx
org.jitsi.videobridge.octo.BIND_PORT=4096 
org.jitsi.videobridge.REGION=mytest01    

I can see that both jvbs login to jicofo in server2.

Jicofo 2020-05-07 14:47:07.735 INFO: [27] org.jitsi.jicofo.bridge.BridgeSelector.log() 
Added new videobridge: Bridge
[jid=jvbbrewery@internal.auth.mytest02.myservice.com/mytest01-37e3c899-b56a-4237-a50a, 
relayId=null, region=null, stress=0.00]
Jicofo 2020-05-07 14:47:46.879 INFO: [27] org.jitsi.jicofo.bridge.BridgeSelector.log() 
Added new videobridge: Bridge
[jid=jvbbrewery@internal.auth.mytest02.myservice.com/mytest02-d847-49e8-aa63, 
relayId=null, region=mytest02, stress=0.00]

I am wondering what I am missing to get octo enabled.

Any help would be very much appreciated, thanks in advance!

Same problem in my config also:

One observation I have is that both jvb use same o.j.v.x.u.shard.USERNAME and o.j.v.x.u.shard.PASSWORD. Could that be a problem?

It needs to be like that to make MUC work, all jvbs should use same username & password but unique nicknames

1 Like

Any one, for a lil help here?

@omesta Were you able to get it working?

I can see octo_enabled=true in logs and also can see relay and region information. But i am not sure why participants in the same room are not distributed different jvbs

Today I upgraded to unstable version (jicofo v.1.0-589-1) and I can see that octo_enabled= true.

Jicofo 2020-05-20 09:00:14.519 INFO: [29] org.jitsi.jicofo.JitsiMeetConferenceImpl.log() 
Region info, conference=ff4c3c octo_enabled= true: [[mytest01    , null, null]]

If any one facing this issue, try upgrading to atlest v.1.0-589-1 and test.

Its all working now.

I think I made two mistakes:

  1. I did not set region information in jitsi config.js
  2. My jvbs had different REGION set in config.

Hopefully it will all work now.