Octo Cascade Bridges - here's how! FULL GUIDE

Set the public IP on both IPs on the config file
All bridges should be on same Shard though to my understanding

will it work if i set 0.0.0.0 as ip in both sip files

will it work if i set 0.0.0.0 as ip in both sip files

Hmm… no cause then Jicofo doesn’t know where to send the streams

As i m using elastic ip so how can i set ip on both ??

have 2 different server in 2 different regions in aws so how can set that

Yeah Elastic IP is a static IP so you need to type the elastic IP for each server

Is it any way possible i can contact you personally and explain my scenrio

Hi and thank you for this guide,

I’l trying to set up octo but unfortunaly, it doesn’t work.

All seem’s to be good, her is may videobrige config :

org.ice4j.ice.harvest.DISABLE_AWS_HARVESTER=true
org.ice4j.ice.harvest.STUN_MAPPING_HARVESTER_ADDRESSES=meet-jit-si-turnrelay.jitsi.net:443
org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=muc
org.jitsi.videobridge.xmpp.user.shard.HOSTNAME=meet.etps.com
org.jitsi.videobridge.xmpp.user.shard.DOMAIN=auth.meet.etps.com
org.jitsi.videobridge.xmpp.user.shard.USERNAME=jvb
org.jitsi.videobridge.xmpp.user.shard.PASSWORD=TA8iQ8oi
org.jitsi.videobridge.xmpp.user.shard.MUC_JIDS=JvbBrewery@internal.auth.meet.etps.com
org.jitsi.videobridge.xmpp.user.shard.MUC_NICKNAME=JVBx
org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=muc,colibri
org.jitsi.videobridge.STATISTICS_INTERVAL=1000
org.jitsi.videobridge.xmpp.user.shard.DISABLE_CERTIFICATE_VERIFICATION=true
org.jitsi.videobridge.octo.BIND_ADDRESS=0.0.0.0
org.jitsi.videobridge.octo.PUBLIC_ADDRESS=@PUBIP
org.jitsi.videobridge.octo.BIND_PORT=4096
org.jitsi.videobridge.REGION=region1

videobridges seems connect correctly to jicofo :

2020-12-20 14:51:56.011 INFO: [1] org.eclipse.jetty.server.AbstractConnector.doStart: Started ServerConnector@2f16c6b3{HTTP/1.1,[http/1.1]}{0.0.0.0:9090}
2020-12-20 14:51:56.011 INFO: [1] org.eclipse.jetty.server.Server.doStart: Started @963ms
2020-12-20 14:51:56.012 INFO: [1] MainKt.main#128: Starting private http server
2020-12-20 14:51:56.040 INFO: [16] [hostname=meet.etps.com id=shard] MucClient$MucWrapper.join#788: Joined MUC: jvbbrewery@internal.auth.meet.etps.com
2020-12-20 14:51:56.049 INFO: [1] org.eclipse.jetty.server.Server.doStart: jetty-9.4.15.v20190215; built: 2019-02-15T16:53:49.381Z; git: eb70b240169fcf1abbd86af36482d1c49826fa0b; jvm 1.8.0_275-8u275-b01-0ubuntu1~18.04-b01
2020-12-20 14:51:56.335 WARNING: [1] org.glassfish.jersey.internal.inject.Providers.checkProviderRuntime: A provider org.jitsi.rest.Version registered in SERVER runtime does not implement any provider interfaces applicable in the SERVER runtime. Due to constraint configuration problems the provider org.jitsi.rest.Version will be ignored.
2020-12-20 14:51:56.335 WARNING: [1] org.glassfish.jersey.internal.inject.Providers.checkProviderRuntime: A provider org.jitsi.rest.Health registered in SERVER runtime does not implement any provider interfaces applicable in the SERVER runtime. Due to constraint configuration problems the provider org.jitsi.rest.Health will be ignored.
2020-12-20 14:51:56.463 INFO: [1] org.eclipse.jetty.server.handler.ContextHandler.doStart: Started o.e.j.s.ServletContextHandler@6f8f8a80{/,null,AVAILABLE}
2020-12-20 14:51:56.464 INFO: [1] org.eclipse.jetty.server.AbstractConnector.doStart: Started ServerConnector@4b1c0397{HTTP/1.1,[http/1.1]}{127.0.0.1:8080}
2020-12-20 14:51:56.465 INFO: [1] org.eclipse.jetty.server.Server.doStart: Started @1417ms

my /etc/jitsi/jicofo/sip-communicator.properties file :

org.jitsi.jicofo.BRIDGE_MUC=JvbBrewery@internal.auth.meet.etps.com
org.jitsi.jicofo.auth.URL=XMPP:meet.etps.com
org.jitsi.jicofo.jibri.BREWERY=JibriBrewery@internal.auth.meet.etps.com
org.jitsi.jicofo.jibri.PENDING_TIMEOUT=90
org.jitsi.jicofo.BridgeSelector.BRIDGE_SELECTION_STRATEGY=SplitBridgeSelectionStrategy

But when I try to activate octo in my /etc/jitsi/meet/meet.etps.com-config.js, it’s ending in a grey page at https://meet.etps.com and no options to start a meeting.

testing: {

    p2pTestMode: false

    octo: {
       probability: 1
    },
},
  [...]

deploymentInfo: {
     shard: "shard1",
     region: "region1",
     userRegion: "region1"
},
[...]

Do I miss something ?

Thank you for your help.

Juju

Usually means you have a syntax error in one of your JSON files. Probably the config

Exactly, was missing a , and the end of a line …

Now it is working as expect.

THank for your help.
Regards,
Juju

Thanks for the write up Raviv, it’s greatly appreciated :+1:

1 Like

If anyone here is looking for help setting up Jibri
Check out my latest guide