'npm start' giving error


#1

When I try to install jitsi/jitsi-meet-electron in my terminal after doing npm install , when I try to do npm start in my Terminal , it is showing me following error :


#2

Try running npm start in the root of the project, not the build dir.


#3

Okay, thanks for replying. The error is basically in node_modules and I have to install them again in my project. Could you please tell me to how to install node_modules as npm install --overbose
is also taking so much of time to install node_modules in my project. Now, when I try to run npm install from root , terminal is giving following error :


#4

Are you running overbose or verbose? verbose should be showing you details on what’s running and that way you can debug at least what part of the install process is taking time.


#5

I have already tried running npm install --verbose in my terminal but nothing is working out for me
as terminal is taking so much time to install node_modules in this project . Here is the screenshot


#6

Have you checked npm issues about extract taking a while? I see an issue on " npm install hangs on extract step." Funnily one of the recommended solutions is to use yarn.


#7

I have installed yarn but it is also taking so much time time to execute completely in my terminal.


#8

And you also tried the http workaround they were describing in the issue? I checked stackoverflow and that was a common suggested workaround.


#9

After installing yarn and doing yarn start, this error is showing in terminal :


#10

The http workaround fixed the original issue? If so you might want to go back to using npm. yarn has some open issues about postinstall scripts not being run, which I suspect is the reason why your electron app hasn’t been built.


#11

Now, after starting things again , executing sudo npm install --verbose is being stuck in my terminal . Here is the screenshot


#12

This is still with the http workaround? You should also fix your env so you dont have to do sudo. Something like this: https://stackoverflow.com/questions/16151018/npm-throws-error-without-sudo


#13

Now when I try to install node_modules terminal is now showing this error . Can you please inform me about what version of npm is required for this project?



#14

Looks like there’s no documentation of recommended versions in the repo. Usually it should list it in package.json at least but it doesn’t. I just tried node/npm 10.15.1/6.8.0 and 8.12.0/6.7.0 and 11.9.0/6.5.0 and it installed fine. You should probably research the error about “unsupported platform for fsevents”