Npm install throwing error 'ERR! typeerror Error: Missing required argument #1'

Hello guys,

I am trying to learn how to customize Jitsi (which I really like up to this moment) I get an error after running npm install. Next are the commands I ran:

git clone https://github.com/jitsi/jitsi-meet.git
sudo apt-get install npm nodejs
cd jitsi-meet
npm install

All commands worked as expected but the error I get with the last one is the following:

Does anyone know what is this error about and how to solve it?

Thanks in advance.

This was a problem of the Node.js and npm version. The command in development.md is not the correct one for Ubuntu 18.04 since it installs the versions that appear in the picture and not the ones required by development.md.

Had the same issue with Ubuntu.
Steps to fix were:

  1. Uninstall current version of node and npm
  2. Execute following commands:
curl -sL https://deb.nodesource.com/setup_10.x | sudo -E bash -
apt-get install -y nodejs
1 Like