NPM install issue

I seem to have some issues when using NPM install, I tried every version from node v14 and npm v7 (recommended on the developer guide) as well as versions up to node v17.

After I git clone and run NPM install, the same error keeps popping up about tarball corrupted no matter which version I use. I also tried creating new VM multiple times, and can’t find any clue on Google. Anyone could provide any assistance? Thank you!

I would try node v16.4