Npm install in Windows 10 WSL

Hi all
I am trying to build jitsi-meet in windows 10 in WSL where I have Ubuntu 18.04.
Running just “npm install” it will soon start to spit out a million lines
“npm WARN tar EPERM: operation not permitted, futime”

So I have tried “sudo npm install” and after a short while I get “RangeError: Maximum call stack size exceeded”.

Can anyone give me a hint of what’s wrong here?

node v12.18.2
npm v6.14.5

TIA
Staffan

the last lines from npm debug log are here:

1945 warn react-native-youtube-iframe@1.2.3 requires a peer of react-native@>=0.59 but none is installed. You must install peer dependencies yourself.
1946 warn react-native-youtube-iframe@1.2.3 requires a peer of react-native-webview@^7.5.2 but none is installed. You must install peer dependencies yourself.
1947 warn optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.3 (node_modules/chokidar/node_modules/fsevents):
1948 warn notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.3: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“x64”})
1949 verbose notsup SKIPPING OPTIONAL DEPENDENCY: Valid OS: darwin
1949 verbose notsup SKIPPING OPTIONAL DEPENDENCY: Valid Arch: any
1949 verbose notsup SKIPPING OPTIONAL DEPENDENCY: Actual OS: linux
1949 verbose notsup SKIPPING OPTIONAL DEPENDENCY: Actual Arch: x64
1950 warn optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/fsevents):
1951 warn notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“x64”})
1952 verbose notsup SKIPPING OPTIONAL DEPENDENCY: Valid OS: darwin
1952 verbose notsup SKIPPING OPTIONAL DEPENDENCY: Valid Arch: any
1952 verbose notsup SKIPPING OPTIONAL DEPENDENCY: Actual OS: linux
1952 verbose notsup SKIPPING OPTIONAL DEPENDENCY: Actual Arch: x64
1953 verbose stack RangeError: Maximum call stack size exceeded
1953 verbose stack at RegExp.test ()
1953 verbose stack at isDepOptional (/usr/lib/node_modules/npm/lib/install/deps.js:432:45)
1953 verbose stack at failedDependency (/usr/lib/node_modules/npm/lib/install/deps.js:441:9)
1953 verbose stack at failedDependency (/usr/lib/node_modules/npm/lib/install/deps.js:457:9)
1953 verbose stack at failedDependency (/usr/lib/node_modules/npm/lib/install/deps.js:457:9)
1953 verbose stack at failedDependency (/usr/lib/node_modules/npm/lib/install/deps.js:457:9)
1953 verbose stack at failedDependency (/usr/lib/node_modules/npm/lib/install/deps.js:457:9)
1953 verbose stack at failedDependency (/usr/lib/node_modules/npm/lib/install/deps.js:457:9)
1953 verbose stack at failedDependency (/usr/lib/node_modules/npm/lib/install/deps.js:457:9)
1953 verbose stack at failedDependency (/usr/lib/node_modules/npm/lib/install/deps.js:457:9)
1953 verbose stack at failedDependency (/usr/lib/node_modules/npm/lib/install/deps.js:457:9)
1953 verbose stack at failedDependency (/usr/lib/node_modules/npm/lib/install/deps.js:457:9)
1953 verbose stack at failedDependency (/usr/lib/node_modules/npm/lib/install/deps.js:457:9)
1953 verbose stack at failedDependency (/usr/lib/node_modules/npm/lib/install/deps.js:457:9)
1953 verbose stack at failedDependency (/usr/lib/node_modules/npm/lib/install/deps.js:457:9)
1953 verbose stack at failedDependency (/usr/lib/node_modules/npm/lib/install/deps.js:457:9)
1954 verbose cwd /mnt/e/dev/jitsi-meet
1955 verbose Linux 4.19.104-microsoft-standard
1956 verbose argv “/usr/bin/node” “/usr/bin/npm” “install”
1957 verbose node v12.18.2
1958 verbose npm v6.14.5
1959 error Maximum call stack size exceeded
1960 verbose exit [ 1, true ]

@andrei-gavrilescu you were running your dev env on WSL right? Maybe you can help here?

Thanks, for this.

Yello, I encountered this issue while using the ubuntu distro as well and I couldn’t work around it.
Using the Debian distro worked for me, you could try that.
However with the latest windows 10 update (2004) WSL 2 is available which uses an actual underlying vm and makes the whole ecosystem a lot more stable, you can even install docker natively. I didn’t try it with ubuntu but I’m pretty sure it works.
So either use Debian with WSL1 or upgrade to WSL 2 which is what I’d recommend. Hope this helps, have a good one…

Thanks @andrei-gavrilescu for your suggestions. I am running WSL 2, forgot to mention that.
I will try Debian instead .

I’ll be back …

Kudos guys. I’m new here.