Notification sounds feedback

Here’s a question for the team,
When we added audio to our self-hosted Jitsi system we can hear them through the participants microphone. So a chat notification will be heard in all endpoints when only one actually get a message.

Anyone knows how to filter these notification sounds so they’ll be heard only by the intended endpoint?

RNnoise is not the right way to go for this.

Interestingly enough even on https://meet.jit.si we’re can hear audio like “Recording is on” from other endpoints when a recording starts.

@damencho some insight into how we can prevent notification audio from going to endpoints will be great

This is played for every participant, it’s not filtered sound.

Hi again @Freddie
Is there a way we won’t hear this audio playing on other participants’ endpoints?

Chat notification is the greatest pain for this issue.

Cheers

You can locally mute participants while playing notifications, this is the only option I see.

That’s an idea. Not sure how it’ll affect the experience. Will look into it.

Thanks