Nothing is sent to my dropbox from my server

Hi everyone, this is my first post here. I have been trying to install jitsi and jibri on my ubuntu 16.4 virtual server for days. After many attempts and guides, I finally managed to have jitsi working on my server, even jibri senbra working, as now the recording starts without errors.
my problem now is that after I authenticated myself on dropbox and started recording, the file is not sent to dropbox, the file is present on the server, so jibri seems to do its job correctly, but not to send to dropbox. Can you help me and tell me how to solve the problem? thanks

ultimo log jibri

2020-06-03 16:11:45.145 INFO: [1] org.jitsi.jibri.Main.main() Jibri run with args [–config, /etc/jitsi/jibri/config.json]
2020-06-03 16:11:45.148 INFO: [1] org.jitsi.jibri.Main.main() Using config file /etc/jitsi/jibri/config.json
2020-06-03 16:11:45.148 INFO: [1] org.jitsi.jibri.Main.main() Using port 3333 for internal HTTP API
2020-06-03 16:11:45.149 INFO: [1] org.jitsi.jibri.Main.main() Using port 2222 for the HTTP API
2020-06-03 16:11:45.720 INFO: [1] org.jitsi.jibri.Main.loadConfig() Parsed config:
JibriConfig(recordingDirectory=/tmp/recordings, singleUseMode=false, enabledStatsD=true, finalizeRecordingScriptPath=/path/to/finalize_recording.sh, xmppEnvironments=[XmppEnvironmentConfig(name=prod environment, xmppServerHosts=[prod.xm$
2020-06-03 16:11:46.150 WARNING: [1] org.glassfish.jersey.internal.inject.Providers.checkProviderRuntime() A provider org.jitsi.jibri.api.http.internal.InternalHttpApi registered in SERVER runtime does not implement any provider interfa$
2020-06-03 16:11:46.353 INFO: [1] org.jitsi.jibri.api.xmpp.XmppApi.updatePresence() Jibri reports its status is now JibriStatus(busyStatus=IDLE, health=OverallHealth(healthStatus=HEALTHY, details={})), publishing presence to connections
2020-06-03 16:11:46.355 INFO: [1] org.jitsi.xmpp.mucclient.MucClientManager.log() Setting a presence extension: org.jitsi.xmpp.extensions.jibri.JibriStatusPacketExt@771158fb
2020-06-03 16:11:46.360 INFO: [1] org.jitsi.jibri.api.xmpp.XmppApi.start() Connecting to xmpp environment on prod.xmpp.host.net with config XmppEnvironmentConfig(name=prod environment, xmppServerHosts=[prod.xmpp.host.net], xmppDomain=xm$
2020-06-03 16:11:46.360 INFO: [1] org.jitsi.jibri.api.xmpp.XmppApi.start() The trustAllXmppCerts config is enabled for this domain, all XMPP server provided certificates will be accepted
2020-06-03 16:11:46.375 WARNING: [19] org.jitsi.xmpp.mucclient.MucClient.log() Disabling certificate verification!
2020-06-03 16:11:46.417 WARNING: [1] org.glassfish.jersey.internal.inject.Providers.checkProviderRuntime() A provider org.jitsi.jibri.api.http.HttpApi registered in SERVER runtime does not implement any provider interfaces applicable in$
2020-06-03 16:11:46.554 SEVERE: [19] org.jitsi.xmpp.mucclient.MucClientManager.log() Failed to initialize and start a MucClient:
org.jivesoftware.smack.SmackException$ConnectionException: The following addresses failed: ‘prod.xmpp.host.net:5222’ failed because: java.net.UnknownHostException: prod.xmpp.host.net: Name or service not known
at org.jivesoftware.smack.SmackException$ConnectionException.from(SmackException.java:278)
at org.jivesoftware.smack.tcp.XMPPTCPConnection.connectUsingConfiguration(XMPPTCPConnection.java:619)
at org.jivesoftware.smack.tcp.XMPPTCPConnection.connectInternal(XMPPTCPConnection.java:902)
at org.jivesoftware.smack.AbstractXMPPConnection.connect(AbstractXMPPConnection.java:383)
at org.jitsi.xmpp.mucclient.MucClient.initializeConnectAndJoin(MucClient.java:277)
at org.jitsi.xmpp.mucclient.MucClientManager.lambda$addMucClient$0(MucClientManager.java:152)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at java.lang.Thread.run(Thread.java:748)
2020-06-03 16:12:16.379 WARNING: [28] org.jivesoftware.smackx.ping.PingManager.pingServerIfNecessary() XMPPConnection was not authenticated
2020-06-03 16:14:31.630 INFO: [15] org.jitsi.jibri.api.http.internal.InternalHttpApi.gracefulShutdown() Jibri gracefully shutting down

I solved:

apt install jitsi-upload-integrations

“finalize_recording_script_path”: “/usr/bin/jitsi_uploader.sh” in /etc/jitsi/jibri/config.json

stop