Nothing happens when "Open Shared Document" is clicked. (Etherpad-lite integration is not working)

Hi.
I installed and configured etherpad-lite roughly using the following as guide:

Etherpad is working fine, I can access etherpad manually using the following urls:

  1. http://:9001
  2. https://<mydomain.com>:9001 (with SSL)
  3. https://<mydomain.com>/etherpad/p/

So it seems the etherpad-lite installation and the nginx configuration is working fine.

However, nothing is happening or opening when I click the “open shared document”.
There is no error in the JS console, there is no error in the nginx log and there is no access or activity in etherpad-lite as well. Are there additional steps not mentioned in the link above that need to be done for etherpad integration to work in Jitsi?

I am running Jitsi in Ubuntu 20.04 and currently following the nightly unstable release:

jitsi-meet : 2.0.6552-1
jitsi-meet-prosody : 1.0.5523-1
jitsi-meet-turnserver : 1.0.5523-1
jitsi-meet-web : 1.0.5523-1
jitsi-meet-web-config : 1.0.5523-1
jitsi-videobridge2 : 2.1-581-gce152789-1

Thanks in advance!

make sure the blow are uncomment in your …config.js
etherpad_base: https://<mydomain.com>/etherpad/p/

or config.etherpad_base =https://<mydomain.com>/etherpad/p/

Hi @Yassine,

Yes, the etherpad_base is in config.js. The “Open Shared Document” does not show if it’s not present in the config.js. I also tried using the config URL parameter and it’s just the same. The etherpad link is present in the menu, but nothing happens when it is being clicked.

I tried with the latest stable and etherpad works.
So it seems, at least on my install - etherpad is not working in the unstable branch.
Can anyone from the dev team confirm this?

Hello. Can anyone self-hosting and is following the unstable branch verify if the Etherpad-Lite integration is working in your install base?