Not working in Safari/Macbook/iPhone/iPhone Chrome

I have Jitsi on my aws server. Its working on web but on mobile browser it asks to download the app. I have made changes in app.bundle.min.js from function i(){return"android"===r.a.OS||“ios”===r.a.OS} to function i(){return false; return"android"===r.a.OS||“ios”===r.a.OS}
After changed this its working fine on Android phones/in google chrome on mac os but its not working in safari in mac os and in iphone safari/google chrome however its working in Jitsi mobile app in iPhone check the error below. iPhone

Do you find any solution for your problem ?

I don’t know if it will still work for you. But this worked for me.

So that Jits Meet does not show the option screen to Download the application etc. Just set the following option to: “true” at meet.example.com-config.js

Original:
// disableDeepLinking: false,

Activate this line and change to:
disableDeepLinking: true,

This way, when the user accesses his link on his cell phone he will go straight to the video room.

In our case we did something like…
function i(){return"androidrrrrrrr"===r.a.OS||“ios”===r.a.OS}
So, if it’s an android system it will return false and show the web version BUT if it’s a ios system it will show the app link. We did this because iphone systems did not work properly (or at all?) with the web version.