Not Working if 2nd Person Join from Different Country

India To USA video Conferences Not working we are trying in Self-Hosting Server.
Person Joined from USA not able See video or Hear Audio inputs from our end via versa.

Hey there!

Are you able to get 3 participants in a meeting at all?

Hi Saghul,

1st & 2nd Person Same network[From India] its working.
1st Person from India and 2nd Person from Outside Country its not working.

If 3rd Person Join from within network or from other country audio & Video not working.

Thanks for the quick response

Did you test 3 participants from the same region? Does it work?
Do you have multiple JVB and shard?

Did you test 3 participants from the same region? Does it work?
No Its not working.

Do you have multiple JVB and shard?
No Sure ,I am just going with default configurations which are setup at the time of installation.

Then your problem is not related to user location, but to your overall setup.

Is your port 10000 open? Do you see any errors in the browser console when then 3rd participant joins?

Hi @saghul

I am receiving the same error. For 2 participants it is working fine but when 3rd participant joins then his video and share screen is not showing in the thumbnail. thumbnail is coming in tile view for 3rd participant.

when 3rd participant joined then every participant is able to see his own video and his shared screen only.(for 2 participants it is working fine. Both can see each other and their shared screen also.)
JVB1 is running on port 10000 and JVB2 is running on 30000 :

It gives following error in the 3rd participants console.
chrome error:

Access to fetch at 'https://website-name.com:8090/xmpp-websocket?room=“room-value”&token=“jwt-token-value” from origin ‘http://localhost:9080’ has been blocked by CORS policy: The ‘Access-Control-Allow-Origin’ header contains multiple values ‘http://localhost:9080, *’, but only one is allowed. Have the server send the header with a valid value, or, if an opaque response serves your needs, set the request’s mode to ‘no-cors’ to fetch the resource with CORS disabled.

XmppConnection.js:436 GET https://website-name.com:8090/xmpp-websocket?room=“room-number-value”&token="jwt-token-value " net::ERR_FAILED 200
_keepAliveAndCheckShard @ XmppConnection.js:436
(anonymous) @ XmppConnection.js:419
setTimeout (async)
_maybeStartWSKeepAlive @ XmppConnection.js:418
(anonymous) @ XmppConnection.js:420
Promise.then (async)
(anonymous) @ XmppConnection.js:420
setTimeout (async)
_maybeStartWSKeepAlive @ XmppConnection.js:418
(anonymous) @ XmppConnection.js:420
Promise.then (async)
(anonymous) @ XmppConnection.js:420
setTimeout (async)
_maybeStartWSKeepAlive @ XmppConnection.js:418
(anonymous) @ XmppConnection.js:420
Promise.then (async)
(anonymous) @ XmppConnection.js:420

Logger.js:154 2023-01-23T13:46:57.346Z [modules/xmpp/XmppConnection.js] Websocket Keep alive failed for url: https://website-name.com:8090/xmpp-websocket?room=“room-value”&token=“jwt-token-value” {error: TypeError: Failed to fetch
at Js._keepAliveAndCheckShard (http://localhost:9080/libs/lib-jitsi-…}
error
: TypeError: Failed to fetch at Js._keepAliveAndCheckShard (http://localhost:9080/libs/lib-jitsi-meet.min.js?v=136:2:107630) at http://localhost:9080/libs/lib-jitsi-meet.min.js?v=136:2:107397
[[Prototype]]
: Object

@suraj You shouldn’t hijack a thread - your issues may not necessarily be the same.

First stop the remote JVB and test a 3-party meeting again. If it still doesn’t work, check to make sure that port 10000/UDP is open and accessible, BOTH on your server’s firewall AND on the host’s firewall.

Once you get the local JVB working fine, then move to the remote JVB. If you’ve set a different port number for it, that must be referenced in the config.

ok @Freddie thanks for the reply. I will be careful next time.

can you please tell me how can I check port 10000 is open and accessible for both server and host firewall. Is there any command for that. I am using docker on ubuntu.

For the host firewall, you need to check the firewall settings in the host’s portal to make sure the port is open and accessible.

Now can see 3rd Person also after add 10000 Port in AWS Security Inbound/Outbound Firewall but facing issue with Audio not getting audio outputs from both ends Camera Inputs working fine.

I can see below Message in Console
2023-01-24T05:41:25.835Z [modules/statistics/AudioOutputProblemDetector.js] A potential problem is detected with the audio output for participant 9d9052da, local audio levels: [null,null], remote audio levels: undefined

If you see video but no audio check the audio devices on both ends. Data goes over the same port, so it’s not a network problem then.

Any Updates on this we are also facing same issue.
India To USA video Conferences we are trying in Self-Hosting Server

This was a meet.jit.si issue and was fixed. Do you experience problems when using meet.jit.is or just with your self-hosted instance?

We are facing with self hosting

If you are not facing the same with meet.jit.si its either wrong setup or problems with connectivity to your instance. What errors do you see in the js console logs in the browser?

jicofo.log (1.7 MB)
jicofo.log (1.7 MB)
Currently I am working on Self-hosted Jitsi-Meet in my Amazon Ec2 Instance.
When 2nd Person Joined from Some other country we not able see his video and same with audio via versa.
In jicofo log file I see the below warning message.

Jicofo 2023-01-23 07:39:38.123 WARNING: [112] [room=testing@conference.pocdemo.aitacs.com meeting_id=55b65939-1c25-4986-8695-1fb2715bb536 participant=12da315a] ParticipantInviteRunnable.lambda$doRun$0#194: Failed to convert ContentPacketExtension to Media:
Jicofo 2023-01-23 07:39:38.123 INFO: [112] [room=testing@conference.pocdemo.aitacs.com meeting_id=55b65939-1c25-4986-8695-1fb2715bb536] ColibriV2SessionManager.allocate#277: Allocating for 12da315a
Jicofo 2023-01-23 07:39:38.123 INFO: [112] BridgeSelectionStrategy.select#127: Existing bridge does not have a relay, will not consider other bridges.

what about browser js console logs?

We added 10000 Port as Custom UDP in AWS Security Inbound/Outbound Firewall. Now we can see Camera 2nd Person Joined from other Country but not getting his Audio.2nd Person can hear us and see us.

I am Sharing screenshot console error on 2nd Person browser console.



.
jicofo.log (946.4 KB)
jvb.log (91.9 KB)

Moved your posts on the same issue here so efforts to help you are not being duplicated.