Not working for more than 2 people in the room

sorry, I was scanning only TCP. 10000 is open

@CMA you caught the nuisance in my install… yes it was webmin. Once I disabled it my issues varnished. I have since moved webmin to a different port even though it was initially only running on the internal lan port.

U welcome

@xavdum
Finally have you fixed that issue ?
It seams be ok in your target server @free.fr (more than 3 peoples)
Can explain that you made ?
Thanks

Hello,

My system is based on ARM, it was the issue.
I followed the steps in this topic (compile some component to replace existing) and it works.
Here is the topic : https://github.com/jitsi/docker-jitsi-meet/issues/195#issuecomment-614124344

Regards.

i have the same problem, because i used webmin, now is working with more than 2 users. i change webmin port to other port and changed the
/etc/jitsi/videobridge//etc/jitsi/videobridge SINGLE PORT and restart jitsi :

org.jitsi.videobridge.SINGLE_PORT_HARVESTER_PORT=17000

 `service jitsi-videobridge2 restart`

this works for me.

Hi,

I have almost exact same setup (Virtualmin, port changed) like you guys and I have made/tried all the changes that you suggested (even added single port).

But I am still unable to get 3 people in call. 2 Works perfectly fine, but the moment 3rd person joins in, I goes for a toss.

Can someone pls help?

Many Thanks,
Rav

Hi @albercuba

Tried following your instruction step by step, still no cigar.

Uninstalling and reinstalling everything from the scratch is not an option for me. So I need some troubleshooting and log analysis to be done.

Can you spare few minutes - happy to work on Teamviewer or something simillar if that works for you - I am in the UK (GMT Timezone).

Many Thanks,
Rav

Hi All ,
Even i am facing the same issue . mine is docker-jitsi-meet installation .
Added the DOCKER_HOST_ADDRESS and commented the JVB_STUN_SERVER in .env file

Added this to lines in .jitsi-config/jvb/sip.communication.properties
org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=<Local_Adress>
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=<Public_Adress>

Here are my logs
jvb.log (197.5 KB)
browser_console.log (102.0 KB) jicofo.log (87.3 KB) prasody.log (13.9 KB)

Thanks
Dinesh

All sorted now. Many Thanks to @damencho.

All details available over here.

@dinesh_babu I will be more than happy to help, but I don’t know a lot about docker and my setup is not in a docker environment. So if you want I can assist you with what I know from my regular setup and if you can translate it for your docker environment then do let me know.

Many Thanks,
Rav

Thank you @raviktiwari .
I saw your Latest unstable JVB2 is broken with three more participants forum and tried this command ,
echo “Test” | nc -u <my.public.ip.address> 10000 , i didnt get any messages ,
Any idea how to go about this .

Thanks
Dinesh

@dinesh_babu where you running the other nc command listening? If so, you need to fix your network config and forward the 10000 port.

Hi @damencho I got few Jitsi update yesterday night which I installed and since then I am again having the same issues - this time even worse.

I used to be able to work with 2 way chat and struggle with 3 way conference. But right now I am struggling with even 2. When 2 people get connected and then in less than 1 min, one of them gets disconnected saying: “Unfortunately, something went wrong. We’re trying to fix this. Reconnecting in 0 sec…” and then it reconnects and then it disconnects again. I am now testing port 10K forwarding which is again not workin and I am unable to get the message sent across the main machine.

But what worries me is the fact that it was just Jitsi update, there were no changes made on the firewall, so how come the port forward has got an issue now (if it has)?

Any idea/suggestion?

Just so you know, this is what I am trying:

sudo service jitsi-videobridge2 stop
nc -l 10000 -u

And from Internet machine:

echo "123" | nc -u <your public address> 10000

Many Thanks,
Rav

Hi @damencho,

If even 2 people are not able to communicate that will mean 443/tcp issue. And for more than 2 people it will mean port 10K/udp issue . Right?

I am still struggling to fix port 10K forward, 443 is working but now I a not able to get 2 people on chat. I think I know the issue and I will raise it in appropriate group/thread. But can you pls confirm the answer for my question above.

Many Thanks,
Rav