Not working due to Nginx issue

Is nginx behind a proxy?


Do you use some kind of DNS load balancing?


To add, regardless of whether it works properly or not, the iOS client cannot connect and Stream shows a 404 status for config.js.

If you run the following command in jitsi server, can you get config.js?

curl -k -H 'Host: jitsi.mydomain.corp'

Change jitsi.mydomain.corp according to your domain.


Have you tested it many times? Are you always get the same output?

Do you get the same output from the outside too? For example run the following command on your client machine

curl https://your.jitsi.domain/config.js

Local testing is always successful, but remote testing sometimes results in a 404 status code

This means that the problem is somewhere else, not on jitsi

Yes, I suspect it’s an Nginx problem, but I don’t see where it’s going wrong

It shouldn’t be an nginx problem because when the requests come from the local server, it works correctly.

I think someone else handles the requests when they come from the outside, such as a proxy server.

But I made sure there was no proxy server. I tried to set up other sites and they all worked fine

I found that whenever it worked exceptionally, the Nginx logs did not record access information, as if the service was not being controlled by Nginx at that moment

Can you try to stop nginx

systemctl stop nginx

Can you get any response for HTTPS requests now?

Er…I found all the sites to be normal, closing seems to be the same as not closing