Not able to install

Hey all,
i´m new to jitsi and try to install jitsi-meet on my own Ubuntu 20.04.1 server.

I get error during download:

E: The repository ‘https://download.jitsi.org stable/ Release’ does not have a Release file.

Who can help me here? Thanks a lot,
Andi

Welcome to the forum!

Try these commands:

echo 'deb https://download.jitsi.org stable/' | sudo tee /etc/apt/sources.list.d/jitsi-stable.list

wget -qO - https://download.jitsi.org/jitsi-key.gpg.key | sudo apt-key add -

sudo apt update

sudo apt install jitsi-meet

Hello Freddie,

thanks. After sudo apt update i get:

Ign:1 https://download.jitsi.org stable/ InRelease
Err:2 https://download.jitsi.org stable/ Release
Could not handshake: An unexpected TLS packet was received.

Is there other source to download / install package?

Are you behind proxy or on VPN? Seems like for some reason the SSL connection is breaking.
Check the other lines in your /etc/apt/sources.list file (and in sources.lid.d folder), are they using https? Do you get ssl errors only from the Jitsi entry? (try with commenting it out and checking if the other sources work)

OT: Technically you can always edit the source and use http instead of https. It will work, but needless to say that using SSL is always better, especially for a security-aware software like Jitsi.
Plus, your system seems to have issues with https in apt and it’s better to resolve them, because you will have other sources using ssl in future.

Hey Yasen_Pramatarov1, yes i´m behind a proxy.
I will check that and retry it with connection and download.

The proxy config may be wrong (only for apt over https wrong I mean) - check the files under /etc/apt/apt.conf.d/ and see if there somewhere you have sth like the following (if you configured the proxy on instaling the machine):
Acquire::https::Proxy "http://your-proxy"
try changing these - for example if your proxy URL should be http:// instead of https:// or sth like that - and try again with apt update

I reconfigure the proxy and still the same “Could not handshake: An unexpected TLS packet was received.” after that i try it with http download Err:1 http jitsi-videobridge2 2.1-416-g2f43d1b4-1 Connection failed. :frowning:

Err:53 http://download.jitsi.org stable/ jitsi-videobridge2 2.1-416-g2f43d1b4-1 Connection failed
Err:54 http://download.jitsi.org stable/ jicofo 1.0-690-1 Connection failed
Get:55 http://download.jitsi.org stable/ jitsi-meet-web 1.0.4628-1 [7,683 kB]
Get:56 http://download.jitsi.org stable/ jitsi-meet-web-config 1.0.4628-1 [16.6 kB]
Get:57 http://download.jitsi.org stable/ jitsi-meet-prosody 1.0.4628-1 [40.3 kB]
Get:58 http://download.jitsi.org stable/ jitsi-meet 2.0.5390-1 [2,868 B]
Get:59 http://download.jitsi.org stable/ jitsi-meet-turnserver 1.0.4628-1 [6,244 B]
Fetched 59.9 MB in 2min 9s (466 kB/s)
E: Failed to fetch http://download.jitsi.org/stable/jitsi-videobridge2_2.1-416-g2f43d1b4-1_all.deb >  Connection failed
E: Failed to fetch http://download.jitsi.org/stable/jicofo_1.0-690-1_all.deb  Connection failed

I think definitely the proxy (or the apt proxy config) is blocking you.
If you have access to the proxy, you can take a look at its logs (and its configs). You can also look at your server’s /var/log/dpkg.log and apt/* logs, but I don’t think there will be much more info.

When you try with http and you fail to fetch the files, check the apt proxy configs for http (not only https), the “Acquire::http::Proxy” - maybe the config there is not right.

The other option left is that the proxy is blocking you to access these files - maybe a domain and/or file type (deb) blacklist. You can try excluding these one by one:

Yes , that is very strange.
I can install other deb packages without any problem and also http-download from jitsi.org works.

sudo apt update
Hit:1 archive. ubuntu. com/ubuntu focal InRelease
Get:2 archive. ubuntu. com/ubuntu focal-updates InRelease [114 kB]
Get:3 archive. ubuntu. com/ubuntu focal-backports InRelease [101 kB]
Get:4 archive. ubuntu. com/ubuntu focal-security InRelease [109 kB]
Hit:5 download. jitsi. org stable/ InRelease
Fetched 324 kB in 1s (489 kB/s)
Reading package lists… Done
Building dependency tree
Reading state information… Done
All packages are up to date.

If i do that with HTTP download i missing only two files.

sudo apt -y install jitsi-meet
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following additional packages will be installed:
ca-certificates-java coturn fontconfig-config fonts-dejavu-core java-common jicofo jitsi-meet-prosody jitsi-meet-turnserver jitsi-meet-web jitsi-meet-web-config jitsi-videobridge2 libavahi-client3
libavahi-common-data libavahi-common3 libcups2 libevent-core-2.1-7 libevent-extra-2.1-7 libevent-openssl-2.1-7 libevent-pthreads-2.1-7 libfontconfig1 libgd3 libhiredis0.14 libjbig0 libjpeg-turbo8
libjpeg8 liblcms2-2 libmysqlclient21 libnginx-mod-http-image-filter libnginx-mod-http-xslt-filter libnginx-mod-mail libnginx-mod-stream libnspr4 libnss3 libpcsclite1 libpq5 libtiff5 libwebp6
libxi6 libxpm4 libxrender1 libxtst6 lua-bitop lua-event lua-expat lua-filesystem lua-sec lua-socket lua5.2 mysql-common nginx nginx-common nginx-core openjdk-14-jre-headless prosody sqlite3
ssl-cert x11-common
Suggested packages:
sip-router default-jre cups-common libgd-tools liblcms2-utils pcscd fcgiwrap nginx-doc libnss-mdns fonts-dejavu-extra fonts-ipafont-gothic fonts-ipafont-mincho fonts-wqy-microhei
| fonts-wqy-zenhei fonts-indic lua-dbi-mysql lua-dbi-postgresql lua-dbi-sqlite3 lua-zlib sqlite3-doc openssl-blacklist
The following NEW packages will be installed:
ca-certificates-java coturn fontconfig-config fonts-dejavu-core java-common jicofo jitsi-meet jitsi-meet-prosody jitsi-meet-turnserver jitsi-meet-web jitsi-meet-web-config jitsi-videobridge2
libavahi-client3 libavahi-common-data libavahi-common3 libcups2 libevent-core-2.1-7 libevent-extra-2.1-7 libevent-openssl-2.1-7 libevent-pthreads-2.1-7 libfontconfig1 libgd3 libhiredis0.14
libjbig0 libjpeg-turbo8 libjpeg8 liblcms2-2 libmysqlclient21 libnginx-mod-http-image-filter libnginx-mod-http-xslt-filter libnginx-mod-mail libnginx-mod-stream libnspr4 libnss3 libpcsclite1 libpq5
libtiff5 libwebp6 libxi6 libxpm4 libxrender1 libxtst6 lua-bitop lua-event lua-expat lua-filesystem lua-sec lua-socket lua5.2 mysql-common nginx nginx-common nginx-core openjdk-14-jre-headless
prosody sqlite3 ssl-cert x11-common
0 upgraded, 58 newly installed, 0 to remove and 0 not upgraded.
Need to get 72.8 MB/133 MB of archives.
After this operation, 358 MB of additional disk space will be used.
Err:1 download. jitsi. org stable/ jitsi-videobridge2 2.1-416-g2f43d1b4-1
Connection failed [IP: 8080]
Err:2 download. jitsi. org stable/ jicofo 1.0-690-1
Connection failed [IP: 8080]
E: Failed to fetch download. jitsi. org/stable/jitsi-videobridge2_2.1-416-g2f43d1b4-1_all.deb Connection failed [IP: 8080]
E: Failed to fetch download. jitsi. org/stable/jicofo_1.0-690-1_all.deb Connection failed [IP: 8080]

The proxy-configuration for http and https are still the same :frowning:

Any chance for me to get these two files?

/stable/jitsi-videobridge2_2.1-416-g2f43d1b4-1_all.deb Connection failed
/stable/jicofo_1.0-690-1_all.deb Connection failed

All other downloads and installation works fine… :frowning:

  • Could you paste your proxy config

  • what is the output for curl

curl http://download.jitsi.org/stable/Release
  • what is the output for wget
wget http://download.jitsi.org/stable/jicofo_1.0-690-1_all.deb

Hey emrah,

this is apt.conf.d/02proxy:

Acquire::http::proxy “http:// user: pass @my. proxy. de:8080/”;
Acquire::https::proxy “http:// user: pass @my. proxy. de:8080/”;

(without blancs)

Downloads and installation from archive.ubuntu.com works fine with that configuration.

There is no output from curl and wget show connection refused but only from jitsi. All other domains wich i test works.

It seems that your network has a limited access to Internet. Your system admin can solve this.
needed some rules on the proxy server