Not able to build app in release mode with flutter after adding jitsi_meet in dependency in my existing project

I am getting this error when i try to build the app in release mode(android)

C:\Users\aniru.gradle\caches\transforms-2\files-2.1\2c2c6022183245c56e727e343d054c2a\jetified-react-native-0.61.5-jitsi.2-runtime.jar: R8: Type com.facebook.react.uimanager.events.RCTEventEmitter is defined multiple times: C:\Users\aniru.gradle\caches\transforms-2\files-2.1\2c2c6022183245c56e727e343d054c2a\jetified-react-native-0.61.5-jitsi.2-runtime.jar:com/facebook/react/uimanager/events/RCTEventEmitter.class, G:\subcodevs\postfit_app\build\stripe_android\intermediates\runtime_library_classes_jar\release\classes.jar:com/facebook/react/uimanager/events/RCTEventEmitter.class

FAILURE: Build failed with an exception.

  • What went wrong:
    Execution failed for task ‘:app:minifyReleaseWithR8’.

com.android.tools.r8.CompilationFailedException: Compilation failed to complete, origin: C:\Users\aniru.gradle\caches\transforms-2\files-2.1\2c2c6022183245c56e727e343d054c2a\jetified-react-native-0.61.5-jitsi.2-runtime.jar:com/facebook/react/uimanager/events/RCTEventEmitter.class

I have never seen this error, but we also never build on Windows…

Can you try updating the SDK to the latest version? You seem to be using an old release.

Thanks for the reply.
I have installed the latest one available.
jitsi_meet: ^4.0.0

Ah sorry, I had missed the fact that you are using Flutter.

We don’t maintain the Flutter package, you should ask the maintainer instead.

Oh.
No problem.
Thank you