Noob question: URL shows PLESK Admin Interface instead of jitsi.org

Hi all,

it’s my first Ubuntu server and first project, so I ordered a small VServer with PLESK.

Going to the command line, I installed jitsi from the following instructions:
https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md til
apt-get -y install jitsi-meet
and didn’t receive any error messages.

Before I added
127.0.0.1 jitsi.example.org (–> example(.)org == my own domain)
to the sources list and typed in the URL during installation.

But when I go to jitsi.example.org, I just receive the login prompt from my PLESK.

At that point I’m not sure how to continue? Any ideas?

Regards,
Toni

You need to fix your web config.

Confused, but on a higher level. :roll_eyes: :grimacing:

I’m not afraid of reading or google and this might seem absolutely dump to you, but which web config do you mean?

Try to get an environment where you can access the OS of your server on a command line level and not on a plesk level. You will want to edit all kinds of configuration files. Plesk is a too simple tool for this kind of work, in my opinion.

I can fully access the OS of my server on a command line level. If possible, I just wouldn’t like to uninstall PLESK.

The jitsi-meet quick-install checks if you have an nginx, and if you have, it modifies the nginx files, if not, ot proceeds to check for an apache, and if not it then installs its own webserver. This process is a bit fragile. Plesk also has a similar mechanism, which ensures that after an install you will find the plesk ui at the specific url. Probably the web server configuration the jitsi-meet installer found was a bit different than expected and so the installation went wrong. Probably the nginx or apache config has been patched in some way that it serves plesk instead of jitsi-meet.

I had a similar situation on one of my machines and the problem sounds familiar. :slight_smile:

I suggest as follows: Remove jitsi-meet again using the command line (they have an apt-get remove/purge kind of command line somewhere in their instructions). Then shutdown you webserver using service or systemd commands. Then completely deinstall the webservers using apt-get purge/remove commands. Make sure that the /etc/nginx or /etc/apache2 directories are gone to ensure you have a clean environment. Then manually install nginx using apt-get or similar. nginx is a bit more robust than apache, so use nginx. Then manually check that the webserver is runnign. Then manually quick-install jitsi-meet again and make sure you check and react on all error and warning messages this might throw up. Then manually check the nginx configuration and site-enabled files. Now it probably will work.

1 Like

@cleclap: I am facing the very same problem. Your solution seems to imply that Plesk will not work anymore, right?

I got it to work. Basically you have to manually configure nginx and tell Plesk where to find the web pages.

You have to copy the jitsi-meet directory that’s under /usr/share/ in your vhost directory. You need to tell Plesk that your home directory is the jitsi-meet folder because plesk doesn’t allow you to choose a subfolder that’s not in the vhost folder. So, after you copied the directory, you can set it as your home directory in Plesk under your domain, “Hosting Settings” -> “Document Root”. Also check “SSL/TLS support”, “Permanent SEO-safe 301 redirect from HTTP to HTTPS” and “SSI Support”.

Then you have to open the default nginx configuration that comes with jitsi-meet under /usr/share/jitsi-meet-web-config/jitsi-meet.example and paste and copy part of it in plesk under your domain “Apache and nginx settings” -> “Additional nginx directives”. I started copying from

# ssi on with javascript for multidomain variables in config.js
ssi on;
ssi_types application/x-javascript application/javascript;

up to

# websockets for subdomains
location ~ ^/([^/?&:'"]+)/xmpp-websocket {
	set $subdomain "$1.";
	set $subdir "$1/";
	set $prefix "$1";

	rewrite ^/(.*)$ /xmpp-websocket;
}

included.
You have to replace jitsi-meet.example.com with your domain. You also need to create the certificate with LetsEncrypt, that’s built in Plesk.

2 Likes

Dude, you are the MVP.
I’ve been struggling with this installation for a while now without any luck. There is no guide for this anywhere and I think that it would be nice to put ti somewhere in the documentation because this will happen to anybody using a plesk (ubuntu 18 in my case)

Thanks!

2 Likes

Hi I am trying to do this install Jitsi on my ubuntu server with Plesk. Can you do this for me? I will pay you. Also would it be best to install on a sub domain? My server is a dedicated server on Hetzner with Ubuntu and Plesk. What would be the best optimum pre configuration . I have several other domains hosted on plesk and do not want to interfere with them. My dedicat4ed server host name is same as my domain name hoot.ooo . Should I install jitsi on hoot.ooo or a subdomain or create another domain seperate from my computer host name? I want this to work without causing pain and problems in future. I need a stable install working . Can you help?

Where I have to replace jitsi-meet.example.com with my domain? I have followed all the steps except that, but when I access the domain the jitsi page is shown in black.

Everywhere in /etc/nginx/*, /etc/prosody/*, /etc/jitsi/*
In fact the install script of the packages asks you for the domain and if you enter it there correctly, it should be all ok, it will do the replacements for you.

During the installation I indicated the subdomain and the files in the directories that you indicate have the name of the subdomain, but the screen appears in gray when accessing the url. You know why?