No video or audio on iOS app

Hi all,

We setup a jitsi-meet server on aws with latest source and it is working flawlessly on browsers. Now we want to compile mobile apps for both android and ios. We successfully compiled Android app and run on simulator. But compiled ios app from recent source connects to session but cannot send or receive any video or audio. Please see attached images for reference. We tried this on meet.jit.si to eliminate any server side configuration issues. So we just downloaded the jitsi-meet’s recent repo (commit e0563a7). Did all steps for compiling in ios mentioned in the guide and just changed the signing team info and bundle identifier. We tested this on a iOS 13 iPhoneX device and several simulators but it is all same. We are compiling this on macOS Catalina Version 10.15.4 with Xcode Version 11.4. iPhone X os version is 13.3.

Any help would be appreciated

Same issue. Chrome browser works on android and PC but android and iOS apps won’t stay connected to our server. Can open multiple tabs of chrome with no issues. Using nginx and the bundled turnserver to only allow 80 and 443 through our firewall. Mobile apps show connected icon for a few seconds then go connection lost BUT they still show connected and mute icons appear for video and audio if they are pressed in the mobile app. You can see these appear/disappear in the chrome tabs meeting. Something with the turn isn’t being liked by mobile apps. SSL chain should be fine as it’s all setup with let’s encrypt by the install scripts when installing jitsi meet.

Same problem for us. No audio/video in jitsi-meet app iPAD12 while with browsers it works perfectly.

It is working only :

  • in p2p mode
  • on iPAD12 (and not on iOS even if same jitsi build)
  • config server: https://myjitsiserver
  • room : jitsi-meet/myroomname

On Android and iOS you get an immediate deconnection

Same problem here. Jitsi-meet version 2.0.4548-1

Only issues with iOS…

Please do a test in p2p (2 participants) and with videobridge (3 or more participants), you could get differents results

We have a strange issue of audio video. Our browser meeting are 100% fine everytime. On Andriod and iOS, only sometimes, we dont get video / audio on the conference, however on click on either mic/video button, everything becomes normal and participant starts listening and seeing other participants.

Another strange behaviour is while a participant is not able to listen and view anyone, if some particpant leaves / joins the conference, on its notification, everything becomes normal at participant side and he is able to listen / view.

Can anyone share , why its happening ?

@damencho could you please respond to this. Thank you .

I am having the same issue as well. The jitis on my browser and android is working really fine. But on iOS to iOS and iOS to Android and iOS to the web, there are mic and video off issue.

/**
     * Specify custom URL for downloading android mobile app.
     */
     MOBILE_DOWNLOAD_LINK_ANDROID: 'https://play.google.com/store/apps/details?id=net.hind.android',

    /**
     * Specify URL for downloading ios mobile app.
     */
    MOBILE_DOWNLOAD_LINK_IOS: 'https://apps.apple.com/us/app/hind/id1515297954',

    /**
     * Specify mobile app scheme for opening the app from the mobile browser.
     */
    APP_SCHEME: 'net.hind.ios',

    /**
     * Specify the Android app package name.
     */
    ANDROID_APP_PACKAGE: 'net.hind.android',

    /**

This is my config file. any help would be appreciated. @damencho @saghul
Regards

1 Like

I don’t know what the issue could be. I just tested our last beta build, which got build yesterday off master, works no problem.

@saghul Thank you for your response.

I have checked in latest source today, facing same video and audio muted for iOS users. All other platform working fine Android to Web and Web to Android.

Latest jitsi source get from https://github.com/jitsi/jitsi-meet

I have created a meeting in web and joined using iOS application. Video is muted in both ends, this will happen only when an ios users is join a meeting.

Sharing screen shots please check.

I was stuck in this issue last 2 week. I have checked the same scenario in different versions, but same result.

I have tried in framework provided by Jitsi https://github.com/jitsi/jitsi-meet-sdk-samples, its working fine in iOS too.

We have some customisation in Jisti meet application, thats why we are using Jitsi Meet main project.

2 Likes

5 days later and my (tech illilterate) friend on an iPhone has just installed and encountered the same problem via meet.jit.si : cannot transmit audio or video but can see (and hear?) me. Like @saghul , he has no microphone or video icon options (like @emrekoc had) to click.

This does not give me confidence in Jitsi if iPhone users are locked out for more than two weeks due to a bug.

When he installed he declined to giving calendar permission but was not subsequently asked for video or mic permission. I asked him to look in the settings to enable video or mic but it does not seem he has those options.

Hello,
Same here for desktop, laptop as well as tablet iOS (Mac).
Is this the same problem? Tried (nearly) everything.
Only functioning after new installation (ubuntu 18.04 as well as Debian 10) + restart of prosody, jicofo, videobridge. Second time restart jicofo error (so in fact not functioning).
Would be quite a pity if you can’t combine jitsi with iOS - would make it useless.
However: functioning okay via meet.jit.si - what is the difference? Should be quite easy to solve, I guess. But nowhere a relevant answer/help.

have a look to this issue just in case : https://github.com/jitsi/jitsi-meet/issues/6520

Thanks.
Checked with new installation (ubuntu 18.04, nginx), installed via digital ocean instructions (seems better than quick install handbook, which I used a few times). No NAT - so advanced section handbook not necessary (has been checked a few times already without success).
Now test with windows desktop and android phone.
Same problem: participant (fellow jitster) no video and no audio. Chat contact functions okay - so the connection functions. So iOS is not the problem.
Thanks for the link, but I’m afraid this does not solve my problem (?). Pity.
I made a mistake (?) or a bug (?) somewhere in jicofo. Where?
Fokko

Me again.
All a bit urgent, since I would like to include jitsi in a ‘blended approach’ in EU teacher in-service training programme (Erasmus), as part of europeantrainingproviders.eu. Hot issue. At the moment we use meet.jit.si (server). This is okay (as the many other existing instances), but we would like to promote the 'open source alternative’ (and also train teachers this way). This would strongly spread the programme in the EU educational field. Of course only possible if we can make this function.
Fokko

I think you’ll get a faster response on github, either leave a comment in https://github.com/jitsi/jitsi-meet/issues/6520 and I’ll reopen it or just open a new issue. Optimally with logs, so faster support can be provideed.

Hello again,

Many thanks for your attention!Problem had been solved already.

Solution found in:
https://community.jitsi.org/t/proposal-fix-connection-issues-with-unable-to-create-new-native-thread-in-jicofo-log/59639
(after identifying the ‘problem’ in the jicofo log).

I may be mistaken, but think the ‘advice’ in the ‘Advanced configuration’ in the quick install guide is confusing or simply wrong.
I had a completely clean installation (Ubuntu 18.04 - no nginx, no apache2)
Then followed the procedure in the install guide and, later, digital ocean.
So no NAT and no proxy.
Nevertheless followed the tricks in the advanced configuration. No success.

Finally:
New installation Ubuntu 18.04 (without plesk)
New installation Jitsi
Test

Completely cleaning jicofo log (via: echo > /var/log/jitsi/jicofo.log) - (so you are not confused by the endless log text)
New test.
check jicofo log: result: 'Health check failed - too many files open’ (or something like this)
then: systemctl edit jicofo.service (see link above)
and fill in this (new) file with:

[Service] # more threads for this process TasksMax=65000 # allow more open files for this process LimitNPROC=65000 LimitNOFILE=65000

And …. the miracle happens: functions okay.
I afterwards checked the file /etc/systemd/system.conf (according to ‘advanced configuration’)
has not been changed (of course).

Jitsi is a fantastic tool/programme. Deep respect for and gratitude to the creators/developers. Really hope this will be used and installed generally (and we will promote this in EU teacher training https://europeantrainingproviders.eu/meet.php).
So I hope this contribution with help a few people (to avoid my weeks long frustration failing to make this function).

Only thing left: I have the impression that the regular iOS safari browser (in mac mini and mac laptop) has a problem with the video function. App in the iPad tablet is functioning okay. Will check this later again.

Thanks again,
Fokko

1 Like

Hello,

I want to use with Android and iOS. For use on the browser can work well. Can someone recommend

https://jitsisan.mine.bz/777

@Fokko I’m facing a simular issue. Our app was based on a jitsi meet stable branch from January, but after upgrading to master branch last week (react native) it stopped working.

@saghul Do you connect over BOSH or by WebSocket connection? I wonder if latest releases still supports connection by BOSH. Also, which commit/tag would you consider to be the lastest stable for mobile apps? It looks like you keep updating your web version from master but apps on stores are compiled with another branch

Thanks!

I found a solution in
Proposal: Fix connection issues with "unable to create new native thread" in jicofo.log
Also see my earlier post on this issue.