No video no sound transmit in jitsi

Hi, I am really confused: Jitsi-Meet is fresh installed on own ubuntu server. In a first test it runs really nice: on ipad and iphone with Jitsi-App and on MS-Windows 10 via Opera browser. The second test with another two participants via MS-Windows with Chrome, Opera and Edge resulted with this: no video and no sound of and between the participants (login etc. did function). Only a the windows with the first letter of their names in the middle appeared. The participants permitted camera and microphone in browser and in windows system settings (they could see their own video). Jitsi gave the info “Teilnehmer hat die Kamera angehalten” (german → participant did stop the camera) and the same for micro - allthough they did not. What is the solution? Thank’s a lot for your advice

Most probably you were testing in p2p mode and when you added a third participant you started testing the link to the videobridge, which apparently is not properly configures. You need to forward port 10000 udp to the videobridge and make sure no firewall is blocking that. For more information look at https://jitsi.org/qi in the advanced section.

The “no vid, no sound” result did happen with one participant (p2p) - we just added the third to analyse …

The firewall setting for port 10000 udp is: ALLOW IN anywhere

Is your videobridge on a machine with public address? Or it is behind nat?

Well - the configuration is this: the ubuntu-jitsi server (DELL-Hardware) is connected to the web via Fritzbox. The Fritzbox can be reached via an url with dyndns (refreshed by the Fritzbox dyndns-function). On the Fritzbox port 443 is open for TCP.

I found that there could be a conflict between https access and Video/Audio-connection of the videobridge that use both port 443. So I am trying the following changes:

  • enable the tcp function of videobridge ( set “org.jitsi.videobridge.DISABLE_TCP_HARVESTER=false” in `"/etc/jitsi/videobridge/sip-communicator.properties")

  • Set the TCP_HARVESTER_PORT=4443

  • open another port 443 n Fritzbox type udp

-open https port 4443 for tcp

-open port 4443 for tcp in ufw

I really don’t have any idea … What do you think? Is it worth to try another test in this way tomorrow? `

It is not recommended to use the tcp from jvb. Just forward port udp 10000 to jvb. And restart jvb on every ip change.

Okay: Now it runs perfectly. First I tried (allthough it isn’t recommended) with tcp port 4443 and (Set the TCP_HARVESTER_PORT=4443). This did NOT function. After that all settings were revoced and only in the Fritzbox port 10000 was set for udp (with http port 80 and https for 443). And then: It runs!!! (Tested with 3 participants). Thanks a lot for your advice :slight_smile: :+1: