No video in Jitsi Meet

Hello,

First I’d like to say I’m a big fan of the Jitsi software. Being able to self-host an entire videoconferencing solution is just great!

I do however run into some troubles. When I go to https://meet.jit.si/ and join a chatroom everything is working just fine. Both my camera and audio are working just fine (except for constant 100% cpu, but that is an issue I should address in another topic I suppose).

I have a Synology DS918+ on which I have installed ‘Virtual Machine Manager’ and is therefore now acting as a hypervisor. I have installed a Debian virtual machine on it. On that Debian virtual machine I have installed Jitsi Meet using the instructions for Debian from the Jitsi website.

When I go to the webpage (in Chrome), the Jitsi page shows up just fine. The little light of my camera is activated right away. When I go to the Jitsi device settings, I can see the webcam image is working. Audio is recognized as well.

But I have no video/audio when actually using it, so I cannot see myself / cannot activate the camera.
After a while, I get a message saying that the network connection is lost and it will reconnect in 30 seconds or so.

I have tried getting my laptop on the exact same network as the Jitsi server. I guess that rules out this has to do with network settings.

If anyone has an idea to share on how to fix this I would appreciate it.

Have you followed the https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md#advanced-configuration bit?

Dear Neil_Brown.
I have exactly the same problem, but slightly different environment.
Jitsi was installed in a VM in VirtualBox running on Win10Pro (VM (bridged mode not NATed) is Debian 10, 6GB, 40GB HD, no firewall).
Name of machine in VM is “Debian01”. I can ping Debian01 from all other devices in my LAN succesfully, so it should not be a matter of connectivity or Firewall.
I can connect to //debian01, then create a conference room, enter that but then there is no video or sound.
Selecting the devices in setup on the main window of Jitsi shows the picture of my webcam (tried several Lenovo laptops succesfully). A test with http://meet.jit.si/ was succesful, means webcam and sound was working properly.
Your solution was targeting to a Jitsi Installation behind NAT, so what are steps without NAT? Where can I look at?
Thank you (and everybody else) for enlightening me.
It is really !! a wonderful piece of software once it works.

Happy Easter!

Is your whole network behind NAT? Or does your Windows 10 machine have a public IP address?

The Network is behind a NAT (FritzBox as router). Does it make a difference? The Jitsi server and all clients are within the LAN, no access from outside required (as far as I’m concerned).
Server and clients are all in the same segment 192.168.178.x

I’d treat that as a NAT’d installation (and you’ll need to forward ports to get a Let’s Encrypt certificate set up).

As per install instructions quick-install.md the certificate is optional (ok, recommended, but still optional).
Why would connection to the Internet be required, if all participants are within the LAN?
I followed #Advanced-configuration but did not forward ports 443, 4443, 10000.
After forwarding the ports now, nothing changed; still meeting page can be accessed, I can create or join a meeting, select my devices in the configuration panel of the initial webpage (see the webcam picture, hear the testsound) but in the meeting there is neither video nor sound and the connection is broken after ~30-35 seconds and re-initiated automatically just to disconnect again after ~ 30 seconds.

I just took a look at the services overview in Webmin, which I use to handle “Debian01”. It tells me:
jitsi-videobridge2 = running = unknown
jitsi-videobridge2.service = running = no
same with
prosody
prosody.service

I think the instructions say that an LE cert is optional - you could use a self-signed one, if you don’t mind everyone having to add an exception in their browser, and as along as you don’t want anyone to use the iOS or Android apps (which don’t work with self-signed certs).

As far as I know, WebRTC in the browser requires TLS.

Thank you for your patience!

I edited my last answer, Maybe you did not see that:
I just took a look at the services overview in Webmin, which I use to handle “Debian01”. It tells me:
jitsi-videobridge2 = running = unknown
jitsi-videobridge2.service = running = no
same with
prosody
prosody.service

I’m coming from the Windows world, having only few experience on Linux, but I would guess, this is not how it should be. How could I get these services running, supposed this could be the, or part of the, problem?

Try:

service jitsi-videobridge2 start

and then:

service jitsi-videobridge2 status

If it doesn’t start, that should be helpful in working out why.

jitsi-videobridge2.service - Jitsi Videobridge
Loaded: loaded (/lib/systemd/system/jitsi-videobridge2.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Sun 2020-04-12 18:57:03 CEST; 11s ago
Process: 19852 ExecStart=/bin/bash -c exec /usr/share/jitsi-videobridge/jvb.sh --host=$${JVB_HOST:-localhost} --domain={JVB_HOSTNAME} --port={JVB_PORT} --secret={JVB_SECRET} {JVB_OPTS} < /dev/null >> ${LOGFILE} 2>&1 (code=exited, status=1/FAILURE)
Process: 19853 ExecStartPost=/bin/bash -c echo $MAINPID > /var/run/jitsi-videobridge/jitsi-videobridge.pid (code=exited, status=0/SUCCESS)
Main PID: 19852 (code=exited, status=1/FAILURE)

Apr 12 18:57:03 debian01 systemd[1]: Starting Jitsi Videobridge…
Apr 12 18:57:03 debian01 systemd[1]: Started Jitsi Videobridge.
Apr 12 18:57:03 debian01 systemd[1]: jitsi-videobridge2.service: Main process exited, code=exited, status=1/FAILURE
Apr 12 18:57:03 debian01 systemd[1]: jitsi-videobridge2.service: Failed with result ‘exit-code’.

Thank you for your reply. I immediately did the suggested part of the configuration (which I indeed didn’t do) but unfortunately that didn’t change anything.

Suppenkaschperle, you elaborated my thoughts about the non-nat situation:
“Why would connection to the Internet be required, if all participants are within the LAN?”
I thought as well that, if I’m on the same network, it shouldn’t matter that it is behind nat. But maybe I should indeed treat this problem it as if it were a NAT problem.

I am going to do my entire installation of Jitsi Meet again, just to make sure I did the installation properly according to installation instructions…

Same problem here. I have tried Debian 10.3 “BUSTER” 3 times … with apache2 … same symptoms of:

  • Both my camera and audio are working just fine

  • When I go to the webpage (in Chrome), the Jitsi page shows up just fine. The little light of my camera is activated right away. When I go to the Jitsi device settings, I can see the webcam image is working. Audio is recognized as well.

  • But I have no video/audio when actually using it, so I cannot see myself / cannot activate the camera. After a while, I get a message saying that the network connection is lost and it will reconnect in 30 seconds or so.

I read on line that BUSTER has too new a version of JRE. So, I tried Ubuntu 18.04 headless LTS.

Exact same problem.

Followed all the advice above. No joy.

Added: org.jitsi.jicofo.ALWAYS _TRUST_MODE_ENABLED=true … to /etc/jitsi/jicofo/sip-communicator.properties …

Still no joy.

I’m using nginix.

Did anything change / does it work now after you have redone the installation?

i have same issue with this error status jitsi.videobridge2.service

● jitsi-videobridge2.service - Jitsi Videobridge
Loaded: loaded (/lib/systemd/system/jitsi-videobridge2.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Wed 2020-04-22 15:48:18 WIB; 3min 50s ago
Process: 894 ExecStartPost=/bin/bash -c echo $MAINPID > /var/run/jitsi-videobridge/jitsi-videobridge.pid (code=exited, status=0/SUCCESS)
Process: 893 ExecStart=/bin/bash -c exec /usr/share/jitsi-videobridge/jvb.sh --host=$${JVB_HOST:-localhost} --domain={JVB_HOSTNAME} --port={JVB_PORT} --secret={JVB_SECRET} {JVB_OPTS} < /dev/null >> ${LOGFILE} 2>&1 (code=exited, status=1/FAILURE)
Main PID: 893 (code=exited, status=1/FAILURE)

Me too… Any solution?

I have the same problem here, (no camera, connection goes down after ~30s, and restarts).
The videobridge seems to be running ok, however.

jitsi-videobridge2.service - Jitsi Videobridge
Loaded: loaded (/lib/systemd/system/jitsi-videobridge2.service; enabled; v>
Active: active (running) since Thu 2020-04-30 18:31:01 CEST; 7min ago
Process: 765 ExecStartPost=/bin/bash -c echo $MAINPID > /var/run/jitsi-vide>
Main PID: 764 (java)
Tasks: 43 (limit: 65000)
Memory: 240.5M
CGroup: /system.slice/jitsi-videobridge2.service
└─764 java -Xmx3072m -XX:+UseConcMarkSweepGC -XX:+HeapDumpOnOutOfM>
apr 30 18:31:01 jitsi systemd[1]: Starting Jitsi Videobridge…
apr 30 18:31:01 jitsi systemd[1]: Started Jitsi Videobridge.

Running on Ubuntu 20.04 LTS (fresh install)
I would love to get Jitsi up and running…
I’m also no linux expert

any update or solution related to this issue?

I have done my installation again and this part is working now. It probably had something to do with the domain/host-name I used during installation and when navigating to it in the browser.

I have now properly used my external domain name, with an SSL certificate I bought some time ago, and at least I can see my webcam-video now.

However, I must say that I’m running into other problems now. The biggest problem is that after about 20 seconds, I get a message about reconnecting. It just keeps and keeps getting disconnecting / reconnecting. Another issue i’m facing is that video only works when connecting from outside of my network. So from the internal network I can’t get a connection.