No Video, http-bind service unavailable

Hi there,

I installed jitsi-meet from scratch and set the domain meet.[mydomain].com, then I switched to letsencrypt for certification. Everything seams alright so far.

Now, when I start a new conference, I have neither video nor audio. Connecting via iOS App shows the same result. Any idea?

I’m unsure where to find the error logs to post. Error console in Chrome says:

2020-04-12T20:47:53.300Z [features/analytics] Error: No analytics handlers created!

POST https://meet.[mydomain].com/http-bind?room=123 503 (Service Unavailable)

2020-04-12T20:47:54.281Z [JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>: UnhandledError: null Script: null Line: null Column: null StackTrace: Error: Strophe: request id 1.1 error 503 happened
at Object.i.Strophe.log (VM411 lib-jitsi-meet.min.js:17)
at Object.error (VM411 lib-jitsi-meet.min.js:1)
at I.Bosh._onRequestStateChange (VM411 lib-jitsi-meet.min.js:1)

Check your nginx config whether it has the correct setting for http-bind and check and prosody logs for errors.

Hey! Thank you for the instant reply. Can you give me a hint, where to find the logs and what to look for?

BTW I’m using apache2, not nginx, would that be a difference?

Guido

Does your config looks like: https://github.com/jitsi/jitsi-meet/blob/master/doc/debian/jitsi-meet/jitsi-meet.example-apache#L45
Prosody logs are in /var/log/prosody

Sorry to keep you waiting. I tried a lot myself, but to no avail.

#1
yes, my apache config at /etc/apache2/sites-available/video.[mydomain].com.conf looks the same.

#2
/var/log/prosody is an empty directory.

#3
I have a website on the same server, that is configured as default (letsencrypt is done using certbot). Would that be a possible issue?
Also, I noticed, that every time I run the letsencrypt install script, it kind of messes up my website configuration.

Hope you have an idea!