No video/audio when more than 2 users join the call

For 2 users, the video and audio seems to work. But when a third user joins, audio and video of every user is no longer available. Chat works but video/audio do not.

We are running Jitsi as an aws ECS service behind a load balancer (internet facing). The image (docker) version used: 7648-4. We have tried multiple things but nothing seems to work like

  • Mapped public url to [https://example.dev.com] and tried

  • Tried setting DOCKER_HOST_ADDRESS to (public url endpoint/ ALB DNS)

The server id property remains empty string in the /config/jvb.conf.
websockets {
enabled = true
domain = appDomain
tls = true
server-id = “”
}

Any ideas on how to fix this?

In the security group open port udp 10000.

This is under network bindings for jvb in ec2

I see inbound.

We are allowing udp 10000 from private subnets. Also, we added a rule to allow traffic on port 4443 between the private subnets. All traffic from alb is allowed to backed ec2 (containers)

Are you sure that alb works with UDP?

You can stop jvb and use nc as server and do nc as client from internet to check that udp reaches jvb machine on port 10000.

I will check this out. Thanks.

We found out that even though the udp port was open, when ec2 is in private subnet, it is not able to connect. We had to rebuild the ec2 instances in the public subnet. Only then the multi user scenario worked. Thanks.