No valid OpenPGP data found

Hello,
Sorry if a little rudimentary but I’m trying to install Jitsi on a new Ubuntu 18.04 install running inside VirtualBox. For some reason I am unable to parse the repository which I think starts with the issues I’m having with the PGP keys.

Following the directions adding the repository seem to complete ok. When I run as root:
wget -qO - https://download.jitsi.org/jitsi-key.gpg.key | apt-key add -
I get the following error: "gpg: no valid OpenPGP data found.

When I download the key and add it as a separate command it seems to complete successfully. But then when I try to update ‘apt’ I get:
“Could not handshake: Error in the pull function. [IP: 130.79.200.22 443]

E: The repository ‘https://download.jitsi.org stable/ Release’ does not have a Release file.”

Does anyone know how to resolve this?

I just created a VM in DO Ubuntu 18.04.2, tested it and it works just fine. That is strange, I can even open the release file from my PC: https://download.jitsi.org/stable/Release.
Is it possible that transferring commands from your clipboard to the virtualbox VM is modifying the commands, just a wild guess?
Are you ssh-ing to the VM?

I’m not using the clipboard; been fat fingering it. Also, no SSH’ing, just console as VM is running on my desktop.

Weird that is just worked for you. I was also thinking that is could be a firewall/filter issue but I’m able to open those just fine. Here’s what I’ve been using to add to the repository:

sudo sh -c “echo ‘deb https://download.jitsi.org stable/’ > /etc/apt/sources.list.d/jitsi-stable.list”

damencho, thanks for your help. I tried this at home and is worked perfectly. I exported the appliance and brought it with me to work to try it and it failed. I think it’s something we are blocking on the network.

Thanks again.