No sound unless restarted

We have our own jitsi installation, which is on a private server that is linked via dyndns to the internet.
It works, but only after I restart the services.
If they are running for a while there is no sound, so people can’t talk and hear the others.
I restart with:
systemctl restart prosody
systemctl restart jicofo
systemctl restart jitsi-videobridge2
our adress is: https://meet.berfin.eu
I can support any needed information…
Thomas

You may need to restart the JVB every time your IP address changes, that might be the root cause. We don’t really support dynamic public IPs out of the box.

If you know that your address only changes outside of normal usage hours, you can try to set this in jvb.conf (not in the videobridge section, it should be added after it)

ice4j {
  harvest {
     mapping {
        aws {
          enabled = false
        } 
        static-mappings = [
           {
             local-address = "xx.xx.xx.xx"
             public-address = "meet.berfin.eu"
           }
        ]
     }
  }
}

Thank you, with the changed IP makes sense. I scheduled a restart at 5am, so the service restart after the system gets a new IP address.
I also added the section in jvb.conf.
Lets see what happens tomorrow
Thanks you guys so far!
Thomas

1 Like