No sound no video with web browser (work with android app)

Hello,

I’m looking for installing jitsi-meet on a raspberry pi (debian 10) behind nat.
I’ve followed this tutorial : https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md
It’s work fine when user using android application are connected to the room. But when one people use a web browser (firefox), the sound and video are lost (all people stay connected).

/var/log/jitsi/jvb.log :
2020-04-12 12:30:03.330 INFO: [16] Videobridge.createConference#326: create_conf, id=a645c23620282dee gid=null logging=false
2020-04-12 12:30:03.342 SEVERE: [16] RecurringRunnableExecutor.run#230: The invocation of the method org.jitsi.videobridge.health.Health.run() threw an exception.
java.lang.NoClassDefFoundError: Could not initialize class org.jitsi.videobridge.sctp.SctpManager
at org.jitsi.videobridge.Endpoint.createSctpConnection(Endpoint.java:758)
at org.jitsi.videobridge.health.Health.check(Health.java:93)
at org.jitsi.videobridge.health.Health.doCheck(Health.java:161)
at org.jitsi.videobridge.health.Health.doRun(Health.java:266)
at org.jitsi.utils.concurrent.PeriodicRunnableWithObject.run(PeriodicRunnableWithObject.java:87)
at org.jitsi.utils.concurrent.RecurringRunnableExecutor.run(RecurringRunnableExecutor.java:216)
at org.jitsi.utils.concurrent.RecurringRunnableExecutor.runInThread(RecurringRunnableExecutor.java:292)
at org.jitsi.utils.concurrent.RecurringRunnableExecutor.access$000(RecurringRunnableExecutor.java:36)
at org.jitsi.utils.concurrent.RecurringRunnableExecutor$1.run(RecurringRunnableExecutor.java:328)

Thank you

Regards

Dam35

I think, it is very similar to the problem here : More than 2 participants, more than 1 Firefox = all muted
With chromium, it is working fine when two people are connected (use p2p I think). But one more people, and all are muted with black screen.
I will check that port 10000 udp is opened.

Guys, my Virtual Server provider fixed this problem:

“The /tmp filesystem must not be mounted with the noexec attribute.”

He found the error in this log: /var/log/jitsi/jvb.log

Hope it helps you!

S

Ok thank you very much for your feedback.
I’ve checked the mount of the /tmp directory :
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime,lazytime,size=1048576k)
But I have not noexec attribute.

and the size :
root@jitsi:~# df -h /tmp
Filesystem Size Used Avail Use% Mounted on
tmpfs 1.0G 68K 1.0G 1% /tmp

I’ve checked netcat on my local network with jitsi stopped :
nc -u -l -p 10000 on my raspberry
nc -u FQDN 10000 on my computer
I can send/received udp packets.
I guess, jitsi shall worked on my local network.

But from external network (with 4G) to my raspberry, this netcat command doesn’t work.

I’ve seen the debug console of firefox, and I have two errors :
2020-04-13T08:30:16.899Z [features/analytics] <te/<>: Error: “No analytics handlers created!”
2020-04-13T08:30:17.804Z [features/base/tracks] <E/</<>: Failed to create local tracks
Array [ “audio”, “video” ]

Dam35

I’ve restart the installation from scratch and I’ve the same problem. I’ve writen each step I’ve done :

Install jitsi from dietpi buster

Note : I guess you’re using a network with DHCP server

Note : You shall enable port on your internet box to the raspberry pi 3 (port tcp 80,443,4443 and udp 10000)

  1. Download dietpi
    wget https://dietpi.com/downloads/images/DietPi_RPi-ARMv6-Buster.7z
  2. Decompress archive
  3. Copy img file to micro sd card (it’s during about 3 minutes, be patient)
    dd if=./DietPi_RPi-ARMv6-Buster.img of=/dev/sdb bs=1M
  4. Insert micro sd card to the raspberry pi 3, connect the ethernet cable and power on (Be patient for the first boot)
  5. Find ip address
    • Install nmap : apt install nmap
    • Scan connected device : nmap -sP 192.168.*.*
      In my case :
      Nmap scan report for 192.168.0.100
      Host is up (-0.12s latency).
      MAC Address: B8:27:EB:XX:XX:XX (Raspberry Pi Foundation)
      
    • Connect ssh : ssh root@192.168.0.100
    • Finalize installation
    • Set ip address to static
  6. Follow instruction installation of jitsi here
    1. Add FQDN to /etc/hosts and /etc/hostname
    2. Add jitsi repository and install jitsi-meet :
      echo 'deb https://download.jitsi.org stable/' >> /etc/apt/sources.list.d/jitsi-stable.list
      wget -qO -  https://download.jitsi.org/jitsi-key.gpg.key | sudo apt-key add -
      # Retrieve the latest package versions across all repositories
      apt-get install apt-transport-https
      # Perform jitsi-meet installation
      apt-get update
      # Perform jitsi-meet installation
      apt-get -y install jitsi-meet
      
    3. Execute /usr/share/jitsi-meet/scripts/install-letsencrypt-cert.sh
    • I obtain an error : Certbot has problem setting up the virtual environment. (bad sha256 for pycparser and zope.component)
    • I install certbot with nginx module : apt install -y python3-certbot-nginx
    • I execute this command: certbot --nginx -d FQDN
    • I enter my address email and accept term condition
    • An other problem : nginx: [emerg] "server_names_hash_bucket_size" directive is duplicate in /etc/nginx/sites-enabled/FQDN.conf:1
    • I comment the line of the file : #server_names_hash_bucket_size 64;
    • I relaunch certbot --nginx -d FQDN and I answer redirect to https
  7. Limit memory use in file /usr/share/jitsi-videobridge/jvb.sh :
    • add VIDEOBRIDGE_MAX_MEMORY=512m
  8. Limit memory use in file /usr/share/jicofo/jicofo.sh :
    • replace -Xmx3072m with -Xmx512m
  9. Restart the service