No screen sharing icon in firefox

Hi guys,

today I installed Jitsi-Meet in docker (quick install way) just to try if screen sharing is possible. Unfortunately I can’t see the screen sharing icon like I see when I go to https://meet.jit.si/.

Reading some of the posts in the forum my understanding is that there is no need for an installation of a browser extension because Chrome and Firefox (don’t know about other browsers) already implemented “getDisplayMedia”.

For Google Chrome an extension is still needed, you need one for your deployment.

So I expected the screen sharing working out of the box.
Btw. I did not execute the let’s encrypt scripts, so when I go to my local jitsi page, I accept the unsinged certificate and proceed to the page. I hope the certificates don’t matter here.
Are there some configurations I have to set to enable screen sharing?
I tried setting “desktopSharingFirefoxDisabled: false,” and calling
./prosody restart &&
./jitsi-videobridge restart &&
./jicofo restart &&
./nginx restart
but that did not help.
Another thing I is that after about 36 seconds a reconnection popup is shown.

You have been disconnected.
You may want to check your network connection. Reconnecting in …

Wondering if this is also a problem (guess that’s because I’m the only person in the conference??)

Thanks.

using:
firefox: 68.5.0
jitsi-meet 1.0.4275-1
jitsi-meet-prosody 1.0.3881-1
jitsi-meet-turnserver 1.0.3881-1
jitsi-meet-web 1.0.3881-1
jitsi-meet-web-config 1.0.3881-1
jitsi-videobridge 1132-1

Tried the stable version but still there is no screen sharing (desktop) icon :frowning:
Can someone tell me what has to be done to make the screen sharing icon/button show up?

So I installed jitsi-meet on a public server (so I can make sure docker is not the problem). Now I can open two firefox windows in private mode and start from one window the conference and join the conference from the other window. I can chat from both windows but screen sharing does not work.

In the firefox console I’ve seen this error (replaced ip address with MYSERVERIPHERE):

2020-04-02T15:18:41.216Z [modules/xmpp/strophe.jingle.js] <value>:  (TIME) received session-initiate:	 179280 Logger.js:154:22
2020-04-02T15:18:41.216Z [modules/xmpp/strophe.jingle.js] <value>:  Marking session from abcvdf34@conference.MYSERVERIPHERE/focus as *not* P2P Logger.js:154:22
2020-04-02T15:18:41.234Z [JitsiMeetJS.js] <getGlobalOnErrorHandler>:  UnhandledError: null Script: null Line: null Column: null StackTrace:  
Exception { name: "NS_ERROR_UNEXPECTED", message: "", result: 2147549183, filename: "https://MYSERVERIPHERE/libs/lib-jitsi-meet.min.js?v=3928", lineNumber: 10, columnNumber: 0, data: null, stack: "k@https://MYSERVERIPHERE/libs/lib-jitsi-meet.min.js?v=3928:10:108130\nvalue@https://MYSERVERIPHERE/libs/lib-jitsi-meet.min.js?v=3928:1:113456\nvalue@https://MYSERVERIPHERE/libs/lib-jitsi-meet.min.js?v=3928:1:204709\nvalue@https://MYSERVERIPHERE/libs/lib-jitsi-meet.min.js?v=3928:10:280910\noe.prototype._acceptJvbIncomingCall@https://MYSERVERIPHERE/libs/lib-jitsi-meet.min.js?v=3928:10:181189\noe.prototype.onIncomingCall@https://MYSERVERIPHERE/libs/lib-jitsi-meet.min.js?v=3928:10:180685\nc.prototype.emit@https://MYSERVERIPHERE/libs/lib-jitsi-meet.min.js?v=3928:1:125831\nvalue@https://MYSERVERIPHERE/libs/lib-jitsi-meet.min.js?v=3928:10:276635\nrun@https://MYSERVERIPHERE/libs/lib-jitsi-meet.min.js?v=3928:1:21579\n_dataRecv/<@https://MYSERVERIPHERE/libs/lib-jitsi-meet.min.js?v=3928:1:30034\nforEachChild@https://MYSERVERIPHERE/libs/lib-jitsi-meet.min.js?v=3928:1:13241\n_dataRecv@https://MYSERVERIPHERE/libs/lib-jitsi-meet.min.js?v=3928:1:29866\n_onRequestStateChange@https://MYSERVERIPHERE/libs/lib-jitsi-meet.min.js?v=3928:1:49867\n" }
Logger.js:154:22

jicofo.log.txt (31.1 KB) jvb.log.txt (29.1 KB) prosody.log.txt (4.3 KB) moderatorFirefoxConsole.txt (25.8 KB)

I compared my config with the one from “https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.md” and here are some things I was wondering about:

/etc/prosody/conf.avail/jitsi.example.com.cfg.lua
=> I don’t have the enty: Component “jitsi-videobridge.jitsi.example.com

nginx config
listen 4444 ssl http2;
listen [::]:4444 ssl http2;
=> shouldn’t that be 443?

=> I have: proxy_set_header Host $http_host;
=> instead of: proxy_set_header Host $host;