No room room lock password for moderators logged in with jwt

I am using jitsi docker with jwt. When I add a password for a room and join again with jwt, it asks for password. Is there any settings disables password for jwt authentication?

Most likely you have encountered the first authorization, then you need to authenticate, there’s a difference. If you remove these security thresholds (provided by the system), you may lose your security guarantees.

1 Like

I’m not sure if this is the approach you are going for but our need was to allow room owners and moderators to bypass the lobby and password with JWT. Use the same principal as the jibri and jicofo whitelist LUA scripts along with token moderation to accomplish it with a custom script. You can pass a custom parameter in your JWT that you can check with LUA and allow the participant in without a password or lobby knocking.

@bababooey Thanks for your advice. Do you have such script written?