No public key for https://download.jitsi.org during install

When going through the steps to install Jitsi on Ubuntu 18.04 I receive an error after adding the repository https://download.jitsi.org stable/.
“The repository ‘https://download.jitsi.org stable/ InRelease’ is not signed.
Updating from such a repository can’t be done securely, and is therefore disabled by default.”

Can anyone point me in the right direction to fix this problem?

This is how to fix it https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md#add-the-repository
Execute the two commands one by one.

Thanks. I found my mistake. I was not putting sudo on my apt-key command. All is well now!