No more than one user at a time

I am trying Jitsi server with the Public IP address so two people can video conference but then the meeting room cannot hold more than one. It crashes and tries to reconnect. Both JVB and Jicofo is explicitly configured with :5347. When I looked in Chrome web logs, I found this

2020-03-22T04:21:58.017Z [JitsiConference.js] <ee._doReplaceTrack>: _doReplaceTrack - no JVB JingleSession

Also, I have set prosody storage to “memory”

Jicofo.log looks like this

Jicofo 2020-03-22 01:45:49.596 SEVERE: [16] org.jitsi.jicofo.discovery.DiscoveryUtil.discoverVersion().200 Failed to discover version, req: <iq to='jitsi-videobridge.<ip-address>' id='qxujp-30' type='get'><query xmlns='jabber:iq:version'></query></iq>, response: <iq to='focus@auth.<ip-address>/focus6381066809469' from='jitsi-videobridge.<ip-address>' id='qxujp-30' type='error'><error type='cancel'><service-unavailable xmlns='urn:ietf:params:xml:ns:xmpp-stanzas'/></error></iq>

@damencho , Good day sir, may i ask if do you have any idea about this ? Failed to discover version of videobridge.

Nope … Which versions do you run? Jicofo and jvb … ?

I only got this message in my logs as SEVERE msg, everything is fine but i don’t know if i need to ignore this in my logs or should i need to do something.

btw, here’s the version
JiCoFo 1.0.1.0-508
JVB 0.1.1126

@damencho, I just follow the instructions from video titled: How to Load Balance Jitsi Meet. then I encountered this SEVERE log msg.

OS: Ubuntu 18

Here’s the log:

Jicofo 2020-03-22 21:01:18.889 SEVERE: [16] org.jitsi.jicofo.discovery.DiscoveryUtil.discoverVersion().200 Failed to discover version, req: <iq to='videobridge2.demo.mydomain.com' id='nhgbS-32' type='get'><query xmlns='jabber:iq:version'></query></iq>, response: <iq to='focus@auth.demo.mydomain.com/focus7722971402360' from='videobridge2.demo.mydomain.com' id='nhgbS-32' type='error'><error type='cancel'><service-unavailable xmlns='urn:ietf:params:xml:ns:xmpp-stanzas'/></error></iq>

Did you follow https://jitsi.org/qi when installing?

I almost got it all, I just missed the /etc/hosts part
wait lemme check it again after putting the 127.0.0.1 with my domain.

Still persist the problem sir :no_mouth:

SEVERE: [16] org.jitsi.jicofo.discovery.DiscoveryUtil.discoverVersion().200 Failed to discover version