No Jitsi when I type in the URL


I’ve installed Jitsi without problem, BUT when I type in the URL I still get the Plesk default page.

I’m also getting the java out of memory error with jicofo and jitsi-videobridge when I run systemctl status (actual message below). I’ve looked at others who’ve had this problem, but I can’t see any solution in the discussions. I mention this problem in case it’s the cause of the first one.

One other bit of information that may be relevant. I thought that I had to install Videobridge to be able to run a server. Having realised my mistake I uninstalled (using --purge), so I would expect this not to be relevant, but I mention it just in case.

I should mention that I haven’t installed an SSL certificate because there is already one extant for the subdomain. Again mentioned in case it’s relevant.

Finally I have 8Gb of memory, (so an out of memory error seems a bit bizarre). I’m using Debian 9 on a PVS

I can’t think of anything else relevant. Any help would of course be deeply appreciated.
Yours desperately :slight_smile:

The actual message is:
│ └─24195 java -Xmx3072m -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=

I am not aware that you can install Jitsi on a VPS that is already configured for something else. Jitsi installs best to a dedicated VPS, using a subdomain on an existing domain name.

What instructions did you use ?

Debian current stable version is 10, not 9 - so that may be part of the problem. Try again using the latest version.

Thanks for the reply. It is a VPS that as yet is not set up for anything else. I have used a subdomain (jitsi.[mydomain]). I’m using Debian 9 because, according to my ISP, Plesk will not work with Debian 10. I’m new to all this so Plesk is a lifeline, I would much prefer not to have to ditch it.

The only thing I’ve done is install the SSL certificate for the subdomain before I installed jitsi. If the SSL cert is already there will Jitsi detect it? Perhaps I should uninstall the SSL (if you can do this) and re-install it after Jitsi has been installed?

If I enter systemctl --failed it states that jitsi-videobridge was not found. And of course I am still getting the out of memory error for Java.

If you don’t have to deal with Plesk, don’t. A quick search on Plesk here shows it’s not trivial.

Start with the simplest scenario, follow the Quick install instructions on a brand-new, vanilla Debian server install. The instructions include SSL setup with LetsEncrypt. This will improve your command-line, basic sysadmin skills. If you have any questions about the Quick install come back here (open a new topic) and try to be specific, including relevant technical details.

Can you share who your provider is ? It would help others find this post and maybe other customers of such SVP have a similar setup.

For example DigitalOcean has a ready-to–go Jitsi install but it requires running on a 4GB VPS, at U$20 /month perhaps too much to spend even for a small office - or worth all the money for someone that can’t spend the time learning self-hosting it. IMO learning how to self-host Jitsi Meet is worth it and can be achieved in a short time (days or hours, not weeks).