No guest login possible

Hello,

I just installed jitsi on my Ubuntu server. I followed the self-hosting instructions including the docs to enable Authentification on secure domain.

Everything works fine so far. I created a user account for me to be a moderator and I can login.

Now I would like to invite my friends as guests, unfortunatly they all see the login screen “authentifcation required”.

I am sure I did setup the guest-domain in the config as described, maybe someone can help me to find out what is wrong?

Best regards,

Philipp

Did you set anonymousdomain in config.js?

Hello Emrah,

yes I did. Here is a copy of my configuration:

var config = {
// Connection
//

hosts: {
    // XMPP domain.
    domain: 'jitsi.XXX-XXX.XX',
    anonymousdomain: 'guest.jitsi.XXX-XXX.XX',

Share your prosody lua file.

Hello Freddie,

this is my prosody lua config:

plugin_paths = { "/usr/share/jitsi-meet/prosody-plugins/" }

-- domain mapper options, must at least have domain base set to use the mapper
muc_mapper_domain_base = "jitsi.xxx-xx.x";

external_service_secret = "xxx";
external_services = {
     { type = "stun", host = "jitsi.xxx-xx.x", port = 3478 },
     { type = "turn", host = "jitsi.xxx-xx.x", port = 3478, transport = "udp", secret = true, ttl = 86400, algorithm = "turn" },
     { type = "turns", host = "jitsi.xxx-xx.x", port = 5349, transport = "tcp", secret = true, ttl = 86400, algorithm = "turn" }
};

cross_domain_bosh = false;
consixr_bosh_secure = true;
-- https_ports = { }; -- Remove this line to prevent listening on port 5284

-- https://ssl-config.mozilla.org/#server=haproxy&version=2.1&config=intermediate&openssl=1.1.0g&guixline=5.4
ssl = {
    protocol = "tlsv1_2+LY1305:DHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES256-GCM-SHA384"
}

unlimited_jids = {
    "focus@auth.jitsi.xxx-xx.x",
    "jvb@auth.jitsi.xxx-xx.x"
}

VirtualHost "jitsi.xxx-xx.x"
    -- enabled = false -- Remove this line to enable this host
    authentication = "internal_hashed"
    -- Properties below are modified by jitsi-meet-tokens package config
    -- and authentication above is switched to "token"
    --app_id="example_app_id"
    --app_secret="example_app_secret"
    -- Assign this host a certificate for TLS, otherwise it would use the one
    -- set in the global section (if any).
    -- Note that old-style SSL on port 5223 only supports one certificate, and will always
    -- use the global one.
    ssl = {
        key = "/etc/prosody/certs/jitsi.xxx-xx.x.key";
        certificate = "/etc/prosody/certs/jitsi.xxx-xx.x.crt";
    }
    av_moxration_component = "avmoxration.jitsi.xxx-xx.x"
    speakerstats_component = "speakerstats.jitsi.xxx-xx.x"
    conference_duration_component = "conferenceduration.jitsi.xxx-xx.x"
    -- we need bosh
    modules_enabled = {
        "bosh";
        "pubsub";
        "ping"; -- Enable mod_ping
        "speakerstats";
        "external_services";
        "conference_duration";
        "muc_lobby_rooms";
        "av_moxration";
    }
    c2s_require_encryption = false
    lobby_muc = "lobby.jitsi.xxx-xx.x"
    main_muc = "conference.jitsi.xxx-xx.x"
    -- muc_lobby_whitelist = { "recorxr.jitsi.xxx-xx.x" } -- Here we can whitelist jibri to enter lobby enabled rooms

VirtualHost "guest.jitsi.xxx-xx.x"
	authentification = "anonymus"
	c2s_require_encryption = false

Component "conference.jitsi.xxx-xx.x" "muc"
    restrict_room_creation = true
    storage = "memory"
    modules_enabled = {
        "muc_meeting_id";
        "muc_domain_mapper";
        "polls";
        --"token_verification";
    }
    admins = { "focus@auth.jitsi.xxx-xx.x" }
    muc_room_locking = false
    muc_room_xfault_public_jids = true

-- internal muc component
Component "internal.auth.jitsi.xxx-xx.x" "muc"
    storage = "memory"
    modules_enabled = {
        "ping";
    }
    admins = { "focus@auth.jitsi.xxx-xx.x", "jvb@auth.jitsi.xxx-xx.x" }
    muc_room_locking = false
    muc_room_xfault_public_jids = true

VirtualHost "auth.jitsi.xxx-xx.x"
    ssl = {
        key = "/etc/prosody/certs/auth.jitsi.xxx-xx.x.key";
        certificate = "/etc/prosody/certs/auth.jitsi.xxx-xx.x.crt";
    }
    modules_enabled = {
        "limits_exception";
    }
    authentication = "internal_hashed"

-- Proxy to jicofo's user JID, so that it doesn't have to register as a component.
Component "focus.jitsi.xxx-xx.x" "client_proxy"
    target_address = "focus@auth.jitsi.xxx-xx.x"

Component "speakerstats.jitsi.xxx-xx.x" "speakerstats_component"
    muc_component = "conference.jitsi.xxx-xx.x"

Component "conferenceduration.jitsi.xxx-xx.x" "conference_duration_component"
    muc_component = "conference.jitsi.xxx-xx.x"

Component "avmoxration.jitsi.xxx-xx.x" "av_moxration_component"
    muc_component = "conference.jitsi.xxx-xx.x"

Component "lobby.jitsi.xxx-xx.x" "muc"
    storage = "memory"
    restrict_room_creation = true
    muc_room_locking = false
    muc_room_xfault_public_jids = true

That should be:

authentication = "anonymous"

1 Like

Yes, you are right… I was blind :woozy_face:

Now I can login as a Guest and my friends too.

Final question, how can I access now as a Moderator using the login credentials?

Currently only Guest login is working…

Quick update were I am at the moment:

  • Disabling guest login allows us to connect as Moderators
  • having Guest login active we cannot login/create meetings as Moderators (Guest users can create meetings as guests but others guests joining the meeting cannot see other participants)
  • Guests can create meetings, thought I did deactivate it with the proper configuration

Any idea what I can do to make Moderators AND Guest login working?

I would like to have a setting where only Moderators can create Meetings and Guests can join without having an account.

Let me know if I should share any config files.