No Connection with Jitsi-Meet app to own server

Hi,
I’ve set up a Jitsi-server and it works well with Chrome-Browser (not with Firefox ;-()
When I try to connect my own server with Jitsi-meet App on Android I’ve got the message
‘Ihre Verbindung ist getrennt worden.Prüfen Sie allenfalls Ihre Netzwerkverbindung Verbinde in x Sekunden.’
If try to make a connection over meet.jit.si it works well? What is going wrong? Have I done a mistake on server config, or it is a bug on jitsi-meet? Thank you very much for help!
Micha

I have the same problem. Own server on debian 10.3. In Chrome in “Desktop Website” on the smartphone it works. In the app it doesnt’t work. On PC in Chrome it works. I read something about the certificate chain. We have a Comodo Certificate which is trusted in Chrome. Thank you for your help.

Regards,
Martin

Check you’ve got a complete fullchain file set up in your web sever config

I tried to chain my certificate but https://whatsmychaincert.com/?meet.zoechling.at says i don’t have a chained certificate. In Apache the configuration is clear to me because files are separated but in nginx i need to merge these two files and this doesn’t work. Maybe you have an advice for me?

Regards
Martin

I’m using nginx with Let’s Encrypt, and the relevant config bit is this:

    ssl_certificate /etc/letsencrypt/live/example.com/fullchain.pem;
    ssl_certificate_key /etc/letsencrypt/live/example.com/privkey.pem;

My configuration now works on all devices. My failure was i tried to setup my config with the commodo certificate i already had but this had a broken chain. With letsencrypt it works perfect! Thanks for your help.

Regards
Martin

1 Like

Now it’s already working when I use the let’s encrypt certificates instead my own certificate with:

sudo /usr/share/jitsi-meet/scripts/install-letsencrypt-cert.sh

After this I have to change the certificates in
sudo nano /etc/nginx/sites-enabled/meet.mywebpage.com.conf

ssl_certificate /etc/letsencrypt/live/meet.mywebpage.com/fullchain.pem;
ssl_certificate_key /etc/letsencrypt/live/meet.mywebpage.com/privkey.pem;

After ‘sudo root’ it works fine.